[Manjaro] Jak zmusić MHWD do zainstalowania starszej wersji video-catalyst?


(MacGregor) #1

Jak w temacie. Potrzebuję zainstalować starszą wersje sterowników do kart AMD i zablokować je przed aktualizacją. Jakieś pomysły jak to zrobić?


(marcin82) #2

Możesz spróbować dodać taki wpis do /etc/pacman.conf, ale wcześniej musisz mieć tą zainstalowaną tą starszą wersję :smiley:

IgnorePkg = NAZWA_PAKIETU

Nie jestem jednak pewny, czy MHWD nie pozwala na instalację starszej wersji właśnie z powodu zależności (xorg, itp.)

Można jeszcze spróbować JEDNEGO z dwóch narzędzi dostępnych w AUR: downgrade, downgrader:

[marcin@arch ~]$ yaourt -Ss downgrade
archlinuxfr/downgrade 5.1.3-1 [installed]
    Bash script for downgrading one or more packages to a version in your cache or the A.R.M.
aur/downgrade 5.1.3-1 [installed] (351)
    Bash script for downgrading one or more packages to a version in your cache or the A.R.M.
aur/downgrader 1.8.0-2 [installed] (135)
    Powerful packages downgrader for Archlinux. Works with libalpm, ARM and pacman logs

(MacGregor) #3

Temat jest w sumie do zakończenia bo Catalyst jednak wykrywa moje oba Radeony ale tylko z poziomu terminala. Co ciekawe kiedy zainstalowałem system nawet tam dedykowana grafika nawet nie istniała. Pewnie aktualizacja kernela zrobiła swoje.

 

Co do twojej rady. Blokować pakiety w pacman.conf umiem, jednak bardziej zależało mi na downgradzie. Pierwszy program nawet nie ma dokumentacji czy pomocy do wyświetlenia więc nie podjąłem się próby testowania na własną rękę. Drugiego nawet nie zainstalowałem bo PKGBULID wypluwa błędy o błędnych sumach kontrolnych. A MHWD owszem, podobno ma taką opcje, jednak ani na wiki ani na forum nie jest wspomniane jak jej użyć.

Nie mniej, dzięki za pomoc :slight_smile: