Manjaro kde, problem z wifi


(cichy.) #1

witam, mógłbym mi ktoś opisać jak zastosować ten fix w manjaro 17.0.2 kde bez dostępu do internetu? https://github.com/pvaret/rtl8192cu-fixes

rozumiem, że np. polecenie “git clone https://github.com/pvaret/rtl8192cu-fixes.git” nie może być w warunkach braku takiego dostępu zrealizowane, ale to mogę pobrać jako zip na innym PC

większy problem mam z pakietami z polecenia “sudo apt-get install git linux-headers-generic build-essential dkms”, nie wiem jak powinienem je zainstalować bez dostępu do sieci


(FadeMind) #2

Manjaro używa Pacmana, > https://wiki.manjaro.org/index.php?title=Pacman_Overview

Jednakże wpierw zapytam: Jaki masz problem z obecnymi w Manjaro binarnymi wersjami sterownika do Wifi? Manjaro w trybie NonFree powinien automatycznie aktywować binarny sterownik i po instalacji go używać. Podaj wyniki poleceń:

inxi -Fxz 
lspci

Z tego co widzę, to fixy dla 3.11 kernel series. Więc stare. Co ten Fix robi ze sterownikiem, jakie ma zastosowanie i czy czasem nie ma binarnej wersji (DKMS) w AUR? Jest dostępny DIFF ze zmianami, aby poinformować Philipa o wymaganych fixach?


(Domker) #3

Ten co wkleiłeś to raczej w systemach Debianowych ma rację bytu.

Spróbuj tego:
https://aur.archlinux.org/packages/8192cu-dkms/

Potrzebujesz jedynie linux-headers i dkms.
Linux headers pobierasz z tego miejsca:
http://manjaro.melbourneitmirror.net/stable/core/x86_64/

linuxYYY-headers-A.BB.CC-D-x86_64.pkg.tar.xz

(gdzie YYY to skrócony numer wersji kernela np. dla 4.11 jest linux411 itd., A BB CC D to pełna wersja kernela - musisz dobrać wersję do swojego kernela)

Dkms znajdziesz tutaj:
http://manjaro.melbourneitmirror.net/stable/extra/x86_64/dkms-2.4.0-2-any.pkg.tar.xz

Obie paczki instalujesz tak:
sudo pacman -U nazwa_paczki nazwa_paczki_numer2
(oczywiście musisz mieć te paczki w katalogu i dostać się do lokalizacji poprzez
cd LOKALIZACKA_katalogu)

Tu masz przeze mnie przerobiony rtl8192cu, żeby lokalnie się kompilował bez klonowania źródełek:

Wypakuj go do /tmp, wejdź do katalogu /tmp/test i otwórz w nim konsole, wpisz:
makepkg -i PKGBUILD
Powinno się bez problemu skompilować - sprawdzałem.
EDIT: Jeszcze jedno z pliku PKGBUILD usuń linijkę "makedepends=('git')", bo zapomniałem wywalić, a gita chyba nie ma na świeżej instalacji, w momencie jak lokalnie kompilujesz bez klonowania źródeł to jest zbędny.


(FadeMind) #4

JEST :sunglasses:


(Domker) #5

To super :slight_smile: :+1:
Już kawał czasu Manjaro nie instalowałem na czysto. Jak zainstalowałem tak pod dłuższym okresie użytkowania do VDI konwersję zrobiłem jako VM siedzi teraz, a na jego miejsce Archa z tym tylko, co potrzebuję zainstalowałem.


(cichy.) #6

@FadeMind port sterowników właśnie z tego kernela dla 4.x, działa na pewno, bo sprawdziłem na najnowszym Mincie. W Linuxach opartych na paczkach deb wiem jak te pakiety bez internetu instalować, ale Manjaro to dla mnie nowe doświadczenie, bez tego sterownika oczywiście internet działa, ale z prędkością 5kbps

@Domker dziękuję, przetestuję, aktualnie te mirror serwery są przeciążone z tego co widzę i nie mogę się dostać, trzeba poczekać :d


(Domker) #7

Są inne mirrory:
http://repo.manjaro.org/
Wchodzisz w katalogi tak jak są w ścieżce URL, co wcześniej podałem. (stable > core > x86_64 …)


(cichy.) #8

@Domker sprawa wygląda tak, u mnie Manjaro ma wersję kernela po instalacji 4.9.34-1, na tych serwerach nie ma wersji linux headers dla tego jądra, jest dla 4.9.44-1. Pobrałem ów kernel, headers i dkms, zainstalowałem te 3 pakiety, jednak po tym przy próbuje odpalenia system mam błąd z ładowaniem kernela (za szybko się przewija, bym zobaczył szczegóły). W każdy razie system nie chce wystartować.


(Domker) #9

Pewnie brakuje mu przyległości i się wywala.
Przy uruchamianiu wciśnij Ctrl+Alt+F2 i się zaloguj.
Wpisz:
journalctl -k
(skrótem klawiszowym przejdź na koniec loga / Ctrl+END lub FN+END)
Będzie wyszczególnione na czym się wywalił.

Można też spróbować:
journalctl -b

(klawiszem “Q” wychodzisz z loga)


(cichy.) #10

@Domker niestety ani ten pakiet z aur ani ten Twój nie działały - w obu przypadkach adapter wifi w ogóle nie był wykrywany po restarcie

podzielę się rozwiązanie mojego problemu, może komuś się przyda

  1. zaktualizowałem swój kernel do wersji 4.9.39-1
  2. zainstalowałem headers i dkms z wcześniej pobranych paczek i pobrałem “swój” fix (https://github.com/pvaret/rtl8192cu-fixes)
  3. wypakowałem i użyłem poleceń:
    sudo dkms add ./rtl8192cu-fixes
    sudo dkms install 8192cu/1.10
    sudo depmod -a
    sudo cp ./rtl8192cu-fixes/blacklist-native-rtl8192.conf /etc/modprobe.d/
    sudo cp ./rtl8192cu-fixes/8192cu-disable-power-management.conf /etc/modprobe.d/

po restarcie wifi działa idealnie, nie ma żadnych problemów
dziękuję za pomoc