Manjaro. pare problemów, których nie mogę rozwiązać


(kop524) #1

Witam otóż jak w temacie mam kilka problemów z Manjaro 17 RC1, których po ok 40m szukania nie mogę rozwiązać.

Pierwsze to dodanie W10 do Grub’a aby móc się do tego systemu zalogować, a bardzo mi na tym zależy
Przedewszytkim nie wiem jak mam rozpoznać, które to hd(x,x) dla sda2 w GPT UEFI. To prosiłbym jak najszybciej o rozwiązanie jeśli możliwe.

Po drugie chciałbym zainstalować KINK żeby mieć wgląd na tusze mojego Epson’a ale cały czas dostaję:
checking for Qt… configure: error: Qt (>= Qt 3.0) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.

Mam pełną paczkę QT5.8.0 z oficjalnej strony zainstalowaną i nie wiem co jest z tym :frowning:
Log z configure dla kink: http://wklejto.pl/271669

proszę o pomoc.


#2
  1. Dual-boot. Os-prober masz zainstalowany? Samo winno wykryć i rozwiązać Twój problem jak się ma hd(x,x) do sda (nie wiem czemu 2; to druga partycja dysku twardego) - tego ostatniego nikt “zdalnie” nie rozwiąże.
    O dual-boot, jest na wiki Manjaro, jest na wiki Archa. Słabo szukałeś.

  2. KINK. Nie wiem co to jest. W repozytorium nie ma i nie ma w AUR. Skąd zatem to bierzesz? Po tym, co pluje (nie może znaleźć bibliotek i nagłówków Qt3) wygląda na to, że jest to jakaś bardzo stara aplikacja (tak mniej więcej 10 lat), która wymaga bibliotek Qt w wersji 3.x. Ten framework został porzucony bardzo dawno temu i nie jest już rozwijany w ramach Qt. Ich nowe wersje są w projekcie Trinity. Jest z tym jednak pewnien problem. Obecne Qt5, tak jak nie gryzie się z Qt4, tak gryzie się z Qt3. Niczego już na Qt3 nie zainstalujesz. Masz zatem wyjście - albo poszukać nowego KINK, albo pogodzić się z sytuacją, albo spróbować instalacji Trinity (ale tego na Manjaro raczej nie ma).

  3. Nie chce mi się przeglądać ponad 2tys linijek kodu. Z czego ta wklejka i czego dotyczy? Co oznacza też: mam pełną paczkę QT5.8.0 z oficjalnej strony zainstalowaną i nie wiem co jest z tym? Pytanie jest kompletnie niezrozumiałe. W obecnej wersji Manjaro masz Qt5.8. Nie jest to jedna paczka. Instalacja przebiega z repozytorium Manjaro, a nie “z oficjalnej strony”, na której też nie ma żadnych “paczek” (w sensie binarek) - są jedynie spakowane źródła, które wymagają kompilacji (tylko po co, skoro skompilowana wersja jest w repozytorium).


(kop524) #3

dzięki za odp. I ok sprawdzam czy mi wyszuka bo wymyśliłem GRUB-CUSTOMIZER zainstalować i sprawdzić nim. A ze strony mam na myśli QT Open-Source Online Installer dla Linux, który jest w wersji skryptu .run i z niego zainstalowałem QT(https://www.qt.io/download-open-source/).

Jeszcze raz dzięki za pomoc :slight_smile:

Ew. jest coś zamiast kink???


#4

Jezu, chłopie, prosisz się o kłopoty.
Ogólna zasada z linuksem: jeśli coś jest w repozytorium - instaluj z repozytorium i nie kombinuj!!!. Instalacja qt5 to:
sudo pacman -S qt5
(albo qt, bo nie pamiętam, jak to wygląda w Manjaro /mam Archa/ ale chyba obie dadzą ten sam wynik)
Grub-customizer, to jest program do “ustawień” GRUB (nie pamiętam w jakiej wersji). Na razie nie jest Ci to kompletnie potrzebne. Sprawdź czy masz os-prober:
pacman -Q os-prober


(FadeMind) #5

Aplikacja KInk jest bardzo stara napisana dla QT3. Musiałaby być przepisana na Qt5 i KDE Framework 5.
fragment configure.in

KDE_USE_QT(3.0.0)
AC_PATH_KDE
#MIN_CONFIG(3.0.0)

CC @pavbaranov @kop524

Co do Twojego problemu z dualboot:
https://wiki.manjaro.org/index.php?title=UEFI_-_Install_Guide#Dual_booting_with_Windows


(kop524) #6

Jest os-prober zainstalowany.


(FadeMind) #7

Po co GRUB customizer początkującemu?? :scream:
Chyba pijesz za dużo kawy :grin:
@pavbaranov


(kop524) #8

z kawą to fakt już 3 piję dziś XD


#9

Proste: KINK nie zainstaluje się obecnie w zasadzie nigdzie. Można próbować jakiś system z DE Trinity: https://www.trinitydesktop.org/ (to fork KDE3.5; repozytoria dostępne dla Archa, ale nie wiem, czy obecnie to DE jest kompatybilne z jakimkolwiek współczesnym systemem; repozytorium dla Archa jest: https://wiki.archlinux.org/index.php/Trinity). To ostatnie DE, gdzie mogłoby zostać zainstalowane coś na Qt3.x, ale czy uda się je tam odpalić - nie wiadomo.

Aha - @kop524 - weź odinstaluj to coś, co zainstalowałeś z “QT Open-Source Online Installer”, bo jedyne co tym wywołasz, to bardzo szybkie skopanie systemu. W jego miejsce - jeśli potrzebujesz - instalujesz Qt5 z repozytorium (tak na prawdę nie potrzebujesz, albowiem to są zależności, które zainstalują się w razie potrzeby same).


(kop524) #10

Ok winda działa a QT najwyżej później usunę.Dzięki za wszelką pomoc :slight_smile: