[Manjaro] Problem z uruchomieniem


(Saarkkin) #1

Witam. 

 

Dziś zainstalowałem Manjaro XFC 


(roobal) #2

Grub w ogóle się uruchammia? Wyłączyłeś przełączałeś się z UEFI na Legacy BIOS z wyłączonym secure boot? Jeśli masz UEFI zamiast BIOS, utworzyłeś partycję EFI dla Linuksa?


(Saarkkin) #3

Grub się uruchamia a UEFI chyba nie mam, bo zawsze uruchamia się bios :).


(MacGregor) #4

Chyba nie rozróżniasz UEFI/EFI od BIOS’u. Większość obecnych laptopów posiada BIOS hybrydowy. Tzn. że posiadasz stary BIOS z obsługą tabeli partycji GPT (oraz kilka innych dodatków). Pytanie polega na tym czy Manjaro to twój jedyny system. Jeśli tak to czy instalowałeś go używając EFI i tabeli partycji GPT? Jeśli nie to czy dodałeś osobną partycję EFI dla bootloadera linuxa.


(enedil) #5

Ty chyba czegoś nie rozróżniasz. Powiedz mi, jakim cudem zainstalowałem Linuksa na laptopie z 2005 roku używając GPT, skoro pierwsze prace nad UEFI rozpoczęły się w 2006 roku?

Wniosek - instalacja Linuksa na komputerze z tradycyjnym BIOS wymaga dodatkowej dwumegabajtowej partycji na początku dysku.


(MacGregor) #6

A skąd masz informacje że jest to laptop z 2005r? Ja w tym wątku nie widzę ani jednej wzmianki o modelu laptopa czy nawet dacie jego produkcji na której opierasz swoją tezę :wink:


(Saarkkin) #7

Laptop to TOSHIBA satellite c660-1ct :slight_smile:

To w końcu jak jest ? Ten laptop ma UEFI czy go nie ma ? Czyli muszę instalować system od nowa i pobierać wszystkie aktualizacje od nowa ? :frowning:


(nintyfan) #8

Chyba wiem, w czym jest problem pogrzebany. Masz zainstalowany system operacyjny? Jeśli nie, to musisz go zainstalować :slight_smile: .


(Saarkkin) #9

Głupia odpowiedź … 

 Dziś zainstalowałem Manjaro XFC 
Otóż problem wygląda następując.
Po uruchomieniu laptopa naciskam "esc" aby nie rozpoczynał z płyty, po czym wyskakuje okno z czego ma się uruchomić. Jednak tu jest problem gdyż ciągle pokazuje, że nie powiodło się uruchamianie z dysku. Natomiast jak uruchomię z płyty i przejdę na dysk to uruchamia się normalnie

Zainstalował sie Grub ( chyba tak się to nazywa ) beta. Kolejnym problemem jest, żę pokazuje system windows vista a nie windows 7.

(Amaterasu) #10

Co do drugiego - musisz wejść w Manjaro (na dysku) oraz zedytować plik grub.cfg poleceniem:

sudo nano /boot/grub/grub.cfg

Edytujesz to podobny wpis do tego:

menuentry 'Windows Vista (loader) (na /dev/sda1)' --class windows --class os $menue$

I zmieniasz nazwę “Windows Vista (loader)” na “Windows 7 (loader)”. Po prostu na taką, jaką chcesz.


(Saarkkin) #11

Zmieniłem na 

menuentry 'Windows 7 (loader) (na /dev/sda1)' --class windows --class os $menue$

 

i wyświetla się dobrze. Pytanko, a mogę zrobić tak aby windows się uruchamiał po tym krótkim czasie ? 


(Amaterasu) #12

Do konfiguracji GRUB-a według własnych uznań (pierwszy system na liście, kolorki, tapeta, inne ustawienia), polecam zainstalować Grub Customizer:

sudo pacman -S grub-customizer

(Saarkkin) #13

Dzięki wielkie. 


(marcin82) #14

Podaj wynik skryptu bootinfoscript:

http://sourceforge.net/projects/bootinfoscript/ .

 

Podaj wynik polecenia:

cat /etc/default/grub