Marginesy w FF i Operze


(Stalker) #1

Witam,

Mam problem. Jak daję ujemny margines np.

to w FF tekst na siebie nie wchodzi, a w Operze tak. Dlaczego? Chcę by w jednej i drugiej przeglądarce odstępy były jednakowe.

Pozdrawiam,

Stalker


(system) #2

Może dlatego że każda ma trochę inne domyślne marginesy, najlepiej je wszystkie zerować na początku arkusza stylów :

* { margin: 0; padding: 0; }

(Stalker) #3

Nic to nie dało.


(Spam) #4

Ta metoda jest głupia jak but. Tak samo, jak głupie jest skakanie po wszystkich elementach. I do tego nie działa na IE5.x… Zdecydowanie lepiej jest wypisać sobie elementy, ale w tym przypadku to nie ma żadnego znaczenia.

Szczegóły? Jaki DOCTYPE, trochę HTML by się przydało… Z fusów nikt nie wywróży.


(Stalker) #5

Nagłówek strony:

br />
	PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"

	"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

Akapity:

| zachodniopomorskie.png |
Województwo: Zachodnio-Pomorskie

Data wystawienia ostrzeżenia: -

Czas trwania zagrożenia: -

Ostrzeżenie: -

|
[/code]


(Spam) #6

Przede wszystkim posuwaj te slashe na końcu – one powinny być dodane tylko jeśli znacznik nie posiada znacznika zamykającego, jak np. tag „img”, którego nie zamknąłeś. Nazwy znaczników i atrybutów pisz małymi literami – to przy okazji. Używanie „font” i „br” jest żałosne – poczytaj sobie lepiej jakiś kurs…

Czyli – usuń slashe i dodaj je tam gdzie trzeba, potem sprawdź, czy działa.


(Stalker) #7

W xhtml'u praktycznie wszystkie tagi zamyka się slashem :slight_smile:

Złączono Posta : 27.08.2007 (Pon) 14:25

W dodatku to i tak nic nie dało :hahaha:


(Spam) #8

Pierwsze słyszę… Zamyka się tylko i wyłącznie pojedyncze tagi :x


(Kutar 0) #9

Nie, tylko te, które nie mają swojego znacznika zamykającego. Takie taki jak p, b mają swoje odpowiedniki zamykające i takich należy używać.

Może przewaliduj kod http://validator.w3.org i popraw wszystkie błędy. Być może to rozwiąże problem.

@EDIT:

Wasacz pierwszy xD


(Stalker) #10

U mnie problem leży w akapitach, bo pod FF wszystko jest ok, a pod Operą tekst na siebie włazi... I nie wiem jak to poprawić aby i tu i tu było ok... ;/


(Spam) #11

Ustawiłeś ujemny margines, więc tekst na siebie nachodzi. Tyle.


(Stalker) #12

Boże, widzisz i nie grzmisz. Ustawiłem ujemny bo są za duże odstępy w FF i Operze. Chciałem je zredukować i w FF mi to wyszło, a w Operze nie. I dlatego teraz chcę się dowiedzieć co zrobić żeby i tu i tam było ok. ;]


(Airborn) #13

jak są za duże odstępy, to pozycjonuj dokładniej elementy, anie nadajesz im ujemne marginesy


(Stalker) #14

Ta, jak mam pozycjonować dokładniej jeśli wywala mi wielkie odstępy i nie mam jak tego zlikwidować?


(Kutar 0) #15

Przewaliduj kod! Zdarza się (choć nie mówię że w Twoim przypadku również tak będzie), że różne błędy mają wpływ na zupełnie odmienne rzeczy na stronie.

A jeśli to nie pomoże to spróbuj ustawić linie za pomocą

line-height:10px;

(Stalker) #16

To również nic nie dało. Cóż, najwyżej pod Operą strona będzie rozwalona :wink:


(Kutar 0) #17

Daj na rapidshare paczkę z pełnym kodem + css + obrazki.


(Stalker) #18

Masz spakowany cały portal:

http://rapidshare.com/files/51808599/portal_meteo.rar


(Kutar 0) #19

W pliku pogoda.htm

JEST:

mapa.png[/code] POWINNO BYĆ:
[code]
mapa.png


(Stalker) #20

No i co z tego? Mi chodzi o plik z ostrzeżeniami...