Menedżer "Zarządzanie sterownikami" - zawiesza się


(Przemek Ch) #1

Witam ponownie,
Jak widać korzystanie z Linuksa zmusiło mnie do ponownego zadania pytania odnośnie pojawienia się problemu.
Otóż zauważyłem, że nieraz po uruchomieniu komputera (teraz podczas dodawania tematu pojawiło się to w trakcie pracy systemu) obraz “szarpie się”, bardzo szybko migocze, jednak nie cały czas. Dzieje się tak przy zamykaniu i otwieraniu nowych okien, przewijaniu strony w przeglądarce… Po restarcie jest już ok.
Pomyślałem, że można by spróbować przełączyć sterowniki graficzne z otawrto-źródłowych na własnościowe nVidia. Jest z tym jednak problem, ponieważ program do zarządzania sterownikami zawiesza się na komunikacie: “Zbieranie informacji o Twoim systemie”. Dałem mu ponad pół godziny na to zbieranie i nic. W czymże znowu rzecz?
Pozdrawiam!


(marcin82) #2

Podaj wyniki poleceń z terminala:


(Przemek Ch) #3

Kolejno:

Linux stacjonarny 4.8.0-45-generic #48~16.04.1-Ubuntu SMP Fri Mar 24 12:46:56 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04.2 LTS
Release: 16.04
Codename: xenial

server glx vendor string: SGI
server glx version string: 1.4
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
OpenGL vendor string: nouveau
OpenGL renderer string: Gallium 0.4 on NV94
OpenGL core profile version string: 3.3 (Core Profile) Mesa 12.0.6
OpenGL core profile shading language version string: 3.30
OpenGL version string: 3.0 Mesa 12.0.6
OpenGL shading language version string: 1.30
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 12.0.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00

01:00.0 VGA compatible controller: NVIDIA Corporation G94 [GeForce 9600 GT] (rev a1)
Subsystem: Micro-Star International Co., Ltd. [MSI] G94 [GeForce 9600 GT]
Kernel driver in use: nouveau


(marcin82) #4

Pokaż listę repozytoriów:

Wykonaj pełną aktualizację systemu:

Jeśli aktualizacja obędzie się bez przeszkód pokaż wynik symualcji instalacji pakietu nvidia-340:

Z tego co wyczytałem na podstronach “supported hardware” twoja karta jest - oprócz wersji 340 - wspierana jeszcze przez sterowniki w wersjach 304 oraz 173.


(Przemek Ch) #5

Rezpozytoria: sl.txt (2,9 KB)
Aktualizacja przebiegła bez przeszkód.
Wynik symulacji instalacji sterowników dla karty: symulacja.txt (5,4 KB)


(marcin82) #6

A jak teraz uruchomisz program do instalacji sterowników własnościowych to będzie błąd czy nie?

Wygląda na to, że nie powinno być problemów po instalacji pakeitu nvidia-340. Oczywiście zawsze może coś pójść nie tak :smiley:


(Przemek Ch) #7

Bez zmian; że niby cały czas “zbiera informacje”. Coś “niedorobiony” ten Kubuntu - przynajmniej na moim komputerze tak się zachowuje - z centrum oprogramowania też problem, ale ominąłem to instalując Synaptic’a. Może by trzeba zgłosić te błędy to twórców tych programów…
Poczekam trochę, może po aktualizacji zniknie problem z obrazem. Jeżeli nie, to zainstaluję sterownik nvidia.
A po zainstalowaniu pakietu nvidia-340 jak przełączyć, aby system korzystał z tego właśnie sterownika?


(marcin82) #8

Podczas instalacji automatycznie powinien zostać włączony sterownik własnościowy, a otwartoźródłowy dodany do czarnej listy modułów.


(Domker) #9

To co się u Ciebie dzieje to chyba “Screen Tearing”.
Dodaj ten skrypt do katalogu “/etc/profile.d” (najpierw rozpakuj), dodaj mu prawa do uruchamiania i zmień właściciela pliku na root:
kwin.zip (186 bajtów)
Po ponownym uruchomieniu komputera powinno być OKI.


(Przemek Ch) #10

Dla porządku napiszę, że od czasu aktualizacji systemu jest spokój…
Dziękuję bardzo za porady :slight_smile:
Jeżeli chodzi o “Screen Tearing” to patrzyłem w Google jak to wygląda i to nie byłoby to.
Jakby to wróciło (miejmy nadzieję, że nie), to nagram jak to wygląda i zalinkuję.