Mikrotik 2 x WAN 2 x LAN Fail to Over


(dj1sklero) #1

Mam dwa łącza internetowa łączone via PPPoE , oraz dwa LANy, każdy korzysta z jednego łącza przez markowanie w Mangle, i teraz chce zrobić Fail to over na podstawie pingowania znanych adresów jak np. DNS Google ( Bo mój gateway przy awariach też lubi odpowiedzieć na ping) robię to przez dodanie routingu dla np adresu googla by miał stały dostęp do łącza i potem jego pingowanie, według przykładu:

/ip route
add dst-address=8.8.8.8 gateway=192.168.1.1 scope=10

Z tąd pochodzi poradnik: http://kielceserwis.pl/2-wan-przelaczanie-fail-over-mikrotik/

( i tutaj jest problem, bo mam dynamiczny gateway, i w momencie jak mu podam interface ppp to drugi wpis nie ma odpowiedzi na ping, a jak mu podam wyciągnięty z ppp gateway to odpowiedzi dochodzą.)

add dst-address=10.2.2.2 gateway=8.8.8.8 scope=10 target-scope=10 check-gateway=ping

Zatrzymałem się w miejscu gdzie nie mogę dostać odpowiedzi ping.

Do teraz mam tak:
/ip rotue
add check-gateway=ping distance=1 gateway=pppoe-ALFA routing-mark=to_ALFAC
add check-gateway=ping distance=1 gateway=pppoe-NEO routing-mark=to_NEOC
add check-gateway=ping distance=2 gateway=pppoe-NEO,pppoe-ALFA

to mam wrażenie że działa, ale jest problem z pingowaniem bramy LAN i routingiem między dwoma sieciami LAN (jak dam disabled na tych wpisach to nagle wszystko idzie pingować) oczywiście routing sieci LAN mam:

4 ADC 10.0.0.0/24 10.0.0.1 NEO 0
9 ADC 192.168.2.0/24 192.168.2.1 ALFA 0

Chyba że ktoś poleci jakiś inny sposób przez skrypty czy Netwatch.