Montowanie dysku w trybie do odczytu


(Przemo D) #1

Cześć,

mam problem z zamontowaniem dysku który służył jako magazyn danych pod Windows w trybie do odczytu.

Korzystam z komendy: sudo mount -ro /dev/sdb1 /mnt

Dostaje : mount: can't find /mnt in /etc/fstab or /etc/mtab


(ra-v) #2

??


(Przemo D) #3

Zrobiłem tak wcześniej, utworzyło bo po wklepaniu drugi raz mam że nie może utworzyć bo istnieje już.


(Piesek64) #4

A może by tak -o ro? Czyli w wolnym tłumaczeniu -options readonly.


(Przemo D) #5

Kolega dragonn wczesniej mi to sugerowal, ale po tym dysk znika z menadzera pilkow :stuck_out_tongue: nie wiem czy ma znaczenie ale teraz to z live cd robie bo po aktualizacji wisi na fioletowym tle i fcsk tego nie naprawil, choc wyszedl ze stanem 1.


(roobal) #6

Jeśli to ntfs, to nie musisz używać żadnych opcji w mount, ponieważ jadro obsługuje ntfs tylko i wyłącznie w trybie tylko do oczytu.

sudo mount -t ntfs /dev/sdb1 /mnt

Jeśli nie ma katalogu mnt, utwórz go na nowo.


(Przemo D) #7

Tak to ntfs, ale wydaje mi sie ze jak mialem rownolegle ubuntu i win 8 to moglem modyfikowac to co na ntfs bylo. Teraz popsulem bo nie wylaczylem fastboota z windows i wyrzucilem go zostawiajac Ubuntu :confused: Dostaje :

The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sdb1': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

Czyli probowal w odczyt zapis montowac chyba


(dragonn) #8
sudo mount -t ntfs -o ro /dev/sdb1 /mnt

I to musi zadzialać, a to że znika on w menadżerze plików to sie nie przejmuj, przejdź po prostu do folderu /mnt.


(saitoh) #9

Skąd wziąłeś to “-ro”?

​RTFM:

man mount

Montowanie zasobów bezpośrednio do /mnt to nie jest najlepszy pomysł.


(dragon321) #10

 

To już od jakiegoś czasu nieaktualne. Sterownik ntfs w kernelu Linuxa ma obsługę zapisu, co prawda wciąż eksperymentalną, ale używałem jej i jakoś danych nie straciłem. Jednak o wiele lepszym pomysłem jest stosować ntfs-3g jak chcesz cokolwiek zapisywać, bo on ma obsługę zapisu dużo dłużej, więc powinien być stabilniejszy. Dobry przykład jest taki, że jak zamontujesz partycje NTFS w trybie RW używając wbudowanego w kernel sterownika ntfs to Steam nie pozwala utworzyć na niej biblioteki gier, bo twierdzi bodajże, że bilbioteka steam musi być na partycji z uprawnieniami wykonania czy coś podobnego(nie sprawdzałem tego). Jak używasz ntfs-3g to nie robi żadnego problemu z tym, sam to stosuje do niektóryc gier, bo mam trochę za mało miejsca na partycji Linuksowej i wszystko śmiga. Zresztą sam opis sterownika ntfs na stronie kernel.org mówi o tym, że obsługa zapisu jest jeszcze ograniczona, tutaj można poczytać:

https://www.kernel.org/doc/Documentation/filesystems/ntfs.txt

Montowanie bezpośrednio do folderu /mnt to niezbyt dobry pomysł. Przejdź w konsoli do tego katalogu i wpisz sudo mkdir ntfs. Potem montujesz poprostu tak:

sudo mount -t ntfs -o ro /dev/sdb1 /mnt/ntfs


(Przemo D) #11

Faktycznie dziala, dysponujac live cd moge pokopiowac dane inaczej niz terminalem, bo potrwa to wiecznosc?

@saitoh na manuala przyjdzie czas jak bede w stanie korzystac choc mininalnie ze sprzetu, obiecuje :stuck_out_tongue:


(nintyfan) #12

Dysk znika z menadżera plików, bo został podmontowany przez mount. To tak samo, jakbyś dodał wpis do /etc/fstab.


(Przemo D) #13

@up dzięki za wyjaśnienie, Ubuntu choć trochę mniej czarną magią się stało.


(roobal) #14

Tak, bo w Ubuntu zainstalowany jest domyślnie sterownik ntfs-3g, który działa nie w jądrze, a w przestrzeni uzytkownika (FUSE).

Pomożemy, ale nie w tym temacie, ponieważ nowy problem = nowy wątek. Proszę również poprawić posty bez polskiej pisowni.