Msstyle nie działają nawet po patchowaniu, XP sp3


(Tommygun15) #1

Witam. Chciałem włączyć styl z rozszerzeniem .msstyle. Z tego co wyczytałem w internecie, włączanie tematów zostało zablokowane w nowszych wersjach systemu. Aby włączyć temat należy spatchować system co też chciałem uczynić. Próbowałem spatchować uxthemepatcherem, ale nic to nie dało. Próbowałem czymś jeszcze, nazwy już nie pamiętam, ale ponownie nie uzyskałem pożądanego efektu. Zainstalowałem program StyleXP 30-dniowy w nadziei, że on rozwiąże mój problem. Program wyświetlił mi komunikat mówiący o tym, że ta wersja programu StyleXP nie działa na mojej wersji systemu i bym sprawdził aktualiacje do StyleXp. Sprawdziłem czy są aktualizacje i okazało się, że wersja StyleXP, którą posiadam jest najnowsza. Mimo to tematu nie mogę zastosować ani normalnie, przez Windows, ani przez StyleXP. Pokazywał się też komunikat błędu, którego treści nie pamiętam. Podejrzewam, że inne programy w stylu StyleXP na nic się nie przydadzą. Jednak łatwo się nie poddałem i poszukałem jeszcze informacji na temat msstyle i znalazłem program UXTHEME MULTI-PATCHER (Neowin Edition) 4.0, który podobno działa w różnych wersjach czy buildach (jak zwał tak zwał) systemu. Program ten spatchował system i StyleXp nie wyświetlają teraz komunikatu o tym, że moja wersja systemu nie jest obsługiwana. Mimo to nadal pokazuje się błąd. Treść tego błędu to: "An exception occured while applying the style." przy próbie włączenia tematu. Dokładnie to wygląda tak: klikam "zastosuj styl", włącza się ekran "czekaj", włącza się dźwięk błędu krytycznego 'SRU!", ekran "czekaj" po chwili gaśnie, pokazuje się komunikat z błędem. Po spatchowaniu mam styl klasyczny którego nie mogę zmienić na jakikolwiek inny. Co można zrobić, by wstawić tematy msstyle?


(Danielm86) #2

A spróbuj zainstalować np. Brico Pack Crystal Clear. Potem zainstaluj swoją skórkę.


(Tommygun15) #3

Nie pomogło... wywaliłem StyleXp i zainstalowałem Brico Pack Crystal Clear i teraz wybierając we właściwościach ekranu skórkę "HITMAN2" pokazuje się komunikat Błędu ładowania kompozycji:

. Kiedy próbuję włączyć inną skórkę pokazuje się taki błąd:

Może jakiś inny pomysł?? [-o<


(Rmk) #4

Jak ja lubię ludzi co komplikują sobie życie.

Po instalacji SP3 wystarczy w trybie awaryjnym zmienić rozszerzenie pliku uxtheme.dll na uxtheme.dll.old i wkleić zmodowany plik ze strony:

Po tym musi chodzić a jak nie to masz coś uszkodzone w systemie lub sprzęcie.

PS: Brico Pack Crystal Clear prawdopodobnie uszkodził ci pliki systemowe.


(Tommygun15) #5

Dzięki za odpowiedź :). Zadziałało, ale mogę stosować jedynie skórki z rozszerzeniem .theme. Skórek z rozszerzeniem .msstyles nadal nie mogę stosować. Nadal pokazuje się komunikat błędu:

Można coś na to poradzić?

Ps. Razem ze skórką "HITMAN2", w jednej paczce zamieszczony był program uxthemepatcher, który nie zadziałał jak powinien. Do niego dołączony był plik tekstowy z taką treścią:

Wpisałem 3 pierwsze komendy a przy 4. wyświetlił się komunikat, że plik uxtheme.pat nie istnieje. Nie jestem pewien do końca czy dokładnie taki komunikat mi się wyświetlił, ale to mi właśnie zaświtało w głowie. Kopii uxtheme.dll nie było w folderze \SYSTEM32\DLLCACHE.

Proszę o dalsze porady co do skórek z rozszerzeniem .msstyles. Będę bardzo wdzięczny :slight_smile: :slight_smile: .

Udało się zastosować skórkę z rozszerzeniem .msstyles :lol: :lol: :lol: ! To prawda, że komplikuję sobie życie. Zamiast uruchomić skórkę otwierając plik, ja próbowałem uruchomić ją przez "właściwości ekranu" :expressionless: co kończyło się marnie. Teraz otworzyłem plik skórki i poszło. Dzięki za odpowiedzi :slight_smile: Na was zawsze można liczyć. Skórka warta była zachodu :).