Munin-node instalacja na starych wersjach RHEL/CentOS


#1

Witam.

Mam mały problem. Muszę zainstalować munina na kilkunastu serwerach. Tam gdzie są nowsze wersje systemów - nie ma problemu, wszystko jest w repo. Niestety, kilka z nich stoi jeszcze na RHEL4/CentOS4, a nawet są kwiatki na 3 wersji tych dystrybucji. Ręczne ściąganie paczek - piekło zależności. Męczył się już ktoś z czymś takim? Może podpowiedzieć jak to ugryźć? Wiem że się da, bo na kilku jest już to zainstalowane i działa, tylko nie wiem czy mój poprzednik robił to ręcznie, czy jak. Za wszystkie sugestie z góry dziękuje.


EDIT

Dobra, znalazłem repozytoria EPEL, tylko nie wiem czy to zadziała na tak starych systemach, a wolę nie położyć maszyn.


EDIT2

Już wiem że EPEL działa, przynajmniej w większości wypadków. Na serwerze z RHEL3 muszę sobie munina darować. Na tych z 4 praktycznie wszędzie działa, poza jednym przypadkiem.

Jako zależność wymagane jest perl(:MODULE_COMPAT_5.8.5) przez co instalacja staje. Mam tam perla w nowszej wersji i w systemie siedzi perl(:MODULE_COMPAT_5.10.0) oraz

perl(:MODULE_COMPAT_5.10.1). Na pozostałych serwerach, tam gdzie działa, perl jest nawet w nowszych wersjach i takich problemów nie było.