Mysqldump nie da się przywrócić kopii bazy


(Pawel Pieczyrak) #1

Cześć!

W mojej bazie danych występują dwie bazy: jedna z nich to wordpress, a druga test, z czego pierwsza jest zapełniona tabelami, a druga pusta. Wykonuję backup bazy wordpress następującym poleceniem:

mysqldump -u root -p wordpress > wordpress.sql

Teraz chcę wykonaną kopię bazy przywrócić do bazy test, więc:

mysqldump -u root -p test < wordpress.sql

I konsola wypluwa następujący wynik:

- MySQL dump 10.13 Distrib 5.5.34, for debian-linux-gnu (x86_64)

--

-- Host: localhost Database: test

-- ------------------------------------------------------

-- Server version	5.5.34-0ubuntu0.13.10.1


/*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;

/*!40101 SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */;

/*!40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION */;

/*!40101 SET NAMES utf8 */;

/*!40103 SET @OLD_TIME_ZONE=@@TIME_ZONE */;

/*!40103 SET TIME_ZONE='+00:00' */;

/*!40014 SET @OLD_UNIQUE_CHECKS=@@UNIQUE_CHECKS, UNIQUE_CHECKS=0 */;

/*!40014 SET @OLD_FOREIGN_KEY_CHECKS=@@FOREIGN_KEY_CHECKS, FOREIGN_KEY_CHECKS=0 */;

/*!40101 SET @OLD_SQL_MODE=@@SQL_MODE, SQL_MODE='NO_AUTO_VALUE_ON_ZERO' */;

/*!40111 SET @OLD_SQL_NOTES=@@SQL_NOTES, SQL_NOTES=0 */;

/*!40103 SET TIME_ZONE=@OLD_TIME_ZONE */;


/*!40101 SET SQL_MODE=@OLD_SQL_MODE */;

/*!40014 SET FOREIGN_KEY_CHECKS=@OLD_FOREIGN_KEY_CHECKS */;

/*!40014 SET UNIQUE_CHECKS=@OLD_UNIQUE_CHECKS */;

/*!40101 SET CHARACTER_SET_CLIENT=@OLD_CHARACTER_SET_CLIENT */;

/*!40101 SET CHARACTER_SET_RESULTS=@OLD_CHARACTER_SET_RESULTS */;

/*!40101 SET COLLATION_CONNECTION=@OLD_COLLATION_CONNECTION */;

/*!40111 SET SQL_NOTES=@OLD_SQL_NOTES */;


-- Dump completed on 2013-11-15 12:09:42

Niestety, baza danych test nadal jest pusta. Uwaga! Jeżeli posłużę się oprogramowaniem phpmyadmin to kopia naturalnie zostanie przywrócowa w bazie test. Czy ktoś wie dlaczego phpmyadmin daje radę a mysqldump nie?

Z góry dzięki na odpowiedź.


(pawelllek) #2

Pr