Naprawa Microsoft Store, resetowanie aplikacji nie pomaga

Cześć,

Nie mogę pobierać aplikacji z Microsoft Store, gdyż wywala “błąd” po “pobieraniu licencji”.
Resetowałem kilka razy aplikację, lecz i to nie pomogło - dawniej reset pomagał.
Jakieś pomysły?
Windows 10 w wersji 2004.

  • Spróbuj usunąć zawartość katalogu C:\Windows\SoftwareDistribution
  • Naciśnij Win+R wpisz WSReset.exe i naciśnij Enter
  • Uruchom kompa ponownie
  • Sprawdź aktualizacje w Windows Update

@phx84lbn dzięki za radę, lecz to nie przyniosło oczekiwanego efektu.

Zauważyłem, że nawet strona Microsoft Store nie działa z przeglądarki. To tak, jakby był to problem po stronie serwerów Microsoft. Sprawdź ktoś, czy strona Microsoft działa i potwierdzi.

co ma wspólnego %WINDIR%\SoftwareDistribution z MS STORE?? :thinking:

Zmień DNSy na cloudflare >

1.1.1.1
1.0.0.1

a potem jako admin w PS:

ipconfig /flushdns

Sprawdź poprawność danych w systemie (PowerShell jako ADMIN):

sfc /scannow
DISM /Online /Cleanup-Image /CheckHealth
DISM /Online /Cleanup-Image /ScanHealth
1lajk

Chyba o to chodziło?

EDIT: po zmianie serwera DNS, strona Microsoft działa, jak i Microsoft Store. Udało się pobrać aplikację.
Dzięki za pomoc @FadeMind

proszę :wink:

Próbuję zmienić DNS na routerze starszym, jednak po wpisaniu Secondary DNS i Primary DNS wartość wraca do domyślnych. Jest na to rada?

Jaki model? :> :thinking:

tl-wr1043nd

FW aktualny? Zwróć uwagę na rewizję.

TPLINK lubi się wieszać bo ma strasznie zbagowany kod.
Zasadniczo jak USER nada na sztywno DNSy to powinien na nich polegać bez zająknięcia.

Status - Hardware Version: WR1043ND v1 00000000
Zdaje się, że nie jest aktualny.

Sprawdź z tyłu (pod spodem) jaką masz REWIZJĘ, bo oni mają kilka. I każda ma swoją wersję FW. W sumie jak urządzenie jest podpięte do NETU to sam możesz sprawdzić sobie czy jest nowa wersja FW - pod warunkiem, że masz takie opcje w setup.

Edit


Aktualizacja
WAŻNE: Aby zapobiec problemom podczas aktualizacji, zapoznaj się z poniższymi punktami

Upewnij się, że oprogramowanie jest przeznaczone dla twojej wersji sprzętowej routera. Zainstalowanie oprogramowania dla nieprawidłowej wersji może uszkodzić urządzenie i spowodować utratę gwarancji.( V1.x=V1)
NIE zalecamy używania oprogramowania przeznaczonego dla innego regionu niż ten, w którym się znajdujesz. Możesz wybrać swój region tutaj.
NIE odłączaj urządzenia od prądu podczas trwania aktualizacji. Może to spowodować trwałe uszkodzenia.
NIE przeprowadzaj aktualizacji za pomocą połączenia bezprzewodowego jeżeli nie jest to konieczne.
Zalecamy rozłączenie połączenia z Internetem przez przeprowadzeniem aktualizacji.
Rozpakuj pobrany plik za pomocą programu do dekompresji, takiego jak np. 7Zip lub WinRAR.

TL-WR1043ND_V1_140319
Data publikacji: 2014-03-19 Język: Angielski Rozmiar pliku: 4.75 MB
Modifications and Bug Fixes:

Fixed some vulnerabilities and improved security.
Notes:

For TL-WR1043ND V1

Sprawdziłem pod spodem urządzenia. Mam Ver.1.6

wrzuć fotkę bo takiej wersji tam nie ma :thinking:

:thinking:
(zdjęcie usuwam)

Na tylnym panelu urządzenia znajduje się etykieta produktu z oznaczeniami " Ver.X.Y " (np. Ver.1.0). W polu numer serii znak X oznacza wersję sprzętową urządzenia. Np. w przypadku oznaczenia “Ver: 1.1”, wersja sprzętowa urządzenia to V1.

OK, ale na stronie producenta nie ma wersji 1.6 dają tylko DATĘ wydania:
TL-WR1043ND_V1_140319
to jest 2014-03-19

No właśnie.
Pogubiłem się z tym urządzeniem. No ale to nic, udało mi się zmienić DNS’y w ustawieniach routera.

Po nazwie modelu masz chyba numer build. Wygląda na to, że u autora jest on zerowy. W każdym razie przeinstalowanie firmwer jest jak najbardziej wskazane przy tak dziwnym zachowaniu routera i znając jakie to są słabe i podatne urządzenia na ataki :wink:

ps.
@Pajan Jakie masz teraz DNS na routerze? Może to jakieś man-in-the-middle attack i wszystkie zapytania DNS są rozwiązywane na fałszywym serwerze? :smiley:

WAN - DNS Server: 1.1.1.1 , 1.0.0.1
Zrobiłbym firmware urządzenia, tylko jaka to teraz wersja jest odpowiednia dla urządzenia…
EDIT: zdaje się, że ta wersja jest odpowiednia: TL-WR1043ND_V1_140319