Naprawienie systemu po aktualizacji


(Przemo D) #1

Hej,

po aktualizacji systemu Ubuntu 14.04 system stoi na fioletowym ekranie. Próbowałem korzystac z dostępnych w recovery narzędzi ale nie udało mi się nic naprawić. Odkryłem że system startuje po wybraniu 'Ubuntu za pomocą systemu Linux 3.19.0-25-generic' czytałem gdzieś że błędy w aktualizacji naprawić można komendami:

sudo apt-get update
sudo apt-get upgrade

Jednak po restarcie wciąż fioletowy screen. Będę bardzo wdzięczny za pomoc.


(dragon321) #2

Najpewniej X’y nie chcą wystartować. Zanim w GRUB’ie wybierzesz Ubuntu, to wciśnij E i otworzy ci się edytor wpisu. Na końcu linijki, która zaczyna się od linux powinno być coś takiego jak splash - musisz to usunąć i potem Ctrl+X aby wystartować. Jak ci się powiesi, to wciśnij Ctrl+Alt+F1 i powinien ci się otworzyć terminal, w którym się logujesz na swoje konto. No i potem, jak się zalogujesz, to będziesz mógł wpisać te polecenia.


(Przemo D) #3

Wklepalem je ale nic nie pomoglo. Wciaz fioletowy screen.

 

Edit: Samego splash’a usunąć? czy inne rzeczy za nim też? Usunąłem splash’a i zrobiłem jak napisałeś i wciąż był fioletowy screen.


(nintyfan) #4

Splasha się usuwa dopisując quiet to parametrów uruchamiania jądra.

 

Która wersja kernela się nie uruchamia?


(Przemo D) #5

3.19.0-26-generic, po wybraniu w GRUB’ie stoi na ‘wczytywaniu początkowego dysku Ram’


(dragon321) #6

 

Nieprawda, quiet służy do czego innego i jest domyślnie załączony razem z parametrem splash. Aby usunąć splash należy usunąć parametr splash, quiet służy do ukrycia informacji kernela, gdyż kernel uruchomiony bez żadnych dodatkowych parametrów wyświetla informacje o tym co robi/co jest ładowane, Ten parametr poprostu je ukrywa.

Ja to chyba za bardzo nie rozumiem. Uruchamia się na poprzednim kernelu?


(nintyfan) #7

Może poprzednio nie miałem racji, ale teraz raczej będę mieć.

Na wielu dystrybucjach do każdego jądra jest oddzielny ramdysk rozruchowy. Skoro się zacina na ładowanie ramdysku rozruchowego, to może być coś z nim nie tak. Uruchom na innym kernelu i wykonaj mkinitrd.


(marcin82) #8

 

 

Po normalnej aktualizacji dostęnej w systemie czy po aktualizacji z innej wersji Ubuntu, np. 12.04 (tak logicznie zakładam).

 

Czy w systemie były ręcznie instalowane sterowniki karty graficznej?

 

 

 

 

W Ubuntu? Tak raczej - dotyczy jądra, które da się uruchomić:

update-initramfs -u -k $(uname -r)

Co do parametrów linii komend jądra:

quiet  [KNL] Disable most log messages .


(Przemo D) #9

i) na 3.19.0-25-generic się uruchamia natomiast na 3.19.0-26-generic stoi na fioletowym ekranie

ii)Po normalnej dostępnej aktualizacji, co ciekawe 2 razy pod rząd mi się to przydarzyło, po pierwszym wgrałem ponownie 14.04 i znowu po aktualizacji fioletowy screen.

iii) Ręcznie chyba nie, zmieniłem tylko w “Dodatkowych sterownikach” na te od Nvidii.

 

Mam w końcu robić mkinitrd czy nie? Jestem strasznym nowicjuszem i dopiero poznaje system i byłbym wdzięczny ogromnie za mówienie wprost co mam robić :wink:


(dragonn) #10

Mała uwaga, to polecenie nie zadziała bo przebuduje tylko initrd dla aktualnego jądra a nie tego co nie działa.

Trzeba by było chyba tak:

update-initramfs -u -k 3.19.0-26-generic

(jajecpl) #11

To jajko 3.19 to wogóle jakieś poryte jest,u mnie nie działa. albo od razu zmiana na serię 4.0, albo jakies 3.16…====3.19 ACPI PCC PROBE FAILED tak mi pokazywało …


(Przemo D) #12

Nie pomogło niestety.

 

Edit: Zainstalowałem kernel 4.0 i odpukać póki co jest wszystko ok :slight_smile:

Jak mogę usunąć te wcześniejsze? Bo po update gruba w terminalu mi pokazało coś jakoby się 3 zachowały


(GamerPL) #13

sudo apt-get remove linux-image-3.19* linux-headers-3.19*