NBOX Recorder - podłączenie do Internetu


(NRN) #1

Na wstępie, żeby nie było. Przeszukałem forum i znalazłem te dwa wątki:

Jak widać po linkach i po "podświetleniach" treści, materiały znalezione zostały za pomocą "szukajki". Wymagania spełnione :wink: Szkoda tylko, że tematy nic nie dają - jeden urwał się w połowie, drugi proponuje zrobienie czegoś co zrobiłem, i co nie działa. Problematyczne, nie?

Problem: Podłączenie NBOX Recordera do Internetu.

Sytuacja: Do niedawna działało. Po modernizacji jednego z węzłów sieci, przestało działać, choć praktycznie nic się nie zmieniło.

Opis szczegółowy:

Do niedawna, z Internetem łączył mnie U.S. Robotics 9108, firmware w wersji BETA problemów nie sprawiał (niestety, nie doczekał się update'u). Ma on jednak swoje lata, kupiony w 2006 roku swoje przeżył.

Tym niemniej, ok. 2010-2011 roku doczekał się dodatkowego zadania - musiał zająć się dostarczaniem Internetu do NBOX'a i do telewizora (który update'uje ponoć swój firmware w tle, jeśli ma połączenie z Internetem). Został w tym celu zakupiony jeden węzeł - zalecany w tamtym okresie przez "n" router D-Link DAP-1160, jeden z najtańszych sprzętów sieciowych na rynku, bardzo w Polsce popularny. Po użyciu specjalnej aplikacji do ustawiania go (czy może raczej do upgrade'u wbudowanego F/W z 1.20 do 1.30 z ustawieniami dla "n"), prześlicznie chodził z USR-em bez dodatkowych ustawień. Pracował w trybie AP Client, podczas gdy USR w czystym trybie AP, bez żadnych udziwnień typu bridge itp.

Jednak z czasem, USR przestał sobie radzić z zadaniem dostarczania Netia-owo-TPSA-owego dostępu do Internetu. Rozwiązanie? Zakup nowego, ponownie dość drogiego i funkcjonalnego sprzętu. Wybór padł na podobną grupę cenową, co przy USR-ze - 300-600 zł, i Access Point ASUS DSL-N55U. Urządzenie działa pod kontrolą nowego cudeńka ASUSa, czyli ASUS WRT, wariację na temat OpenWRT. Co prawda część ustawień jest okrojona, a do swobody działania znanej z Tomato mu wiele brakuje, ale jest w miarę wygodny w użyciu. No i ma bardzo przyjemne moduły monitorowania ruchu w sieci i udostępniania zasobów z dwóch w pełni funkcjonalnych portów USB 2.0.

Tylko pojawił się pewien problem. Do "n" przestał docierać Internet... I właśnie...

Diagnoza i rozpoznanie:

  • Wyłączony jest MAC-Filter, gdyż w aktualnej wersji ASUS WRT skopano jego implementację (zawsze blokuje wszystko; prawdopodobnie pomylili się przy projektowaniu nowego interfejsu, i zapomnieli wprowadzić zmian z zasadami wprowadzania danych do reszty oprogramowania. Cóż... niedopuszczalne przy tej cenie, ale zdarza się...).

  • Sygnał dociera do D-Linka - podłączony w miejsce "n" komputer chwyta połączenie i działa wzorowo.

  • DHCP z ASUSa przydziela adres urządzeniom podpiętym do D-Linka. Wszystko działa zarówno w trybie AP Client, jak i Repeater.

  • Z poziomu komputera podpiętego kablowo do ASUSa, bez problemu dostaję się do panelu zarządzania D-Linka.

  • Próba użycia jako rozwiązania trybu "Bridge with AP" okazała się fiaskiem, gdyż D-Link i ASUS nie są w tej kwestii ze sobą kompatybilne.

  • Telewizor ani "n" nie umieją się połączyć z siecią, mimo, że wykrywają ustawienia. Fiasko następuje przy testach typu DNS / IP, czyli przy próbie wyjścia na świat.

  • Przydzielanie tym urządzeniom ręcznych IP i DNSów nie pomogło.

  • Aktualizacja F/W w D-Linku do wersji 1.41 (niestety, konfiguratora dla NBOXa do tej wersji oprogramowania nie ma) nie pomogła - żadna konfiguracja nie przyniosła dobrego efektu, nawet przy odłączaniu urządzeń od prądu.

Czy ktoś wie, co tu się dzieje?


(Elzear) #2

U siebie miałem podobny problem z siecią.

W domu u siostry jest, jakiś TP-Link budżetowy + stary universal repeater od symbol'a.

Problem pojawiał się w momencie gdy sieć była zabezpieczona WPA2 PSK, nie ważne czy był to tryb repeater czy też AP-mode. Sieć ustanawiała połączenie, a nawet więcej dhcp przydzielał adresy jednak nie dało wyjść się na zewnątrz.

Spróbuj na początek wyłączyć szyfrowania połączenia jeśli masz ustawione i sprawdź czy zadziała. Jeśli tak to możesz popróbować starszych metod szyfrowania np. WPA-PSK (pomimo tego, że protokół szyfrowania jest uznany za mało bezpieczny, to w przypadku długiego hasła nadal zapewnia dobrą ochronę gdy nie ma nic lepszego).

Jeszcze przychodzi mi kolejna myśl. Powiedz mi cy przy firewallu coś nie grzebałeś przy Asusie?


(NRN) #3

Po pierwsze - od kiedy to szyfrowanie WiFi, które jest między węzłami, ma wpływ na klienta podpiętego przez Ethernet do jednego z nich?

Tak czy siak, przeprowadzałem testy na włączonym (WPA2-PSK Personal) i wyłączonym (OPEN, non-WEP) szyfrowaniu. W obu przypadkach komputer podłączony przez Ethernet komputer działał poprawnie. Podpięta "n" i telewizor - niestety już nie.

Asus ma Firewalla na na domyślnych ustawieniach + włączoną blokadę ataków DDoS i blokadę pingów z poziomu WAN-u. That's all. Komputerom to nie przeszkadza, więc podejrzewam, że "n" też nie powinno. Dodatkowo pogrzebałem troszkę w QoS, ale to nie powinno mieć wpływu. Tym niemniej, sprawdziłem - włączanie i wyłączanie QoS nie zmienia niczego w sytuacji.


(Elzear) #4

Ma w momencie gdy urządzenie nie wyrabia z pakowaniem w ramki + szyfrowaniem danych + przesyłaniem ich do drugiego urządzenia (tak jak mówiłem mój repeater jest dość leciwy).

Sprecyzuj informację czy urządzenie odpowiada na zapytania w sieci lokalnej czy też nie?


(NRN) #5

Nie odpowiada, mimo, że samo urządzenie twierdzi, że pobrało adres ip z sieci (może to nieprecyzyjny komunikat?).

A co do pakowania, szyfrowania i przesyłania - wcześniej działało, na poprzednim źródle, więc nie szukałbym w tym przyczyny.

-- Dodane 25.09.2012 (Wt) 20:23 --

Ok, problem rozwiązany. I powiem Wam, że jestem zaskoczony, bo okazuje się, że objawy były wynikiem... naprawdę totalnego przypadku.

Sygnał z mojego NBOXa leci trzema ścieżkami - jedna to HDMI do telewizora, druga i trzecia to analogowe okablowanie do DVD, Telewizora, oraz urządzenia przekazującego sygnał bezprzewodowo do drugiego telewizora. Tak, to w tym urządzeniu jest cała kwintesencja problemu.

To cudeńko nadaje na 2,4GHz (Mikrofalówka, to i WiFi - wszystko na jednym zakresie. Co oni tacy monotonni, nie mogli tego rozbić jakoś? :/) i ma całkiem sporą moc jak na takie wymiary. Postawienie telefonu komórkowego obok kończy się nie tylko zerwaniem WiFi, ale także niemal kompletnym stłumieniem sygnału GSM/3G. Nie dziwota więc, że ten malutki D-Link stojący ok. 40 cm dalej, oddzielony jedynie ścianką ze sklejki oraz dwiema płytami gips-karton na metalowych stelażach, musi się nieźle wysilać, aby chwycić sygnał z ASUSa na drugim końcu domu.

I właśnie w tym jest całe sedno problemu. Sądziłem, że skoro miałem raz dostęp do D-Linka z poziomu ASUSa oraz komputera do niego podpiętego bezpośrednio, to znaczy, że jest między nimi stabilne połączenie. Okazało się jednak, że o ile połączenie było - to do stabilności było mu daleko. Ot, chwyciło na chwilę, uznałem, że działa, ruszyłem D-Linka o parę centrymetrów... i klops. Zupełnie nie zwróciłem na to uwagi :stuck_out_tongue_winking_eye: Tak więc jak zwykle, problem siedział między ekranem klawiaturą...

Tak czy siak, wszystko działa. Przy okazji wyszło na jaw (i sądzę, że jest to warte uwagi), że ustawienia serwowane przez aplikację dedykowaną do konfiguracji D-Linka pod NBOXa to jedna wielka pomyłka!

Zamiast działać w trybie AP-Client, który jedynie zgarnia sygnał WiFi i przekazuje go dalej po kablu, ustawiłem w tej chwili tryb Repeater, który ma dwie zalety:

  • Nadal wzorowo przekazuje sygnał do podpiętych kablowo urządzeń, a oprócz tego udostępnia możliwość połączenia urządzeń bezprzewodowych,

  • Mam wzmocnioną sieć w okolicach tego zakłócającego ustrojstwa, więc o ile D-Link się męczy, to już inne urządzenia dzięki niemu korzystają z dobrodziejstw wzmocnienia.

Ostatecznie, wyniki SpeedTest.net (połączenie kablowe w obu przypadkach skrętką zgodną ze 100MBit LAN):

  • Moc sygnału odbieranego przez D-Linka: 38-48%

  • Ping: 33ms D-Link, 29ms ASUS

  • DownLink: do 9,5MBit/s D-Link, do 11MBit/s ASUS

  • UpLink: do 0,5MBit/s D-Link, do 0,7MBit/s ASUS

Czyli działa, acz słaba jakość sygnału wpływa na parametry w dość znacznym stopniu. Inna bajka, że Netia też święta nie jest, więc bez komentarza.

Sądzę, że to by było na tyle. Wątek można zamknąć :wink: