Neostrada - problemy z komunikacją bridge (P6311-07A) + PPPoE (wrt54gl)


(Zieloony) #1

Witam serdecznie,

 

Konfiguruję połączenie internetowe w nowym mieszkaniu: Neostrada do 20mb/s.

Sprzęt jaki mam przy sobie to: Livebox 2.0, Pentagram Cerberus P6311-07A [ADSL 2+], Linksys WRT54GL (soft fabryczny, bo świeżo kupiony).

 

Wpięty jestem do Liveboxa, aby móc napisać tego posta. Na speedteście moja prędkość to 14-15mb/s.

Dla testu skonfigurowałem połączenie PPPoA na Pentagramie. Na speedteście moja prędkość to... 7mb/s!

 

No więc zaczynam, wchodzę w ustawianie Pentagrama (wchodzi się tragicznie, pingować jego ip mogę od samego podpięcia, natomiast na otwarcie strony z nim czekam wieki, ładuje się połowa menu - odświeżam - jest całe). Zmieniam domyślne ip Pentagrama z 192.168.1.100 na 192.168.2.1, wyłączam DHCP, setup wizardem wprowadzam go w bridge mode.


(j24) #2

Pentagram ustawiłeś na 192.168.2.1 Linksys ma ip 192.168.1.1. Czyli te urządzenia pracują w różnych sieciach - tu masz na trzecim miejscu 2 a tu 1 czyli urządzenia tworzą 2 rożne sieci. 

Tu należy spytać w jakiej sieci jest ustawione gniazdo wejściowe w Linksys aby on zobaczył tego Pentagrama bo jak w rożnych sieciach to się nie zobaczą.

Inaczej mówiąc kabel łączący te urządzenia ma na obu końcach mieć tą sama sieć czyli jak piszesz 192.168.2.xx

Nie będzie realizował połączenia kabel gdy na jego końcach będą ustawione różne sieci.

 

 

Piszesz, że też masz Liveboxa ale jak rozumiem to tylko w zastępstwie a nie na stałe?

Bo nie bardzo rozumiem po co te 2 urządzenia konfigurować jak Livebox załatwiłby sam wszystko?


(Zieloony) #3

(Livebox jest pożyczony, nie mój, nie satysfakcjonuje mnie sprzęt takiej klasy)

 

 

To, że pracują w 2 różnych sieciach chyba nie znaczy, że nie powinno to działać, myle się? W jednej też próbowałem umieścić, tak jak pisałem… bez skutku.

 

 

Niezbyt rozumiem to sformułowanie, powiedz o co chodzi jaśniej, a zamieszczę screena.

 

PS. Dzięki za odzew.


(j24) #4

Nie uważam się za fachowca który ci pomoże w 100% ale widzę że o sieciach chociaż nie wiem zbyt wiele to chyba więcej od ciebie :slight_smile:

Tak jak pisałeś na początku niemożliwe jest abyś z komputera który ma adres 192.168.1.100 zobaczył tak bez problemu Pentagrama który ma 192.168.2.1, One są w różnych sieciach na trzecim miejscu tu 1 a tu 2

Aby to było możliwe trzeba na Linksys to umożliwić czynnością która chyba nazywa się tunelowaniem.

 

A poza tym mój poprzedni wpis udoskonaliłem bo był trochę wadliwy i musisz dojść czy kabel między tymi urządzeniami ma końcówki w jednej sieci.

Jedna sieć to tak dla laika adresy różniące się tylko ostatnią grupą.

Twój Linksys działa po jednej stronie w jednej sieci a po drugiej w innej i to trzeba zaakceptować :slight_smile:


(Zieloony) #5

Hmmm…

Czekając tu na odzew wygrałem do Linksysa Tomato 1.28. Sytuacja jest teraz taka:

Pentagram: bridge-mode, ip 192.168.1.2

Linksys: PPPoE, ip. 192.168.1.1, dhcp 192.168.1.100-150.

Podlaczylem wszystko, nie mogę spingowac pentagrama, Linksys nie nawiązuje połączenia. Są przecież w 1 sieci, tak? To co jest zle?


(j24) #6

Ja tu tylko głośno myślę a nie twierdze że tak ma być :slight_smile:

 

Jest dość oczywiste że w takiej konfiguracji działać nie będzie:

Masz w tej chwili w jednej sieci 2 urządzenia tworzące sieć - nie wiem czy fakt że wyłączyłeś  w Pentagramie DHCP jest wystarczający aby one nie miały konfliktu.

To że go ustawiłeś w tryb bridge mode czyli zrobiłeś go jako Access Pointa nie jest dla mnie rozwiązaniem bo on w pierwszym rzędzie ma być modemem i ruterem a nie Access Pointem.

To w Pentagramie masz wyjście na świat i na mój rozum w tej chwili ono jest wyłączone.

Twój ten Linksys ma ci chyba służyć jako źródło sieci bezprzewodowej w domu i jego rola jest raczej drugorzędna bo to on dostaje sygnał od Pentagramu a nie odwrotnie.

 

Generalnie to myślę że jeżeli zrobisz odwrotnie tzn może tak

Pentagram: PPPoE, ip. 192.168.1.1, dhcp 192.168.1.100-150.

To biorąc na zwykłą logikę może by i działało w jednej sieci

Ewidentnym błędem było to że DHCP przydzielało adresy inne niż był podpięty Pentagram więc jak on miałby sie tam podłączyć?


(Zieloony) #7

Mimo Twoich szczerych chęci nie pomożesz mi, niestety… To rozwiazanie jest normalne, po prostu chce wykorzystać starego, badziewnego Pentagrama jako modem, zeby specjalnie modemu nie kupowac, w tym nie ma nic dziwnego, wrt54gl to przy nim maszyna i to jasne ze on ma sie łączyć z internetem.

Co do tej sieci to nie rozumiem Twojego toku myślenia… są w jednej sieci - zle, są 2 sieciach, tez zle.


(j24) #8

Jak pogodzić tą ostatnia wypowiedź ze zdaniem

 

Ale i tak to co chcę osiągnąć to sprowadzenie Pentagrama do poziomu bridge i łączenie się poprzez Linksysa (chyba w tym setupie nie będzie strat mb/s z powodu Pentagrama, prawda?).

 

Przecież z sieci zewnętrznej podłączyłeś najpierw modem czyli Pentagram więc wszystko idzie przez niego więc jego parametry i prędkość jest dla ciebie najważniejsze i myślisz że to jakimś cudem ominiesz.

Co można zrozumieć przez powiedzenie łączenie się poprzez Linksysa _j_ak wcześniej stoi Pentagram i wszystko przesyła swoja prędkością

 

Ty patrz na przesył danych w sieci ze świata do komputera i na drodze w pierwszej kolejności postawiłeś Pentagram a potem dopiero Linksysa


(roobal) #9

W adresacji. Skroro Pentegram działa jako bridge, powinien być widoczny dla Linuksysa jako przełącznik i Linksys powinen dostawać na WAN IP od ISP. Tylko, że PPPoA ustawić prawdopodobnie powinieneś na Cerberusie, a nie na Linksysie, bo to Cerberus jest urządzeniem dostępowym.

Pokaż zrzut z Cerberusa w trybie bridge to się wyjaśni.


(Zieloony) #10

Właśnie bardzo liczyłem na to roobal , że udzielisz się w temacie, bo Ty chyba na tych sieciach zjadłeś zęby :slight_smile:

Z góry pytam, bo nikt mi nie odpowiedział, czy faktycznie Pentagram sprawi, że zamiast internetu 15mb/s będę miał 7 nawet będąc bridgem? Bo jeśli tak to w sumie te działania nie mają sensu, mogę już nim rzucić w dal z okna.

 

Zamieszczam screena z aktualnym nieudanym configiem Pentagrama.

http://iv.pl/images/28784510692719865395.jpg


(roobal) #11

Jakie tam masz jeszcze opcje w Encapsulation? Jest jeszcze inna opcja. Ja miałem co prawda innego Cerberusa, ale soft powinien być podobny. Wyłącz NAT na Cerberusie i podłącz Linksysa, jak nie pomoże, to wyłącz NAT i ustaw Cerberusa w bridge mode.

To może zależeć od modemu w Cerberusie, zobacz na statystyki jakie pokazuje ten router dla twojej linii. Tak naprawdę w tej kombinacji nic nie uzyskasz, jedynie zmiejszysz o 1ms opóźnienie na przepustowość nie ma to żadnego wpływu.


(Zieloony) #12

Szkoda mi już było czasu na głupie bawienie się z tym.

Encapsulation ustawiłem dobrze - dla Neostrady jest VC-MUX, jest jeszcze LLC. NAT był cały czas wyłączony.

 

Poszedłem do sklepu, kupiłem Tp-linka, ustawiłem identycznie i działa, bridge + PPPoE i przynajmniej prędkość poszła w górę :slight_smile:

ip modemu: 192.168.1.1 (dhcp wyłączone)

ip linksysa 192.168.88.1 (dhcp 88.100-159)