.NET Framework 4.5 - Windows XP


(Savior) #1

Witam serdecznie.

Czy ktoś może mi wytłumaczyć jak to się stało, że przed formatem miałem Frameworka 4.5 zainstalowanego na Windows XP (był to czerwiec tego roku, również po formacie). Teraz gdy próbuję zainstalować, dostaję informację, że system nie spełnia wymagań.

Korzystałem z aplikacji, która wymagała Frameworka 4.5 przed formatem, którego zrobiłem w dniu dzisiejszym. Teraz przy próbie instalacji, mam info, że wymagana jest wersja 4.5.

Nie rozumiem, jak to możliwe, że w czerwcu zainstalowałem 4.5 bez problemu na tym samym sprzęcie i systemie, a w dniu dzisiejszym pojawia się informacja "Program .NET Framework 4.5 jest nieobsługiwany w tym systemie operacyjnym."

Wersje 2.0 i 4.0 bez problemu się zainstalowały.

Czy jest jakaś możliwość, coś zainstalować przed instalacją 4.5, aby działała ? Bo ja już nie mam pomysłu...

Z góry dziękuję za odpowiedzi !

Pozdrawiam.


(Pablo_Wawa) #2

O ile się dobrze orientuję, dla Windows XP nigdy nie było dostępnej wersji MS .NET Framework 4.5 - najnowszym dla tego systemu był 4.0.

Być może jednak przed ostatnią reinstalacją systemu nie miałeś wersji 4.5, ale 4.0 oraz aplikację w (starszej) wersji, która wymagała do działania wersji 4.0, a obecnie pobrana (nowsza wersja) aplikacja wymaga już wersji 4.5? Przykładem może być Google Chrome, którego najnowsze wersje już nie zadziałają w Win XP, ale wersje starsze tak.