Net.Framework Czy potrzebne są wszystkie wersje od 1 do 4


(Kurss1005) #1

Witam,  Czy potrzebne  są wszystkie wersje od 1 do 4 Net.Framework przy  XP HE SP 3? Czy wystarczy  tylko 4?


(rgabrysiak) #2

Cześć,

I tak, i nie. Część aplikacji wymaga starszych wersji .Net Framework, część nowszych. W dużym skrócie mówiąc potrzebujesz tylko tych Frameworków, które są wymagane przez aplikacje które masz zainstalowane.


(Kurss1005) #3

Tak tylko jak mam to wiedzieć która czego potrzebuje,, czyli jak to sprawdzić? Czy wyższe wersje nie są kompatybillne z wcześniejszym,i  a może te wyższe mają w sobie wszysto to co mialy poprzednie plus swoje nowości.


(Dimatheus) #4

Hej,

 

Najczęściej aplikacja już w czasie instalacji powinna poinformować o konieczności instalacji danej platformy .NET. Bardzo wiele programów robi to automatycznie - ściąga platformę, instaluje ją, a na końcu instaluje odpowiedni program.

 

Niestety to nie działa jak Service Packi - im wyższe numery, tym gorsza kompatybilność wsteczna z poprzednim wersjami. Jeśli więc program do działania wymaga .NET Frameworka 2.0, a Ty masz wersję 3.0, to program może zadziałać; a równie dobrze może nie zadziałać. Troszkę taka loteria. :stuck_out_tongue:

 

Pozdrawiam,

Dimatheus