.NET Framework - czy trzeba instalować wszystkie po kolei?


(lostek815) #1

Czy trzeba instalować wszystkie biblioteki .NET Framework po kolei, czy wystarczy najnowsza? Bo np. z niektórymi grami instaluje się wersja 3.5, a nie trzeba mieć kolejno 1.1, 2.0 i 3.5?


(mktos) #2

Zainstaluj takie, jakich wymagają programy których używasz. Nie ma sensu posiadać "na zapas".

3.5 zawiera w sobie 2.0.

1.1 jest niezależny od innych.

4.0 jest niezależny od innych.

Aplikacja powinna zwykle działać na najnowszej zainstalowanej wersji, nawet jeśli była kompilowana pod inną (nie dotyczy zazwyczaj 1.0/1.1).


(lostek815) #3

A najnowsza to 4.0?


(XMan) #4

Tak, najnowsza to 4.0 ale możesz mieć z nią problemy.

Nie wymieniłeś, nie podałeś systemu ale moim zdaniem wystarczy do najnowszych gier, programów

.NET Framework 3.5

http://www.microsoft.com/downloads/pl-p ... 8d977d32a6

To jest on-line, radzę pobrać i zainstalować pełny pakiet redystrybucyjny:

http://download.microsoft.com/download/ ... etfx35.exe