Nie działa autorun z płyty CD


(Grzegorz Ch) #1

Witam

Posiadam Windowsa XP Home. Po włożeniu do napędu płyty CD windows nie podejmuje żadnej akcji,

w oknie mój komputer nie pojawia się ikonka napędu uzależniona od rodzaju płyty, nie pojawia

się nazwa płyty, a co za tym idzie nie startuje autorun z płyty. W oknie mój komputer jest cały

czas jednakowa standardowa ikona, jak w nią kliknę otwiera się zawartość płyty i wszystkie

operacje dyskowe na tej płycie działają poprawnie.

Po resecie, gdy od początku w napędzie jest płyta, w oknie mojego komputera widać

nazwę płyty i właściwą ikonę.

Wartość:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoDriveTypeAutoRun

mam ustawioną poprawnie na 91h.

wartość:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom\AutoRun

mam ustawioną na 1.

We właściwościach napędu->autoplay mam ustawione wszystko poprawnie.

Co jeszcze wpływa na taką sytuację?

Może jest wyłączona notyfikacja wkładania płyty, gdzie to się ustawia?


(Micromac) #2

W kluczu

zmień wartość NoDriveTypeAutoRun na 91 zamiast 91h

Ponadto sprawdz jeszcze w kluczu:

czy wartość NoDriveTypeAutoRun ustawiona jest na 91

Czy zmieniałeś coś w systemie?


(Grzegorz Ch) #3

Pisząc 91h miałem na myśli wartość szesnastkową 91, czyli jest poprawnie 0x00000091.

W drugim kluczu również mam identyczną wartość 91 szesnastkowo.


(Micromac) #4


(Marsmo) #5

grzegorzch - jeżeli nie pomoże weryfikacja ustawień za pomocą gpedit.msc , czyli:

Start -> Uruchom -> gpedit.msc

Znajdujesz: Konfiguracja komputera i Konfiguracja użytkownika - i w każdym z nich kolejno - wchodzisz

w -> Szablony administracyjne -> System i znajdujesz Wyłącz funkcję Autoodtwarzanie - opcję

tę neutralizujesz w obu Konfiguracjach, ustawiając ją na "Wyłączoną".

to pozostaje Ci skorzystanie z darmowego narzędzia Microsoftu Autoplay Repair Wizard , które

przeskanuje system pod kątem naprawy Autorunu.

http://download.microsoft.com/download/ ... utoFix.exe


(Grzegorz Ch) #6

Słuchaj od czasu instalacji ,

czyli gdzieś od roku, sporo rzeczy zmieniałem, ale w którym dokładnie momencie przestał mi

działać autorun, to nie wiem, nie zwróciłem wcześniej na to uwagi. Każda instalacja programu

dodatkowego coś tam może zmieniać w rejestrze.

Złączono Posta : 27.03.2006 (Pon) 21:56

Co do pliku gpedit.msc , to nie mam go w ogóle na dysku, wydaje mi się że powodem może być to, że posiadam system Home, który jak wiadomo jest trochę ograniczony w porównaniu z wersją Pro.

Jeśli chodzi o drugi sposób to załączam log programu:

AutoFix [V5.2.3790.67]

Time [2006-03-27 21:44:01]

Microsoft Windows Version [5.1 (Service Pack 2) <2600>]


Test [The Shell Hardware Detection service is running.] - Instance [N/A]:

    Result [AutoStart Setting]: OK

    Result [The Shell Hardware Detection service is running.]: OK


Test [Policies] - Instance [E]:

    Result [HKCU\...\Policies!NoDrives]: OK {Present}

    Result [HKCU\...\Policies!NoDriveAutorun]: OK {Absent}

    Result [HKCU\...\Policies!NoDriveTypeAutorun]: OK {Present}

    Result [HKLM\...\Policies!NoDrives]: OK {Absent}

    Result [HKLM\...\Policies!NoDriveAutorun]: OK {Absent}

    Result [HKLM\...\Policies!NoDriveTypeAutorun]: OK {Absent}

    Result [Driver level policies]: OK {

        HKLM\...\Services\cdrom!Autorun (Present) 

        HKLM\...\Services\cdrom\Parameters!Autorun (Absent) 

        HKLM\System\CCS\Enum\...!AlwaysEnable (Absent) 

        HKLM\System\CCS\Enum\...!AlwaysDisable (Absent) }


Test [Drive Notification] - Instance [E]:

    Result [Legacy Notification]: OK

    Result [AutoPlay V2 Notification]: Problems {

        Service (Silent)

        Shell (Deaf) }

    >> Repair << [Autoplay V2 Event]

      Step: No steps to take.

      Result: This AutoPlay setting cannot be fixed. Either the device is malfunctioning, or the wizard cannot determine the problem.


>> Required action: The wizard found problems but cannot fix them -> None

Jak widać jest problem z notyfikacją AutoPlay V2 Notification , który nie może zostać naprawiony przez ten wizard.

Zaznaczam, że sprzętowo wszystko jest w porządku, ponieważ jak się zaloguję na konto gościa, to Autorun działa poprawnie.


(Micromac) #7

Daj caly log z tego Autofix. Powinno jeszcze pisac po >> Required action: The wizard found problems but cannot fix them -> None

Możesz sprawdzić czy usluga Magazyn wymienny jest wlaczona.

Wejdz do Menedzera Urzadzen i odinstaluj naped, restart komputera.


(Grzegorz Ch) #8

A więc tak:

to był cały log jaki wygenerował Autofix.

Usługa Magazyn wymienny jest uruchomiona.

Usunąłem z menadżera urządzeń napęd, reset, windows się uruchomił zainstalował nowy sprzęt w postaci napędu - działa autorun. zresetowałem komputer to samo - nie działa.


(Micromac) #9

No to napewno jakiś program go wyłacza.

Czy instalowałeś jakieś programy do nagrywania płyt (np. Easy Audio CD Burner, CD Burner XP i inne) lub do montowania wirtualnych obrazów CD (np. CloneCD lub inne) ?

Jeśli tak to zobacz w ustawieniach (Tools=>Settings) czy nie ma opcji do wyłaczania lub właczania Auto Insert Notification. Powinienies sprawdzic we wszystkich tego typu programach. Nero tez np. wyłacza to ale do momentu wypalenia płytki i pozniej je przywraca a inne programy nie robia tego. Dlatego sprawdz.

Sprawdz w kluczach RUN czy nie uruchamiaja sie tego typu programy przy starcie systemu. Jak tak wyłacz je. Zobacz tez w msconfig czy właczone sa usługi typu CloneCD Systray (czy podobnie).

Sciagnij najnowsza wersję Tweak UI, znajdz pozycje My Computer => Drives i zobacz czy sa zaznaczone fajki na czerwona na wszystkich napedach i dyskach. nastepnieprzejdz na AutoPlay i zobacz czy wszystkie napedy maja zaznaczone fajki. przejdz do Types i zobacz czy jest zaznaczone Enable Autoplay for CD. Jesli nie to zaznacz.

W opcjach folderów Eksploratora sprawdź właściwości plików typu AudioCD. Powinna tam być pozycja Play, która jest domyślnie wybrana i uruchamia aplikację multimedialną, np. Windows Media Player

Sprawdź właściwości sterownika, aby upewnić się, że właczona jest funkcja automatycznego powiadamiania (auto insert notification) o włożeniu płyty

Jeśli te metody nie poskutkuja to pozostało ci odinstalowanie wszystkich programow typu jak nagrywanie (oprocz Nero) czy emulatory i wykonanie uaktualnienia Windowsa jesli ci na tym zalezy.

W wiekszości przypadków przy wypalaniu płyt wskazane jest wyłaczenie auto insert notification.

Pozdrawiam


(Marsmo) #10

No tak, fuckt! :mrgreen: Mea culpa, sorki wielkie - widać i mnie się trafia niedoczytanie, bo - że jest jak byk Home, to widać! :smiley:

Robinhio Ci tak perfekcyjnie podsunął kolejne podpowiedzi, że mogę tylko skromnie dodać:

Sprawdź sobie jeszcze taki klucz:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom

i wartość w nim zawartą REG_MULTI_SZ AutorunAlwaysDisable

Jeżeli jest tam coś świadczącego o obecności CDrom - to taki wpis usuwasz!

Wejdź również w Usługi:

Start -> Uruchom ->services.msc

Znajdź usługę pn. Wykrywanie sprzętu powłoki.

Dwuklik - i w opcji Typ Uruchamiania - wybierz Automatyczne!

I poza tym coś mi się tu niezbyt podoba:

podczas gdy Picasso twierdzi:

A ja tej lasce :wink: wierzę aż do bólu, bo jest fenomenalna - co wszyscy w sieci wiedzą! 8)


(Grzegorz Ch) #11

Odinstalowałem wszystkie programy związane z nagrywaniem, montowanie obrazów płyt, itp. Sprawdziłem gałęzie rejestru odpowiedzialene za uruchamianie programów przy strarcie systemy, powywalałem większość.

Tweak UI nie pomogło, w opcjach folderów ok.

W sterowniku ok, zresztą nie może być inaczej skoro na koncie gościa działa poprowanie.

Wczoraj doszedłem do wniosku, że już sporo czasu straciłem na poszukiwanie rozwiązania problemu i mogę stracić jeszcze więcej. Dałem sobie spokój przeinstalowałem Windowsa :slight_smile: godząc się z tym, że nie poznam przyczyny problemu.