Nie działa touchpad, w bezpiecznym trybie graf. działa


(Mazix2) #1

Nie rozwiązał się mój problem z Ubuntu, kiedy już zdążył pojawić się nowy -.-' Sytuacja wygląda tak: kiedy już uruchomię system, nie działa mi touchpad (część przesuwania jak i przyciski). Oczywiście konieczny jest restart, uruchamiam w bezpiecznym trybie graficznym, tu wszystko pięknie działa, właśnie z niego piszę, touchpad działa tu bez zarzutu, działa też i na Viście.

Komuś, kto chciałby pomóc, podaję temat z forum Ubuntu - tam pomagał mi kolega, ale nie daliśmy rady. Może ktoś po przeczytaniu topicu wpadnie na jakiś pomysł?

Temat na forum ubuntu: http://ubuntu.pl/forum/viewtopic.php?f= ... 05#p865405

Ok, to może ja streszczę co nieco.

wynik polecenia cat /proc/bus/input/devices :

I: Bus=0019 Vendor=0000 Product=0005 Version=0000

N: Name="Lid Switch"

P: Phys=PNP0C0D/button/input0

S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input0

U: Uniq=

H: Handlers=event0 

B: EV=21

B: SW=1


I: Bus=0019 Vendor=0000 Product=0001 Version=0000

N: Name="Power Button"

P: Phys=PNP0C0C/button/input0

S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input1

U: Uniq=

H: Handlers=kbd event1 

B: EV=3

B: KEY=100000 0 0 0


I: Bus=0019 Vendor=0000 Product=0001 Version=0000

N: Name="Power Button"

P: Phys=LNXPWRBN/button/input0

S: Sysfs=/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2

U: Uniq=

H: Handlers=kbd event2 

B: EV=3

B: KEY=100000 0 0 0


I: Bus=0011 Vendor=0001 Product=0001 Version=ab41

N: Name="AT Translated Set 2 keyboard"

P: Phys=isa0060/serio0/input0

S: Sysfs=/devices/platform/i8042/serio0/input/input3

U: Uniq=

H: Handlers=sysrq kbd event3 

B: EV=120013

B: KEY=4 2000000 3803078 f800d001 feffffdf ffefffff ffffffff fffffffe

B: MSC=10

B: LED=7


I: Bus=0019 Vendor=0000 Product=0006 Version=0000

N: Name="Video Bus"

P: Phys=LNXVIDEO/video/input0

S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:01/LNXVIDEO:00/input/input4

U: Uniq=

H: Handlers=kbd event4 

B: EV=3

B: KEY=3e000b 0 0 0 0 0 0 0


I: Bus=0003 Vendor=04f2 Product=b018 Version=0478

N: Name="USB 2.0 Camera"

P: Phys=usb-0000:00:1a.7-2/button

S: Sysfs=/devices/pci0000:00/0000:00:1a.7/usb1/1-2/1-2:1.0/input/input5

U: Uniq=

H: Handlers=kbd event5 

B: EV=3

B: KEY=100000 0 0 0 0 0 0


I: Bus=0011 Vendor=0002 Product=000e Version=0000

N: Name="ETPS/2 Elantech Touchpad"

P: Phys=isa0060/serio1/input0

S: Sysfs=/devices/platform/i8042/serio1/input/input6

U: Uniq=

H: Handlers=mouse0 event6 

B: EV=b

B: KEY=6420 0 30000 0 0 0 0 0 0 0 0

B: ABS=3

Ponadto podaję to, o co proszono na forum ludzi z podobnymi do mojego problemami. lspci :

00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)

00:01.0 PCI bridge: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port (rev 0c)

00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)

00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)

00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)

00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)

00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)

00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 03)

00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 03)

00:1c.5 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 6 (rev 03)

00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)

00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)

00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)

00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)

00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)

00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03)

00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)

00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)

00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)

01:00.0 VGA compatible controller: nVidia Corporation G84 [GeForce 8600M GT] (rev a1)

04:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5787M Gigabit Ethernet PCI Express (rev 02)

0a:00.0 Memory controller: Intel Corporation Turbo Memory Controller (rev 01)

0c:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)

0e:06.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)

0e:06.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)

0e:06.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)

xinput list:

⎡ Virtual core pointer id=2 [master pointer (3)]

⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]

⎜ ↳ Logitech USB Receiver id=10 [slave pointer (2)]

⎜ ↳ Logitech USB Receiver id=11 [slave pointer (2)]

⎜ ↳ ETPS/2 Elantech Touchpad id=13 [slave pointer (2)]

⎣ Virtual core keyboard id=3 [master keyboard (2)]

    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]

    ↳ Power Button id=6 [slave keyboard (3)]

    ↳ Video Bus id=7 [slave keyboard (3)]

    ↳ Power Button id=8 [slave keyboard (3)]

    ↳ USB 2.0 Camera id=9 [slave keyboard (3)]

    ↳ AT Translated Set 2 keyboard id=12 [slave keyboard (3)]

/var/log/Xorg.0.log:

[26.248] 

X.Org X Server 1.9.0

Release Date: 2010-08-20

[26.248] X Protocol Version 11, Revision 0

[26.248] Build Operating System: Linux 2.6.24-27-server i686 Ubuntu

[26.248] Current Operating System: Linux kasiula 2.6.35-30-generic-pae #56-Ubuntu SMP Mon Jul 11 21:51:12 UTC 2011 i686

[26.248] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.35-30-generic-pae root=UUID=24dd2770-fc11-482e-81e5-2b2815e2fdf8 ro quiet splash

[26.248] Build Date: 16 September 2010 05:39:22PM

[26.248] xorg-server 2:1.9.0-0ubuntu7 (For technical support please see http://www.ubuntu.com/support) 

[26.248] Current version of pixman: 0.18.4

[26.248] Before reporting problems, check http://wiki.x.org

    to make sure that you have the latest version.

[26.248] Markers: (--) probed, (**) from config file, (==) default setting,

    (++) from command line, () notice, (II) informational,

    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

[26.248] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Sep 14 20:14:02 2011

[26.248] (==) Using config file: "/etc/X11/xorg.conf"

[26.248] (==) Using system config directory "/usr/share/X11/xorg.conf.d"

[26.248] (==) No Layout section. Using the first Screen section.

[26.248] (**) |-->Screen "Default Screen" (0)

[26.248] (**) | |-->Monitor ""

[26.248] (==) No device specified for screen "Default Screen".

    Using the first device section listed.

[26.248] (**) | |-->Device "Default Device"

[26.248] (==) No monitor specified for screen "Default Screen".

    Using a default monitor configuration.

[26.248] (==) Automatically adding devices

[26.248] (==) Automatically enabling devices

[26.249] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.

[26.249] Entry deleted from font path.

[26.249] (==) FontPath set to:

    /usr/share/fonts/X11/misc,

    /usr/share/fonts/X11/100dpi/:unscaled,

    /usr/share/fonts/X11/75dpi/:unscaled,

    /usr/share/fonts/X11/Type1,

    /usr/share/fonts/X11/100dpi,

    /usr/share/fonts/X11/75dpi,

    /var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,

    built-ins

[26.249] (==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"

[26.249] (II) The server relies on udev to provide the list of input devices.

    If no devices become available, reconfigure udev or disable AutoAddDevices.

[26.249] (II) Loader magic: 0x81f8e00

[26.249] (II) Module ABI versions:

[26.249] X.Org ANSI C Emulation: 0.4

[26.249] X.Org Video Driver: 8.0

[26.249] X.Org XInput driver : 11.0

[26.249] X.Org Server Extension : 4.0

[26.250] (--) PCI:*(0:1:0:0) 10de:0407:14c0:0025 rev 161, Mem @ 0xc6000000/16777216, 0xd0000000/268435456, 0xc4000000/33554432, I/O @ 0x00002000/128

[26.250] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)

[26.250] (II) "extmod" will be loaded by default.

[26.250] (II) "dbe" will be loaded by default.

[26.250] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.

[26.250] (II) "record" will be loaded by default.

[26.250] (II) "dri" will be loaded by default.

[26.250] (II) "dri2" will be loaded by default.

[26.250] (II) LoadModule: "glx"

[26.251] (II) Loading /usr/lib/xorg/extra-modules/libglx.so

[26.283] (II) Module glx: vendor="NVIDIA Corporation"

[26.283] compiled for 4.0.2, module version = 1.0.0

[26.283] Module class: X.Org Server Extension

[26.283] (II) NVIDIA GLX Module 260.19.06 Mon Sep 13 07:01:31 PDT 2010

[26.283] (II) Loading extension GLX

[26.283] (II) LoadModule: "extmod"

[26.340] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so

[26.340] (II) Module extmod: vendor="X.Org Foundation"

[26.340] compiled for 1.9.0, module version = 1.0.0

[26.340] Module class: X.Org Server Extension

[26.340] ABI class: X.Org Server Extension, version 4.0

[26.340] (II) Loading extension MIT-SCREEN-SAVER

[26.340] (II) Loading extension XFree86-VidModeExtension

[26.340] (II) Loading extension XFree86-DGA

[26.340] (II) Loading extension DPMS

[26.340] (II) Loading extension XVideo

[26.340] (II) Loading extension XVideo-MotionCompensation

[26.340] (II) Loading extension X-Resource

[26.340] (II) LoadModule: "dbe"

[26.341] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so

[26.341] (II) Module dbe: vendor="X.Org Foundation"

[26.341] compiled for 1.9.0, module version = 1.0.0

[26.341] Module class: X.Org Server Extension

[26.341] ABI class: X.Org Server Extension, version 4.0

[26.341] (II) Loading extension DOUBLE-BUFFER

[26.341] (II) LoadModule: "record"

[26.341] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so

[26.341] (II) Module record: vendor="X.Org Foundation"

[26.341] compiled for 1.9.0, module version = 1.13.0

[26.341] Module class: X.Org Server Extension

[26.341] ABI class: X.Org Server Extension, version 4.0

[26.341] (II) Loading extension RECORD

[26.341] (II) LoadModule: "dri"

[26.341] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so

[26.342] (II) Module dri: vendor="X.Org Foundation"

[26.342] compiled for 1.9.0, module version = 1.0.0

[26.342] ABI class: X.Org Server Extension, version 4.0

[26.342] (II) Loading extension XFree86-DRI

[26.342] (II) LoadModule: "dri2"

[26.342] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so

[26.342] (II) Module dri2: vendor="X.Org Foundation"

[26.342] compiled for 1.9.0, module version = 1.2.0

[26.342] ABI class: X.Org Server Extension, version 4.0

[26.342] (II) Loading extension DRI2

[26.342] (II) LoadModule: "nvidia"

[26.342] (II) Loading /usr/lib/xorg/extra-modules/nvidia_drv.so

[26.342] (II) Module nvidia: vendor="NVIDIA Corporation"

[26.342] compiled for 4.0.2, module version = 1.0.0

[26.342] Module class: X.Org Video Driver

[26.343] (II) NVIDIA dlloader X Driver 260.19.06 Mon Sep 13 06:37:13 PDT 2010

[26.343] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs

[26.343] (++) using VT number 7


[26.344] (II) Loading sub module "fb"

[26.344] (II) LoadModule: "fb"

[26.344] (II) Loading /usr/lib/xorg/modules/libfb.so

[26.345] (II) Module fb: vendor="X.Org Foundation"

[26.345] compiled for 1.9.0, module version = 1.0.0

[26.345] ABI class: X.Org ANSI C Emulation, version 0.4

[26.345] (II) Loading sub module "wfb"

[26.345] (II) LoadModule: "wfb"

[26.345] (II) Loading /usr/lib/xorg/modules/libwfb.so

[26.345] (II) Module wfb: vendor="X.Org Foundation"

[26.345] compiled for 1.9.0, module version = 1.0.0

[26.345] ABI class: X.Org ANSI C Emulation, version 0.4

[26.345] (II) Loading sub module "ramdac"

[26.345] (II) LoadModule: "ramdac"

[26.345] (II) Module "ramdac" already built-in

[26.345] (II) NVIDIA(0): Creating default Display subsection in Screen section

    "Default Screen" for depth/fbbpp 24/32

[26.345] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32

[26.345] (==) NVIDIA(0): RGB weight 888

[26.345] (==) NVIDIA(0): Default visual is TrueColor

[26.345] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)

[26.345] (**) NVIDIA(0): Option "NoLogo" "True"

[26.345] (**) NVIDIA(0): Enabling RENDER acceleration

[26.345] (II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is

[26.345] (II) NVIDIA(0): enabled.

[27.462] (II) NVIDIA(0): NVIDIA GPU GeForce 8600M GT (G84) at PCI:1:0:0 (GPU-0)

[27.462] (--) NVIDIA(0): Memory: 524288 kBytes

[27.462] (--) NVIDIA(0): VideoBIOS: 60.84.42.00.23

[27.462] (II) NVIDIA(0): Detected PCI Express Link width: 16X

[27.462] (--) NVIDIA(0): Interlaced video modes are supported on this GPU

[27.462] (--) NVIDIA(0): Connected display device(s) on GeForce 8600M GT at PCI:1:0:0

[27.462] (--) NVIDIA(0): cPATH (DFP-0)

[27.462] (--) NVIDIA(0): cPATH (DFP-0): 330.0 MHz maximum pixel clock

[27.462] (--) NVIDIA(0): cPATH (DFP-0): Internal Dual Link LVDS

[27.505] (II) NVIDIA(0): Assigned Display Device: DFP-0

[27.505] (==) NVIDIA(0): 

[27.505] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"

[27.505] (==) NVIDIA(0): will be used as the requested mode.

[27.505] (==) NVIDIA(0): 

[27.505] (II) NVIDIA(0): Validated modes:

[27.505] (II) NVIDIA(0): "nvidia-auto-select"

[27.506] (II) NVIDIA(0): Virtual screen size determined to be 1280 x 800

[28.530] (--) NVIDIA(0): DPI set to (98, 96); computed from "UseEdidDpi" X config

[28.530] (--) NVIDIA(0): option

[28.530] (==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.

[28.530] (--) Depth 24 pixmap format is 32 bpp

[28.530] (II) NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.

[28.532] (II) NVIDIA(0): Initialized GPU GART.

[28.539] (II) NVIDIA(0): ACPI display change hotkey events enabled: the X server is new

[28.539] (II) NVIDIA(0): enough to receive ACPI hotkey events.

[28.539] (II) NVIDIA(0): ACPI brightness change hotkey events enabled.

[28.546] (II) NVIDIA(0): Setting mode "nvidia-auto-select"

[28.822] (II) Loading extension NV-GLX

[28.857] (II) NVIDIA(0): Initialized OpenGL Acceleration

[28.882] (==) NVIDIA(0): Disabling shared memory pixmaps

[28.882] (II) NVIDIA(0): Initialized X Rendering Acceleration

[28.882] (==) NVIDIA(0): Backing store disabled

[28.882] (==) NVIDIA(0): Silken mouse enabled

[28.885] (==) NVIDIA(0): DPMS enabled

[28.885] (II) Loading extension NV-CONTROL

[28.885] (II) Loading extension XINERAMA

[28.885] (II) Loading sub module "dri2"

[28.885] (II) LoadModule: "dri2"

[28.886] (II) Reloading /usr/lib/xorg/modules/extensions/libdri2.so

[28.886] (II) NVIDIA(0): [DRI2] Setup complete

[28.886] (==) RandR enabled

[28.886] (II) Initializing built-in extension Generic Event Extension

[28.886] (II) Initializing built-in extension SHAPE

[28.886] (II) Initializing built-in extension MIT-SHM

[28.886] (II) Initializing built-in extension XInputExtension

[28.886] (II) Initializing built-in extension XTEST

[28.886] (II) Initializing built-in extension BIG-REQUESTS

[28.886] (II) Initializing built-in extension SYNC

[28.886] (II) Initializing built-in extension XKEYBOARD

[28.886] (II) Initializing built-in extension XC-MISC

[28.886] (II) Initializing built-in extension SECURITY

[28.886] (II) Initializing built-in extension XINERAMA

[28.886] (II) Initializing built-in extension XFIXES

[28.886] (II) Initializing built-in extension RENDER

[28.886] (II) Initializing built-in extension RANDR

[28.886] (II) Initializing built-in extension COMPOSITE

[28.886] (II) Initializing built-in extension DAMAGE

[28.886] (II) Initializing built-in extension GESTURE

[28.886] (II) Initializing extension GLX

[28.920] (II) XKB: reuse xkmfile /var/lib/xkb/server-B20D7FC79C7F597315E3E501AEF10E0D866E8E92.xkm

[28.928] (II) config/udev: Adding input device Power Button (/dev/input/event2)

[28.928] (**) Power Button: Applying InputClass "evdev keyboard catchall"

[28.928] (II) LoadModule: "evdev"

[28.928] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so

[28.928] (II) Module evdev: vendor="X.Org Foundation"

[28.928] compiled for 1.9.0, module version = 2.3.2

[28.928] Module class: X.Org XInput Driver

[28.928] ABI class: X.Org XInput driver, version 11.0

[28.928] (**) Power Button: always reports core events

[28.928] (**) Power Button: Device: "/dev/input/event2"

[28.940] (II) Power Button: Found keys

[28.940] (II) Power Button: Configuring as keyboard

[28.940] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)

[28.940] (**) Option "xkb_rules" "evdev"

[28.940] (**) Option "xkb_model" "pc105"

[28.940] (**) Option "xkb_layout" "pl"

[28.942] (II) XKB: reuse xkmfile /var/lib/xkb/server-61818C6B46DD4F01AE1F641F27B555591612208F.xkm

[28.943] (II) config/udev: Adding input device Video Bus (/dev/input/event6)

[28.943] (**) Video Bus: Applying InputClass "evdev keyboard catchall"

[28.943] (**) Video Bus: always reports core events

[28.943] (**) Video Bus: Device: "/dev/input/event6"

[28.953] (II) Video Bus: Found keys

[28.953] (II) Video Bus: Configuring as keyboard

[28.953] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)

[28.953] (**) Option "xkb_rules" "evdev"

[28.953] (**) Option "xkb_model" "pc105"

[28.953] (**) Option "xkb_layout" "pl"

[28.954] (II) config/udev: Adding input device Power Button (/dev/input/event1)

[28.954] (**) Power Button: Applying InputClass "evdev keyboard catchall"

[28.954] (**) Power Button: always reports core events

[28.954] (**) Power Button: Device: "/dev/input/event1"

[28.965] (II) Power Button: Found keys

[28.965] (II) Power Button: Configuring as keyboard

[28.965] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD)

[28.965] (**) Option "xkb_rules" "evdev"

[28.965] (**) Option "xkb_model" "pc105"

[28.965] (**) Option "xkb_layout" "pl"

[28.965] (II) config/udev: Adding input device Lid Switch (/dev/input/event0)

[28.965] (II) No input driver/identifier specified (ignoring)

[28.966] (II) config/udev: Adding input device USB 2.0 Camera (/dev/input/event7)

[28.966] (**) USB 2.0 Camera: Applying InputClass "evdev keyboard catchall"

[28.966] (**) USB 2.0 Camera: always reports core events

[28.966] (**) USB 2.0 Camera: Device: "/dev/input/event7"

[28.981] (II) USB 2.0 Camera: Found keys

[28.981] (II) USB 2.0 Camera: Configuring as keyboard

[28.981] (II) XINPUT: Adding extended input device "USB 2.0 Camera" (type: KEYBOARD)

[28.981] (**) Option "xkb_rules" "evdev"

[28.981] (**) Option "xkb_model" "pc105"

[28.981] (**) Option "xkb_layout" "pl"

[28.983] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event4)

[28.983] (**) Logitech USB Receiver: Applying InputClass "evdev pointer catchall"

[28.983] (**) Logitech USB Receiver: always reports core events

[28.983] (**) Logitech USB Receiver: Device: "/dev/input/event4"

[28.993] (II) Logitech USB Receiver: Found 20 mouse buttons

[28.993] (II) Logitech USB Receiver: Found scroll wheel(s)

[28.993] (II) Logitech USB Receiver: Found relative axes

[28.993] (II) Logitech USB Receiver: Found x and y relative axes

[28.993] (II) Logitech USB Receiver: Configuring as mouse

[28.993] (**) Logitech USB Receiver: YAxisMapping: buttons 4 and 5

[28.993] (**) Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200

[28.993] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: MOUSE)

[28.993] (II) Logitech USB Receiver: initialized for relative axes.

[28.993] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/mouse0)

[28.993] (II) No input driver/identifier specified (ignoring)

[28.993] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event5)

[28.993] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall"

[28.993] (**) Logitech USB Receiver: always reports core events

[28.993] (**) Logitech USB Receiver: Device: "/dev/input/event5"

[29.009] (II) Logitech USB Receiver: Found 1 mouse buttons

[29.009] (II) Logitech USB Receiver: Found scroll wheel(s)

[29.009] (II) Logitech USB Receiver: Found relative axes

[29.009] (II) Logitech USB Receiver: Found absolute axes

[29.009] (II) evdev-grail: failed to open grail, no gesture support

[29.009] (II) Logitech USB Receiver: Found keys

[29.009] (II) Logitech USB Receiver: Configuring as mouse

[29.009] (II) Logitech USB Receiver: Configuring as keyboard

[29.009] (**) Logitech USB Receiver: YAxisMapping: buttons 4 and 5

[29.009] (**) Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200

[29.009] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD)

[29.009] (**) Option "xkb_rules" "evdev"

[29.009] (**) Option "xkb_model" "pc105"

[29.009] (**) Option "xkb_layout" "pl"

[29.009] (EE) Logitech USB Receiver: failed to initialize for relative axes.

[29.009] (II) Logitech USB Receiver: initialized for absolute axes.

[29.012] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event3)

[29.012] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"

[29.012] (**) AT Translated Set 2 keyboard: always reports core events

[29.012] (**) AT Translated Set 2 keyboard: Device: "/dev/input/event3"

[29.021] (II) AT Translated Set 2 keyboard: Found keys

[29.021] (II) AT Translated Set 2 keyboard: Configuring as keyboard

[29.021] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)

[29.021] (**) Option "xkb_rules" "evdev"

[29.021] (**) Option "xkb_model" "pc105"

[29.021] (**) Option "xkb_layout" "pl"

[29.021] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/event8)

[29.021] (**) ETPS/2 Elantech Touchpad: Applying InputClass "evdev touchpad catchall"

[29.021] (**) ETPS/2 Elantech Touchpad: Applying InputClass "touchpad catchall"

[29.021] (II) LoadModule: "synaptics"

[29.021] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so

[29.022] (II) Module synaptics: vendor="X.Org Foundation"

[29.022] compiled for 1.9.0, module version = 1.2.2

[29.022] Module class: X.Org XInput Driver

[29.022] ABI class: X.Org XInput driver, version 11.0

[29.022] (II) Synaptics touchpad driver version 1.2.2

[29.022] (**) Option "Device" "/dev/input/event8"

[29.080] (II) ETPS/2 Elantech Touchpad: x-axis range 32 - 544

[29.080] (II) ETPS/2 Elantech Touchpad: y-axis range 32 - 352

[29.080] (II) ETPS/2 Elantech Touchpad: device does not report pressure, will use touch data.

[29.080] (II) ETPS/2 Elantech Touchpad: finger width range 0 - 0

[29.080] (II) ETPS/2 Elantech Touchpad: buttons: left right double triple

[29.120] (--) ETPS/2 Elantech Touchpad: touchpad found

[29.120] (**) ETPS/2 Elantech Touchpad: always reports core events

[29.136] (II) XINPUT: Adding extended input device "ETPS/2 Elantech Touchpad" (type: TOUCHPAD)

[29.136] (**) ETPS/2 Elantech Touchpad: (accel) keeping acceleration scheme 1

[29.136] (**) ETPS/2 Elantech Touchpad: (accel) acceleration profile 0

[29.136] (**) ETPS/2 Elantech Touchpad: (accel) acceleration factor: 2.000

[29.136] (**) ETPS/2 Elantech Touchpad: (accel) acceleration threshold: 4

[29.168] (--) ETPS/2 Elantech Touchpad: touchpad found

[29.168] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/mouse1)

[29.168] (II) No input driver/identifier specified (ignoring)[/code]
To wszystko wtedy, kiedy działa touchpad. A kiedy działa? To czysta loteria. Raz włączę, działa, innym razem - nie. Mysz na USB działa za każdym razem.



Próbowałem już:

[code]ALT+CTRL+F1 sudo su service gdm stop Xorg -configure reboot
nie zawsze działa. Poza tym robiłem też to - dopisałem do pliku /etc/X11/xorg.conf :

Section "InputClass"

        Identifier "touchpad catchall"

        Driver "synaptics"

        MatchIsTouchpad "on"

        MatchDevicePath "/dev/input/event*"

EndSection

i dalej lipa. Raz działa, raz nie. Pomocy! :frowning:


(Powerfeniks) #2

Jaka wersja ubuntu? Na forum ubuntu znalazlem to http://ubuntu.pl/forum/viewtopic.php?f=139&t=149887&p=861242&hilit=elantech#p861242 moze bedzie przydatne, po za tym z nowa wersja ubuntu/kubuntu ktora wlasnie testuje powinny sie skonczyc twoje problemy z touchpadem, mnie od startu dziala a mam dosyc egzotyczny sprzet wlasnie z elantechem pozdrawiam.


(Mazix2) #3

Jest to wersja Ubuntu 10.10. A jaką wersję testujesz? Mówisz o 11.04? Czy już 11.10?


(nintyfan) #4

Może winny jest Xorg.conf, bo w końcu działa w bezpiecznym trybie graficznym?


(Mazix2) #5

Może i tak, ale jak go "naprawic" ?


(nintyfan) #6

Jeżeli plik istnieje w /etc/X11, to zmienić jego nazwę.


(Powerfeniks) #7

Testuje najnowsza bete 11.10 oneiric.