Nie działa usługa windows update


(Kamas89) #1

Witam! Wiem że był już podobny wątek tutaj:http://forum.dobreprogramy.pl/nie-dziala-usluga-aktualizacji-automatycznych-t248806.html ale niestety tamte porady nie pomogły :frowning:

Mam windows 7 Professional x64 (ORYGINALNY!!). Od jakiegoś czasu nie działa usługa aktualizacji. W zakładce windows update panelu sterowania wyświetla mi się następujący komunikat:

Pierwsza rzecz jaką próbowałem zrobić to ręczne uruchomienie usługi poprzez narzędzia administracyjne. Problem w tym że usługi nie ma na liście usług.

Próbowałem także zainstalować WUA 3.0 z parametrem /wuforce ale podczas instalacji wyświetla mi się błąd:

Log z HijackThis: http://www.wklejto.pl/52199

Jeśli podałem za mało informacji proszę o podpowiedź jakie dane są potrzebne do zlokalizowania problemu.

Z góry dziękuje za wszelką pomoc :slight_smile:


(Rmk) #2

Jak nie ma wejdź w Narzędzia administracyjne i sprawdź " Windows Update " powinno być po między " Windows Image Acquisition (WIA) " a " WMI Performance Adapter"


(Kamas89) #3

Sprawdzałem kilkakrotnie. Spójrz na screen: http://i50.tinypic.com/2n0oq5w.jpg Usługi nie można włączyć ani wyłączyć (zarówno w wierszu poleceń jak i konsoli mmc). Próbowałem uruchomić system w trybie diagnostycznym ale bezskutecznie. Wygląda na to że usługa została usunięta aczkolwiek nie mam pojęcia jak to możliwe. Jeśli ktoś mógłby napisać krok po kroku jak mogę na nowo zainstalować/zarejestrować tą usługę byłbym wdzięczny.


(Rmk) #4

No to coś ci się mocno skopało. Może zainstalowałeś coś co ci usunęło lub ukryło usługę WU. Ewentualnie masz piracką wersje a mówisz tylko tak ze masz oryginał.

PS: spróbuj odpalić płytę z Win7 i użyć funkcji napraw.


(Kamas89) #5

To że się mocno skopało to wiem bo od ponad tygodnia przekopuje fora internetowe i strony MS w poszukiwaniu rozwiązania.

Mam wersję oryginalną (przynajmniej teoretycznie - bo kupiłem OEM i sam go zainstalowałem nie będąc system builderem co w świetle ostatnich informacji może nie być zgodne z licencją - nie zmienia to jednak faktu że nośnik jest oryginalny a system został poprawnie aktywowany na legalnym kluczu i przedtem aktualizacje działały).

Problem polega na tym że nie wiem dokładnie w którym momencie aktualizacje przestały działać i nie wiem jaki program mógł mieć na to wpływ - może ktoś z czytelników zna taki program/wirus?

Próbowałem użyć przywracania systemu ale najwcześniejszy punkt przywracania był utworzony już po tej awarii :frowning:

Formata wolałbym uniknąć z powodu lenistwa - nie chce mi się wszystkiego przeinstalowywać.

Być może istotny jest fakt że używam antywira Microsoft Security Essentials i systemowej zapory.

Spróbuję naprawy z płytki chociaż wątpię aby to pomogło…

Edit: dostępne opcje naprawy systemu nie pomogły. Być może da się coś jeszcze zrobić w konsoli ale nie znam poleceń a “help” nie działa ;/ Ma ktoś jeszcze jakieś sugestie albo podpowiedzi?


(Kamas89) #6

Dzięki Andrew za rady ale niestety nie pomogło - nadal nie mogę zainstalować WUA :frowning: Przeskanowałem tymi programami, było kilka błędów w rejestrze - wszystkie naprawiłem. a-squared free wykrył tylko 2 trojany. Nortona nie zamierzam kupować poza tym on mi usługi nie przywróci a tylko o to mi chodzi. Iolo search and recover przwyraca usunięte pliki, nie widzę w opisie żeby przywracał usunięte usługi więc raczej się nie przyda. Wolę nie instalować 10 000 triali bo zamiast coś naprawić tylko zaśmiecę system.

Moje główne pytanie brzmi jak zainstalować na nowo tą usługę i jak zainstalować WUA 3.0?


(Banyx) #7

Panowie, nie wiem czy to ma jakiś związek bo wprawdzie u mnie nie zauważyłem aby Windows Update nie działało, jednak od mniej więcej 4 dni nie mogę w żaden sposób zainstalować sterowników do karty dźwiękowej realteka(w tym poprzez Windows Update). Tymbardziej wydaje mi się to dziwne, że podobny problem wystąpił i kilku osób w tym samym czasie

np.: post2418860.html#p2418860


(BigBoy666) #8

Mam dokładnie ten sam problem co kolega!

Wszystko co opisał jest tez u mnie.

Próbowałem z tym walczyć ale to chyba niemożliwe!!

Pomocy!


(Kamas89) #9

banyx - ja mam toshibę (model L300-11g) i żadnych problemów z dźwiękiem a też mam kartę realtek. Gdy wyszukuje aktualizacje sterownika nie ma żadnego błędu - tylko informacja że sterownik jest aktualny. U Ciebie aktualizacje działają. Na tej podstawie sądzę że te problemy nie mają związku ze sobą.

BigBoy666 - jeśli sprawdziłeś czy system jest czysty (tzn bez wirusów, robaków itd) to być może problem jest spowodowany przez program a nie wirus - pytanie brzmi jaki to program. Moje podejrzenie to iTunes i QucikTime. Dlaczego te dwa? Ponieważ miałem z nimi problem, który rozwiązałem dzięki wskazówkom na stronie MS. (Przepraszam za zmianę tematu ale może to ma jakiś związek z problemem) Otóż gdy odinstalujesz te programy może się tak zdarzyć że usuną się sterowniki do cd/dvd i w żaden sposób nie można tych sterów na nowo zainstalować. Jedynie wyjście to zainstalować iTunes i QucikTime na nowo. Podejrzewam że instalacja a potem deinstalacja i ponowna instalacja iTunes i QucikTime mogły coś namieszać w systemie - nie tylko ze sterami do cd. Zwłaszcza że w prezencie od apple razem z iTunes w paczce zainstalowało mi się masę innych programów: Bonjour, Apple software Update, Apple mobile device support itd.

Inne podejrzenia to:

  • Windows Live Sync,

  • Microsoft Visual C++ ATL Update kb973923 - x64 (już się zdarzało że poprawki coś psuły więc może to to?)

  • Inne programy microsoftu które aktualizują się przez windows update i mogły dokonywać zmian w usłudze - np. Visual Studio 2010 Beta, SQL Server, Silverlight, Net Framework 4, Web Deployment Tool

Jeśli ktoś ma podobny problem i któryś z powyższych programów to proszę pisać - może razem znajdziemy “winowajcę” i sposób na naprawę problemu :wink:

BigBoy666 jeśli wiesz kiedy dokładnie przestały Tobie działać aktualizacje to sprawdź w panelu jakie programy instalowałeś w tym czasie i napisz tutaj to porównamy :wink:

Formata wolałbym uniknąć a z update’a nie chciałbym rezygnować skoro zapłaciłem spore pieniądze za windowsa to mi się należą :stuck_out_tongue: Poza tym nie wierzę że nie ma sposobu aby ręcznie (albo jakimś skryptem) dodać usługę do systemu. No i musi być sposób aby zainstalować WUA :stuck_out_tongue:

Andrew dzięki za zaangażowanie :slight_smile:


(BigBoy666) #10

Nie powiem ci dokładnie co i jak ale programów które podałeś wogule nie mam zainstalowanych.

A co do czasu to nie wiem czy kiedyś z czystej ciekawości nie wlazłem w opcje Windows Live Sync, i nic więcej nie zrobiłem tylko zobaczyłem co to.

I bodajże od tego czasu coś się zaczęło pier… !!


(Kamas89) #11

Hmm Windows Live Sync może się aktualizować przez Windows Update więc całkiem możliwe że coś pogrzebał ;/ Zapomniałem wcześniej podać jeszcze jeden ciekawy (aczkolwiek nie wiem czy istotny) szczegół. Spójrzcie na screen: http://i46.tinypic.com/wgs50l.jpg W lewym górnym rogu obok ikony aktualizacji brakuje opisu ;|


(BigBoy666) #12

Działa! !!

Microsoft mnie olał!

Producent kompa mnie olał! ASUS

Ale znajomy robiący w firmie w której zakupiłem kompa nie! !!

W konsoli CMD wpisz: regsvr32 wuaueng.dll

I działa!!

Kumpel kazał przekazać: google nie boli :stuck_out_tongue:


(Kamas89) #13

Kurde już to wcześniej gdzieś znalazłem ale mi nie działało bo… nie włączyłem konsoli na uprawnieniach admina i nie mógł zarejestrować usługi tylko wywalał jakiś dziwny błąd :glupek2:

Wszystko działa :smiley: Wielkie dzięki! Temat zamknięty :slight_smile:


(Martyna Walas) #14

Hej!

Wasza wiadomość na tym forum uspokoiła mnie, że nie jestem jedyna na świecie z takim problemem, jak niedostępność windows update. kupiłam wczoraj laptopa z 7 i różnica jest taka, że od początku właśnie nie ma możliwości sciągnięcia aktualizacji. próbowałam sposobem, który podaliście. i dostałam komentarz, że polecenie zostało przyjęte, ale wystąpił błąd: 0x80070005 i nadal nie działa. moglibyście jakoś pomóc? będę bardzo wdzięczna. pozdrawiam serdecznie.


(Łukash) #15

makina85 , odpal tą stronkę: http://www.microsoft.com/genuine/valida … laylang=pl w IE i wykonaj opisane tam kroki > po weryfikacji > restart systemu.


(Gt Man) #16

makina85, jeżeli kolegi propozycja nie odniosła skutku tutaj masz rozwiązanie problemu:

http://windows7forum.pl/przestal-dziala … 12949.html

ostatni post


(aplauz0) #17

(Roman Atka) #18

Mi pomoglo akurat to rozwiązanie http://windows7forum.pl/przestal-dzialac-windows-update-rozwiazany-12949-t

Co prawda stary post ale może komuś się przyda. :slight_smile:


(Hakercom) #19

Witam też miałem ten problem, że windows update nie działał . Miałem trojana access . Nie mogłem zainstalować nortona nawet. Pomógł mi program Norton Power Eraser z tej strony : " http://security.symantec.com/nbrt/npe.aspx " . Trochę obawy jest, że poniszczy komputer ale wszystko śmiga .