Nie mogę rozpakować instalatora programu xampp


(hatezit) #1

Witam, dziś a właściwie od 17, próbowałem zainstalować xampp w linux. Jest plik /opt , czytałem na apachefriends instrukcję, robiłem jak było napisane. Niestety ciągle jest błąd. Paczkę pobrałem i zapisało się w katalogu pobranych. Wiele razy próbowałem i nic a poniżej daję zrzut błędu.

P.S. W linuksie jeszcze nie instalowałem xamppa.


(rgabrysiak) #2

Czy jesteś w katalogu w którym jest pobrany plik? Jeśli nie to podaj właściwą ścieżkę do niego.


(B.Andy) #3

Wykonaj tę komendę przed wypakowaniem do /opt

cd Pobrane

Czyli "przejdź do katalogu Pobrane"


(hatezit) #4

Przechodziłem do katalogu cd Pobrane i nic, ten sam komunikat wyskakiwał. A z roota próbowałem zainstalować.


(B.Andy) #5
ls

To polecenie (dir z windowsa) pokazuje wszystkie pliki i foldery, które są w danym katalogu, pamiętaj, że w Linuxie ważna jest wielkość liter, poza tym wskazówka: gdy wpisujesz w terminalu nazwę pliku/katalogu i naciśniesz klawisz TAB, automatycznie uzupełni się cała nazwa pliku eliminująć możliwość pomyłki przy pisaniu.


(saturno) #6

Błąd!

Znajdując się w katalogu domowym root-a (/root) nie można przeskoczyć tym poleceniem do katalogu znajdującego się w katalogu domowym użytkownika.

W tym przypadku należy podać pełną ścieżkę bezwzględną.

Ps.: hatezit wyniki poleceń wstawia się na forum (używając odpowiednich znaczników), a nie na fotkach.

Pisząc o instrukcji miło by było abyś podawał link do niej.

Dodane:

Chodzi o bezpośredni link do instrukcji, czyli: http://www.apachefriends.org/en/xampp-linux.html#377

Podając go zaoszczędzasz osobom chcącym ci pomóc czasu na szukanie.


(mati75) #7

http://www.devshed.com/c/a/Administrati ... ntu-Linux/


(hatezit) #8

I zainstalowało się. Ale mam drugi problem, nie jest tak jak w instrukcji, która jest tu: http://www.apachefriends.org/en/xampp-linux.html#377.

Nie startuje mi baza jak i apache mimo, że ręcznie dawałem lampp startapache i lampp startmysql ale w osobnych linijkach:) Nawet nie pokazuje sie strona xampp tylko jak wejde na localhost, to jest IT Work's.


(mati75) #9

Jak pokazuje it works to znaczy, że apache działa. Teraz musisz subdomeny i katalogi ustawić.


(hatezit) #10

Subdomeny to swoja drogą, ale czemu nie pokazuje się strona xamppa?


(cinkibolek) #11

Jaka xamppa znowu? O co chodzi, to "it works" nią jest, albo Ci inny apache działa poza xamppem.


(hatezit) #12

No tak, racja. Wcześniej przed instalacja xampp instalowałem samego apache ale nie wiem jaka komenda jest aby zdeinstalować.


(mati75) #13

Jaki system?


(hatezit) #14

System mam Ubuntu 12 ale, znalazłem komendę taką :

sudo apt-get remove apache2 apache2-utils

Ale jutro sprawdzę.


(mati75) #15

Nie remowe a remove.


(hatezit) #16

hehe literówka ale poprawiłem:) Ale dobrą komendę znalazłem?


(Macasz12) #17

Prawdopodobnie tak...

Usuwa pakiety o nazwach apache2 i apache2-utils...

Ogólnie nie wiem po co się bawiłeś. Można to było łatwo apt'em zainstalować ; )

http://www.upubuntu.com/2012/05/how-to- ... pa-on.html


(hatezit) #18

Dzięki za link, tej metody jeszcze nie kombinowałem. Ale o ile pamiętam, to chyba wymagało w repo aby się zainstalował. Nie ważne, zobaczę jutro.


(Macasz12) #19

Teraz nie rozumiem o co Ci chodzi...

BTW.

Istnieje jednak nowsza wersja xampp, więc zalecam użyć dokładnie tego poradnika: http://www.upubuntu.com/2012/07/install ... buntu.html


(hatezit) #20

Czego nie rozumiesz? Jak instaluje się jakiś program, lub program, to trzeba mieć napisane w repozytoriach deb... itd. Sam wiesz. Dzięki za drugi link.

edit z dziś.

Zainstalowałem na nowo i jest strona xampp, ale nie działa baza, gdy wchodzę na phpmyadmin to jest strona biała. nawet nie mam pliku httpdt-conf, znaczy jest ale zawartości nie ma. Gdy wpisuję lampp security to nie pyta sie mnie o haslo do bazy jak na stronach przedstawiających instalację xampp. Może w tej wersji nowszej 1.8.1 tak jest i muszę starszą pobrać.