Nie mogę zainstalować żadnego linuxa


(Itshaki) #1

Mam problem z instalacją linuxa dual boot z Windowsem 10. Próbowałem instalacji Antergos, Elementary OS, Ubuntu GNOME i Deepin’a

  • Antergos instalował się do 40% potem freeze.
  • Elementary OS czasem już przestawał odpowiadać przy logu, a czasami przy kopiowaniu plików.
  • Ubuntu GNOME prawie udało się zainstalować, przy pobieraniu pakietów freeze
  • Deepin się wywalił przy 5% i wymusił reinstalację Windowsa, bo po restarcie nie wykrywało systemu.

We wszystkich systemach live cd działał. Czasami w Elementary OS się wysypywał.
Systemy zacinały się w taki sposób, że nawet kursor stał w miejscu.
Pendrive bootowałem jako bios, nie uefi bo mam tak zainstalowanego windowsa.

Mój sprzęt:

MOBO: Asrock P67 PRO3 B3
CPU: i5-2500k
GPU: Radeon HD7950
RAM: 8GB DDR3

i trzy dyski: 2 HDD i 1 SSD. Na SSD mam zainstalowany Win 10 i tam też chcę zainstalować Linuxa (partycja root - 50GB). Na jednym z HDD chcę dać partycję /home - 200GB. Obie partycje wydzieliłem i przy każdej próbie formatowałem. Boot loader ustawiałem na SSD.

Próbowałem uruchamiać z nomodeset, z sudo, tworzyć pendrive’y Rufusem i unetbootin. Karty graficznej wymontować nie mogę, ponieważ nie mam na płycie głównej wyjścia obrazu. Nie mam już pomysłu co może być problemem. Windows zainstalował się bez przeszkód więc raczej pendrive jest ok.

Najbardziej zależy mi na instalacji Elementary OS, ale to z nim jest najwięcej problemów :frowning:
Co mogę jeszcze sprawdzić ? Skąd mogę wziąć logi instalacji ?


(FadeMind) #2

Sprawdź najnowsze manjaro. Uruchom w trybie NON FREE.

https://manjaro.org/get-manjaro/

Polecam KDE :slight_smile:

https://downloads.sourceforge.net/manjarolinux/manjaro-kde-17.0.2-stable-x86_64.iso

USB boot stwórz rufusem przez DD (nie kopiowanie plików) albo SUSE write studio


(Itshaki) #3

Ściągnąłem Manjaro GNOME ponieważ chcę mieć GUI które jest inne niż na Windowsie. Przy trybie NON FREE nie udało mi się zbootować do LiveCD, błąd:

No UMS support to radeon module!

Bez tego trybu bez problemu mi się uruchomił LiveCD. Uruchomiłem instalacje, zrobiłem partycje i w trakcie instalacji wyskoczył taki błąd:

Screenshot from 2017-08-09 11-26-14

Po czym instalacja została anulowana. Co z tym zrobić ?

Może spróbować zainstalować ponownie Windowsa w trybie UEFI, a nie Legacy i później tak samo linuxa ?


(bob999) #4

Witam. A dysk bez błędów. Skoro zaczyna się instalować to może to jest problem. Pozdrawiam


(FadeMind) #5

https://bbs.archlinux.org/viewtopic.php?id=166037

wrzucaj zdjęcia bezpośrednio do postu przez uploader obok znaku </> albo na imgur


(Itshaki) #6

W Rufusie raz odpalałem “Szukaj błędnych sektorów na urządzeniu - 1 przebieg” i wszystko przebiegło poprawnie, poza tym jak pisałem wcześniej z tego samego dysku instalowałem Windowsa więc chyba jest sprawny. Spróbuję z tym UEFI może to coś da, bo już nie mam innych pomysłów. Ewentualnie może odłączyć dwa dyski HDD i instalować tylko z SSD ?Mam wrażenie, że jest problem z instalacją bootloadera i dlatego wszystkie instalacje się sypią w pewnym momencie.


(Itshaki) #7

Czyli mam wejść na LiveCD, zeedytować /boot/grub/grub.cfg, a następnie włączyć instalację ? Czy przed instalacją jeszcze zrestartować system ?


(FadeMind) #8

Przydałby się cały dmesg i Xorg.0.log z live cd do diagnozy co tu się stało.

Nigdy sam nie edytuj /boot/* tylko najwyżej /etc/default/grub i zregeneruj gruba ( sudo update-grub)PO instalacji. Zgłoś najlepiej błąd do calamares i Manjaro Devs.:

i zawołaj dodatkowo @philm oraz @oberon by poinformować gości z Manjaro o błędzie.

Wydaje się, że mkinicpio kernel nie może poprawnie zbudować IMG i stąd wywala błąd.

Po za tym pokaż co masz w środku:

inxi -Fxz
lspci
lsusb
lsmod

(Domker) #9

Jeżeli uruchamiasz z LiveCD/LiveUSB to w momencie bootowania masz wpis do wyboru w jakim trybie chcesz uruchomić Manjaro. Wybierasz tryb (w którym poprzednio uruchomiłeś livecd/usb) i naciskasz klawisz “e” zamiast ENTER. Pojawia się linia parametrami uruchamiania kernela i wywalasz tego typu parametry: “nomodeset”, “radeon.modeset=0”, “options radeon modeset=0” i zatwierdzasz ENTERem. (zgodnie z tym, co wkleił @FadeMind)

Możesz sprawdzić, czy powyższy błąd (ten ze screena) występuje jeszcze przed instalacją - w konsoli wpisz to:
sudo mkinitcpio -v -p linux49
Jeżeli masz na końcu informację “==> Image generation successful” to błąd raczej nie powinien się powtórzyć przy instalacji systemu.
Jeżeli takowej informacji nie będzie to opcja “-v” sprawia, że wypisywane są szczegóły z działania polecenia - wklej po prostu w którym momencie się wywaliło.

Jeżeli NIE zakończy się błędem to śmiało możesz instalować system. (bo instalator robił dokładnie to samo tylko za sprawą skryptu python)
Po instalacji jeżeli się powiedzie to samo robisz w GRUB (edycje “e” itd.) i będąc już w systemie edytujesz /etc/default/grub i także usuwasz powyższe opcje, a potem “sudo update-grub” i powinny być ok.


(FadeMind) #10


(Itshaki) #11

Z parametrów miałem tylko radeon.modeset=1 więc go wywaliłem i za 3 razem instalacja przebiegła bez przeszkód :). Za 1 razem po uruchomieniu tego skryptu nie mogłem włączyć instalacji, za 2 razem był kernel panic, dopiero za 3 wszystko okej :D. W /etc/default/grub nie było żadnych parametrów do usunięcia tak samo w GRUB’ie przy starcie więc tego nie ruszałem. Nie odpalałem też sudo update-grub. Ten fix tyczył się tylko Manjaro czy mogę też spróbować użyć go przy instalacji innego distro ?


(Domker) #12

Nie we wszystkich dystrybucjach jest tak samo. Np. w OpenSUSE masz:
mkinitrd zamiast mkinitcpio również z innymi opcjami jako parametry.
Tylko plik preset może być inny w zależności też od wersji kernela.

Pierwsze, co to sprawdź, czy jest folder z ustawieniami:
/etc/mkinitcpio.d/ przykładowo w Manjaro po uaktualnieniu kernela do wersji 4.12.x masz preset “linux412” itd.

mkinitcpio to tak naprawdę tylko skrypt napisany w bashu.
Poza tym to nie jest żaden fix tylko generowanie obrazu initramfs.