Nie można zainstalować ubuntu-desktop


(Netacadcisco) #1

mam ubuntu 11.04 i po aktualizacji i restarcie nie uruchomiło się środowisko graficzne, udało mi sie doinstalować xfce

ale chce gnome...

podczas instalacji wywala taki błąd:

sudo apt-get install ubuntu-desktop

Czytanie list pakietów... Gotowe

Budowanie drzewa zależności       

Odczyt informacji o stanie... Gotowe

Nie udało się zainstalować niektórych pakietów. Może to oznaczać,

że zażądano niemożliwej sytuacji lub używasz dystrybucji niestabilnej,

w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione

z katalogu Incoming ("Przychodzące").

Następujące informacje mogą pomóc rozwiązać sytuację:


Następujące pakiety mają niespełnione zależności:

 ubuntu-desktop : Wymaga: gnome-applets ale nie zostanie zainstalowany

                  Wymaga: gnome-control-center ale nie zostanie zainstalowany

                  Wymaga: gnome-panel ale nie zostanie zainstalowany

                  Wymaga: indicator-applet-session ale nie zostanie zainstalowany

                  Poleca: empathy ale nie zostanie zainstalowany

E: Pakiety są uszkodzone

(system) #2
sudo apt-get install gnome-applets, gnome-panel, indicator-applet-session

Albo

sudo apt-get install -f

Podaj też wynik

cat /etc/apt/sources.list

(Netacadcisco) #3

gdyby to było takie łatwe...

xyz@ubuntu:~$ sudo apt-get install gnome-applets gnome-panel indicator-applet-session

Czytanie list pakietów... Gotowe

Budowanie drzewa zależności       

Odczyt informacji o stanie... Gotowe

Nie udało się zainstalować niektórych pakietów. Może to oznaczać,

że zażądano niemożliwej sytuacji lub używasz dystrybucji niestabilnej,

w której niektóre pakiety nie zostały jeszcze utworzone lub przeniesione

z katalogu Incoming ("Przychodzące").

Następujące informacje mogą pomóc rozwiązać sytuację:


Następujące pakiety mają niespełnione zależności:

 gnome-panel : Wymaga: gnome-control-center (>= 1:2.8.2-3) ale nie zostanie zainstalowany

E: Pakiety są uszkodzone

xyz@ubuntu:~$

cat /etc/apt/sources.list

# Ubuntu - podstawowe repozytoria

deb http://pl.archive.ubuntu.com/ubuntu/ natty main restricted universe multiverse

deb-src http://pl.archive.ubuntu.com/ubuntu/ natty main restricted universe multiverse

deb http://pl.archive.ubuntu.com/ubuntu/ natty-updates main restricted universe multiverse

deb-src http://pl.archive.ubuntu.com/ubuntu/ natty-updates main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu natty-security main restricted universe multiverse

deb-src http://security.ubuntu.com/ubuntu natty-security main restricted universe multiverse

deb http://extras.ubuntu.com/ubuntu natty main

deb-src http://extras.ubuntu.com/ubuntu natty main


# Ubuntu Backports

deb http://pl.archive.ubuntu.com/ubuntu/ natty-backports main restricted universe multiverse

# deb-src http://pl.archive.ubuntu.com/ubuntu/ natty-backports main restricted universe multiverse


# Ubuntu Partner

deb http://archive.canonical.com/ubuntu natty partner

# deb-src http://archive.canonical.com/ubuntu natty partner


# Medibuntu

deb http://packages.medibuntu.org/ natty free non-free

# deb-src http://packages.medibuntu.org/ natty free non-free


# GetDeb

# deb http://archive.getdeb.net/ubuntu natty-getdeb apps games

# poniewa� g��wny serwer ostatnimi czasy nie dzia�a - tutaj mirror:

deb http://mirrors.dotsrc.org/getdeb/ubuntu natty-getdeb apps games


# Ubuntu Tewak

deb http://ppa.launchpad.net/tualatrix/ppa/ubuntu natty main

# deb-src http://ppa.launchpad.net/tualatrix/ppa/ubuntu natty main


# Wine

deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu natty main

# deb-src http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu natty main

(Colzen Lan) #4

Spróbuj:

żródło:

http://ccrma.stanford.edu/planetccrma/m ... get.8.html


(roobal) #5

Pamiętaj, że 11.04 to wciąż wydanie niestabilne, więc pakiety mają prawo być uszkodzone lub brakować zależności, natomiast obraz ISO zawiera już cały komplet ale podczas aktualizacji też może wystąpić problem z zależnościami.

Pozdrawiam!