Nie umiem zainstalować aktualizacji w openSuse


(tacyer) #1

Witam,

Właśnie zainstalowałem najnowszego openSuse i nie potrafię zainstalować aktualizacji, wyskakuje mi okienko z taką treścią:

Nie znaleziono zależności pakietu.

Więcej informacji znajduje się w szczegółowym raporcie.

A w szczegółowym raporcie pisze:

openSUSE-release-12.1-1.4.x86_64 requires openSUSE-release = 12.1-1.4, but this requirement cannot be provided

No i nie wiem o co chodzi... Przeglądarki chrome też nie potrafie zaainstalować... Ściągnąłem wersję 64bitową, może to być powodem? Aczkolwiek posiadam procek Intel i5 2410M 2,3GHz.

Z góry dzięki za pomoc


(nintyfan) #2

Wklej tutaj wynik polecenia:

uname -a

(marcin82) #3

Uruchom konsolę, zaloguj się na konto roota poleceniem:

su -

Wykonaj polecenie:

zypper ref && zypper dup

Wstaw wszystko co pojawi się po tej komendzie (kopiowanie Ctrl+Shift+C), użyj tagów Code.


(tacyer) #4

Nie jestem za dobrze obeznany w linuxie oraz w jego wierszu poleceń ale chyba to zrobiłem i wyszło coś takiego:

tacyer@linux-uwlv:~> su-

If 'su-' is not a typo you can use command-not-found to lookup the package that contains it, like this:

    cnf su-

tacyer@linux-uwlv:~> su -

Hasło: 

su: niepoprawne hasło

tacyer@linux-uwlv:~> su -

Hasło: 

linux-uwlv:~ # zypper ref && zypper dup

Repository 'Aktualizacja dla openSUSE 12.1 12.1-1.4' is up to date.

Repository 'openSUSE-12.1-Non-Oss' is up to date.

Repository 'openSUSE-12.1-Oss' is up to date.

All repositories have been refreshed.

Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.

Loading repository data...

Reading installed packages...

Computing distribution upgrade...


The following NEW packages are going to be installed:

  AdobeICCProfiles bridge-utils bundle-lang-gnome-extras-en 

  bundle-lang-gnome-extras-pl cups-libs-32bit flash-player flash-player-kde4 

  gdk-pixbuf-query-loaders-32bit gimp-help-pl gstreamer-0_10-fluendo-mp3 

  gtk2-engines-32bit gtk2-tools-32bit libXi6-32bit libatk-1_0-0-32bit 

  libcairo2-32bit libcanberra-gtk0-32bit libcanberra-gtk2-module-32bit 

  libcanberra0-32bit libffi46-32bit libgdk_pixbuf-2_0-0-32bit 

  libgio-2_0-0-32bit libglib-2_0-0-32bit libgmodule-2_0-0-32bit 

  libgobject-2_0-0-32bit libgstreamer-0_10-0-32bit libgthread-2_0-0-32bit 

  libgtk-2_0-0-32bit libjasper1-32bit libjpeg62-32bit libltdl7-32bit 

  libpango-1_0-0-32bit libpcre0-32bit libpixman-1-0-32bit libpng14-14-32bit 

  libtiff3-32bit libvorbisfile3-32bit libxml2-32bit nspluginwrapper 

  oxygen-icon-theme-large pango-tools-32bit parallel-printer-support 

  patterns-openSUSE-kde4_pure poppler-data tunctl unrar 


The following packages are going to be upgraded:

  Mesa MozillaFirefox MozillaFirefox-branding-openSUSE 

  MozillaFirefox-translations-common NetworkManager NetworkManager-kde4-libs 

  NetworkManager-openvpn-kde4 NetworkManager-pptp-kde4 NetworkManager-vpnc-kde4 

  SuSEfirewall2 aaa_base aaa_base-extras acpid akonadi akregator amarok apper 

  autofs bash bash-doc bind-libs bind-utils cifs-utils cracklib cron cronie 

  cryptsetup curl device-mapper dhcp dhcp-client digikam digikam-doc 

  digikam-lang dolphin eject ft2demos glibc glibc-32bit glibc-locale 

  glibc-locale-32bit grub gstreamer-0_10-plugins-good gtk2-data 

  gtk2-immodule-amharic gtk2-immodule-inuktitut gtk2-immodule-thai 

  gtk2-immodule-vietnamese gtk2-tools gtk3-data gtk3-immodule-amharic 

  gtk3-immodule-inuktitut gtk3-immodule-thai gtk3-immodule-vietnamese 

  gtk3-tools hwinfo icedtea-web iproute2 iptables java-1_6_0-openjdk 

  kaddressbook kdebase4-libkonq kdebase4-nsplugin kdepasswd kdepim4 

  kdepim4-wizards kdialog keditbookmarks kernel-desktop kfind kio_iso klogd 

  kmail knotes konqueror konqueror-plugins konsole kontact konversation 

  konversation-lang korganizer krb5 krb5-32bit libblkid1 libcolord1 libcrack2 

  libcryptsetup1 libcurl4 libfreetype6 libfreetype6-32bit libgnutls28 

  libgtk-2_0-0 libgtk-3-0 libicu libjasper1 libkdepim4 libkonq5 libldb1 

  libmount1 libmsn0_3 libnm-glib-vpn1 libnm-glib4 libnm-util2 libopenssl1_0_0 

  libopenssl1_0_0-32bit libpixman-1-0 libpng14-14 libpolkit-qt-1-1 

  libpoppler-glib8 libpoppler-qt4-3 libpoppler18 libproxy1 

  libproxy1-config-gnome3 libproxy1-config-kde4 libproxy1-networkmanager 

  libproxy1-pacrunner-webkit libpyglib-gi-2_0-python0 libpython2_7-1_0 

  libpython2_7-1_0-32bit libqt4 libqt4-qt3support libqt4-sql libqt4-sql-mysql 

  libqt4-sql-sqlite libqt4-x11 libreadline6 libreoffice libreoffice-base 

  libreoffice-base-drivers-mysql libreoffice-base-extensions libreoffice-calc 

  libreoffice-calc-extensions libreoffice-draw libreoffice-draw-extensions 

  libreoffice-filters-optional libreoffice-help-pl 

  libreoffice-icon-theme-crystal libreoffice-icon-theme-galaxy 

  libreoffice-icon-theme-hicontrast libreoffice-icon-theme-oxygen 

  libreoffice-impress libreoffice-impress-extensions libreoffice-kde4 

  libreoffice-l10n-pl libreoffice-mailmerge libreoffice-math libreoffice-pyuno 

  libreoffice-writer libreoffice-writer-extensions libsensors4 libsmbclient0 

  libtalloc2 libtalloc2-32bit libtdb1 libtdb1-32bit libtevent0 libusbmuxd1 

  libuuid1 libuuid1-32bit libvorbis0 libvorbis0-32bit libvorbisenc2 

  libvorbisenc2-32bit libvorbisfile3 libwbclient0 libxml2 libxml2-python 

  libxslt1 libxtables7 libzip2 logrotate lvm2 mozilla-nspr mozilla-nss 

  nfs-client okular openSUSE-release-dvd openssh openssh-askpass openssl 

  opensuse-manuals_en oxygen-gtk pam-modules perl perl-base plasmoid-folderview 

  plasmoid-networkmanagement pm-profiler pm-utils polkit-default-privs 

  polkit-kde-agent-1 poppler-tools postfix pullin-flash-player python 

  python-base python-cupshelpers python-gobject python-gobject-cairo python-xml 

  readline-doc release-notes-openSUSE rsyslog samba samba-client 

  samba-client-32bit sane-backends sane-backends-autoconfig splashy 

  splashy-branding-openSUSE sudo sysconfig syslog-service 

  system-config-printer-applet system-config-printer-common 

  system-config-printer-dbus-service systemd systemd-sysvinit tar timezone 

  timezone-java udev-configure-printer udisks usbmuxd util-linux vim vim-base 

  vim-data w3m wpa_supplicant xorg-x11 xorg-x11-xauth yast2-backup 

  yast2-kerberos-client yast2-ldap-client yast2-mail yast2-ntp-client 

  yast2-security zlib zlib-32bit 


240 packages to upgrade, 45 new.

Overall download size: 427.6 MiB. After the operation, additional 147.3 MiB 

will be used.

Continue? [y/n/?] (y): ^Clinux-uwlv:~ #

(marcin82) #5

No i jest OK. Użyj od czasu do czasu konsoli do aktualizacji (jako root):

zypper ref && zypper dup

========

Teraz uruchom menedżera aktualizacji i sprawdź czy będzie coś pyskował :smiley: Błędy wynikały prawdopodobnie z tego, że od momentu instalacji nie wykonałeś pełnej aktualizacji systemu.


(tacyer) #6

Jak mi to wyskoczyło to na dole pytało sie coś czy Yes lub No, to dałem Yes, potem "poczytałem" jakieś 2 licencje, zaakceptowałem i coś się robi, chyba instaluje w tym zyperze ino nie wiem czy to są aktualizacje, czy sobie jakies problemy robie :x


(marcin82) #7

Leci normalnie aktualizacja - nie ma żadnych ostrzeżeń o błędach ani popsutych zależności - bo by to od razu zgłosił zypper w konsoli. Poczekaj do końca - zrestartuj komputer i zobacz czy będą komunikaty o błędach.


(tacyer) #8

Ok dzięĸi :slight_smile: a po tym wszystkim Chrome też się zainstaluje normalnie? ;p Bo ja już z obawy ściągam susła 32bitowego xd aczkolwiek na mój procek odpowiedni jest chyba ten co mam? 64bit tak? :slight_smile:


(marcin82) #9

Najpierw sprawdź czy jest w repozytoriach:

zypper se chrome

zypper se chromium

Chromium powinno być w oficjalnych repozytoriach. Dodatkowo tam było jakieś dodatkowe repozytorium, które trzeba włączyć dla pakietów niewolnych - repozytorium Non_OSS. Staraj się nie instalować programów z pakietów *.rpm spoza dystrybucji. To już musisz pomału sam rozgryźć:

http://pl.opensuse.org/Repozytoria_paki ... um_Non-OSS


(tacyer) #10

Ale ja otwarłem mozillą google, wyswietliło mi się pobranie chroma, klikłem i miałem wybór: chrome 32bit dla ubuntu, debiana, tak samo 64bit, oraz 32bit dla fedory, opensuse oraz 64, ściągłem 32 i 64 i nic nie działało, podczas instalacji ciągle leciał pasek, a na górze pisało coś o potwierdzeniu umowy licencyjnej i nic nie dało się zrobić... powtórzył bym tą operacje aby napisać Ci dokładnie co tam pisało, ale zypper działa :stuck_out_tongue:


(marcin82) #11

Zainstalowałeś Google Chrome czy Chromium?


(tacyer) #12

Ściągłem chroma, ale nie zainstalowałem bo tak jak pisałem, pisało coś o potwierdzeniu licencji, ale nic nie wyskoczyło ani nic...

http://www.picfront.org/uploaded.php?images=jMXVwCmhdP

Masz zrzut ekranu


(marcin82) #13

Masz pakiet Google Chrome na dysku twardym? Podaj wynik polecenia:

ls -al ~/Pobrane

albo:

ls -al ~/Downloads

Na stronie wybierasz paczkę i potwierdzasz licencję. Pakiet powinien zostać conajmniej pobrany. ======== EDYCJA:

Tego nie dopatrzyłem :smiley: Otwórz terminal, zaloguj się na roota:

su root

Przejdź do katalogu pobierania:

cd /home/tacyer/Pobrane

i wykonaj instalację takim poleceniem:

rpm -ivh nazwa_pakietu.rpm

Wstaw wszystko co wyświetli się po ostatnim poleceniu.


(tacyer) #14

Wszystko już śmiga, pisze z chroma ;p Tu masz loga z zyppera:

tacyer@linux-uwlv:~> su -

Hasło: 

linux-uwlv:~ # zypper ref && zypper dup

Repository 'Aktualizacja dla openSUSE 12.1 12.1-1.4' is up to date.

Retrieving repository 'google-chrome' metadata [done]

Building repository 'google-chrome' cache [done]

Repository 'openSUSE-12.1-Non-Oss' is up to date.

Repository 'openSUSE-12.1-Oss' is up to date.

All repositories have been refreshed.

Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.

Loading repository data...

Reading installed packages...

Computing distribution upgrade...


Nothing to do.

linux-uwlv:~ #

Wszystko ok? 8)


(marcin82) #15

No jak nie jak tak :smiley: Teraz próbuj Google Chrome isntalować ;]


(tacyer) #16

Heh już pisze z Niego ; D Dzięki wielkie za pomoc, jc to sie jeszcze zgłosze o pomoc :stuck_out_tongue:


(marcin82) #17

You're welcome :smiley: