Niechciane wybieranie systemu przy uruchamianiu komputera


(Do Ka) #1

Chodzi o to, że teoretycznie mam 2 systemy windows, jeden z nich działa, a drugi był instalowany, ale wystąpił jakiś błąd przy instalacji. Robiłem to, gdy z tym pierwszym były jakieś problemy i nie chciał się włączyć. Wymyśliłem sobie, że sposobem na to będzie instalacja drugiego, ale nagle ten pierwszy zaczął działać:stuck_out_tongue: Mam windows XP Media Center, drugi był taki sam z tego co pamiętam chodź pojawia się w wyborze co innego, ale to chyba nieistotne.

Na zdjęciach pokażę co się pojawia:

1.

p2160102ja0.jpg

muszę wybrać pozycję pierwszą, a standardowo wybiera się druga. Wtedy wyskakuje takie coś:

2.

p2210012ih4.jpg

i muszę restartować komputer

Da się usunąć ten drugi system jakoś?


(matiit) #2

Było wiele razy:

:arrow: viewtopic.php?f=13&t=223553&p=1478566&hilit=boot+ini#p1478566

Jak to CI nie pomoże to poszukaj pod hasłem boot.ini


(Do Ka) #3

No tutaj niestety nic o tym nie ma :frowning: Szukam także na forum lecz nigdzie nie jest poruszany mój problem :frowning:


(Leon$) #4

Edytuj plik boot.ini usuń nie potrzebny wpis lub zawartość tego pliku wklej na forum

1.podaj partycję na której jest system który działa

:slight_smile:


(Do Ka) #5

Mógłbyś mnie jedynie nakierować jak mam to zrobić? :stuck_out_tongue:


(Norbert Stepniakowski) #6

Wchodzisz w mój komputer>dysk C. W pasku adresu (masz już c:) piszesz boot.ini Otwiera Ci się notatnik i tam usuwasz niepotrzebny wpis lub kopiujesz to tutaj jak pisał już kolega Leon$.


(Do Ka) #7

Robię tak, ale wyskakuje, że Nie można znaleźć i mam się upewnić czy ścieżka jest poprawna:P

Próbowałem też wyszukać ten plik, lecz to też nic nie dało:|


(Leon$) #8

Poczytaj http://forum.centrumxp.pl/default.aspx?g=posts&t=108297

:slight_smile:


(Do Ka) #9
[Boot Loader]

Timeout=5

Default=C:\$WIN_NT$.~BT\BOOTSECT.DAT

[Operating Systems]

multi(0)disk(0)rdisk(0)partition(4)\WINDOWS="Windows XP Media Center Edition" /noexecute=optin /fastdetect

C:\$WIN_NT$.~BT\BOOTSECT.DAT="Microsoft Windows XP Professional Setup"

Już tu widać, że Microsoft Windows XP Professional Setup jest tu niepotrzebny tylko nie wiem co z tym zrobić, nie chcę nic pochrzanić;)


(Leon$) #10

Na jakiej partycji znajduje się działający system “Windows XP Media Center Edition”?

:slight_smile:


(Do Ka) #11

C

:wink: sorki :stuck_out_tongue:


(Leon$) #12

Wygląda na to że powinieneś mieć taką zawartość pliku boot.ini

[boot loader]

timeout=5

default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows XP Media Center Edition" /noexecute=optin /fastdetect

:slight_smile:


(Do Ka) #13

No ok, dzięki:]

Ale tak patrząc w przyszłość, to co się stanie jeśli wystąpi jakiś błąd i system np. w ogóle się nie włączy? Co w takim wypadku mam zrobić?:>


(De Niro) #14

jeżeli chcesz skasowac drugi wpis to:

W razie kłopotów, Konsloa odzyskiwanie i komenda bootcfg /rebuild

Przy jednym dysku, nie powino być problemów z plikiem BOOT.INI

Pozdrawiam


(Do Ka) #15

A jednak, wszystko się pochrzaniło. Edytowałem boot.ini tak jak podyktował mi Leon$. Na początku zniknęło wybieranie systemu, lecz windows się nie ładował, a pokazywał się jedynie ekran z informacją, że brakuje bodajże pliku hall.dll w Windows/system 32 i należy go “reinstall” (po angielsku było więc tak piszę :P). Przypomniałem sobie co napisał De Niro:

więc czym prędzej włączyłem ów konsolę, a tam miałem wybrac system, na którym ma byc to przeprowadzane czy coś, lecz miałem do wyboru jedynie D:\Windows, a ja na 100% mam windowsa na C:\ :expressionless: więc ta konsola na nic się nie przydała, choc popróbowałem i rebuild, i fixboot czy coś w tym stylu ale nic się nie zmieniło.

Ja spasowałem, poprosiłem o pomoc kolegę, który powiedział, że wie o co chodzi i da radę a w konsekwencji chyba jeszcze bardziej namieszał.

Przyszedł, odpalił mi kompa z XUBUNTU (będę pisał jak ja to widziałem więc przepraszam za ew. błędy czy inne śmieszności :slight_smile: ), kombinował coś z boot.ini, które teraz znajdowało się na partycji D:\ , próbowaliśmy zmienic boot.ini na stare, ale to nic nie dało. Bawił się jeszcze na różne sposoby w konsoli odzysk. - też nic. W końcu na tym swoim Xubuntu znalazł, że D jest partycją bootującą, starał się to zmienic, ale jedyne co z tego wynikło, to to, że teraz podczas włączania wyskakuje komunikat:

NTLDR is missing

Sporą lekturkę napisałem, no ale myślę, że powinno to byc szczegółowo opisane. Mam nadzieję, że mi pomożecie bo chcę jak najmocniej uniknąc formata, dopiero co udało mi się rozprawic z wirusami:P