Niemożliwa instalacja sterownika własnościowego do NVIDII GTX 660, Ubuntu 14


(Pokrzywek321) #1

Przejdę od razu do rzeczy.

Laptop: Lenovo y580

Karta graficzna: NVIDIA GTX660m

Zinegrowany Układ: Intel HD Graphies 4000 (o ile się nie mylę - mało istotne)

System: Linux Ubuntu 14.04 (trusty), GNOME 3.8.4, Kernel 3.13.0-30-generic

Na dzień dzisiejszy wszystkie aktualizacje zainstolwane.

 

Parę tygodni temu po próbie wybrania jakiegokolwiek sterownika własnościowego z tej listy:

 

i próbie ponownego uruchomienia laptopa, cała "akcja" kończyła się fiaskiem, ponieważ pojawiał się błąd o treści: (parafrazując) "nie masz karty graficznej". Do dzisiaj korzystałem ze sterownika Nouveau, jednak postanowiłem się za to zabrać. Ku mojemu zdziwieniu po wybraniu sterownika własnościowego i ponownym uruchomieniu komputera, wszystko działało jak należy... tzn. laptop włączył się, unity działa... czego chcieć więcej. Kiedy jednak chciałem otworzyć ustawienia NVIDIA X Server Settings:

 

i zmienić kartę graficzną na NVIDIA pojawił się problem.

 

 

Nie wiem co to oznacza, ale wydaje mi się, że mimo zainstalowania sterownika własnościowego dalej nie mam możliwości korzystania z karty graficznej NVIDII. Trochę to irytujące - nie mam żadnych opcji, ustawień związanych z tą kartą. Przeszukałem cały Internet, terminal pęka w szwach od komend. Próbowałem już chyba wszystkiego. Da się coś zrobić?


(MrQ) #2

W tym laptopie masz technologię Nvidia Optimus. https://wiki.ubuntu.com/Bumblebee


(Jusko) #3

 

Tak, ale NVidia sama się za to wzięła i zaadaptowała obsługę Optimusa do driverów jakoś nie tak dawno temu. Choć to zawsze jakieś rozwiązanie - obsługa od NV ponoć aż tak rewelacyjna nie jest.

 

A czy jeśli odpalisz panel NVidii z konsoli i postarasz się przestawić tę opcję, to jest jakiś output w konsoli?


(MrQ) #4

 

Niestety w dość kulawy sposób, bumblebee jest wydajniejszym i pewniejszym rozwiązaniem.


(Pokrzywek321) #5

Włączam Ubuntu i komunikat, znany mi z wcześniej:

http://i57.tinypic.com/2a7et1k.jpg

 

Tym razem jednak nie da się przywrócić ustawień domyślnych. Włączenie systemu w trybie awaryjnym w bezpiecznym trybie graficznym nie pomaga. Jest dostęp do konsoli, ale nie wiem jak przywrócić sterowniki Nouveau, bo tylko na nich (znając moje wcześniejsze doświadczenia) włączy się Linux…


(pppoe) #6

Sterownik grafiki, który ma być używany można zmienić z pliku konfiguracyjnym X11.

Gdy uruchomisz system przejdź do basha kombinacją Ctrl+Alt+F1 , a następnie zaloguj się w nim.

Nadaj sobie uprawnienia administratora poprzez sudo -s , następnie:

nano /etc/X11/xorg.conf

Odszukaj pole Driver w sekcji Device i zmień “nvidia” na “nouveau”

Następnie zapisz zmiany kombinacją Ctrl+O po czym opuść edytor za pomocą Ctrl+X, a na koniec:

reboot

Powinno przywrócić “nouveau” do użytku bez konieczności deinstalacji własnościowego sterownika “nvidia”, ale nie wiem bo z tego co mi wiadomo te sterowniki się ze sobą “gryzą”. Ja osobiście “nouveau” nawet nie instalowałem, bo moja nouveau nie działa na mojej przestarzałej karcie, mimo, żeznajduje się na liście obsługiwanych. Tak czy inaczej nie potrzebny mi ten sterownik. Mam Debiana ze starszym XWindow bo na aktualnym z kolei sterownik “nvidia” nie działa, bardzo stary sprzęt.


Z tego co czytałem to można chyba wyłączyć jedną z kart w BIOSIe, tak więc spróbuj deaktywować kartę Intela.


(ra-v) #7

Najnowsze sterowniki od producenta mają końcówkę 331.89. 

Ja instaluje sterowniki tylko i wyłącznie z konsoli na wyłączonych Xach (uwaga - to wymaga instalacji dodatkowego pakietu z nagłówkami jądra) i praktycznie jeśli sterowniki się zainstalują to system sam wstaje.

 

Niestety nigdy tego nie robiłem na lapku ani na lapku z jakimikolwiek 2 kartami - na swoim mam tylko jedną kartę - ATI. 


(Agatonster) #8

pokrzywek

Proszę zapoznać się z tematem i poprawić tytuł tematu na konkretny, mówiący o problemie. W celu dokonania zaleconej korekty proszę użyć przycisku Edytuj, umieszczonego w prawym dolnym rogu swojego posta, następnie opcji Użyj pełnego edytora, znajdującej się pod edytowanym postem.

Zignorowanie zalecenia będzie skutkowało przeniesieniem tematu do Kosza.


(treuer25) #9

Zainstaluj sterowniki Nvidii z PPA Edgers

Natomiast gdy ci się nie uruchamia ubuntu bo źle się sterowniki zainstalowały bierzesz wtedy Live CD z Ubuntu  i startujesz następnie :

 


(marcin82) #10

 

Po ‘chroot’ nie potrzeba już sudo.


(Pokrzywek321) #11

Serdeczne dzięki za odpowiedzi. Postaram się jak najszybciej wcielić w życie w/w wskazówski. Szczerze mówiąc trochę sobie zapomniałem o Ubuntu, przez ostatni tydzień głównie używałem Windowsa. Dzisiaj zainstalowałem wersję 64-bitową (nie wiem jak to się stało, ale tamta była 32… mniejsza o to). Po drodze napotkałem na małe problemy (GRUB nie chciał się wyświetlić), ale aktualizacja z poziomu terminala pomogła. Dzisiaj już nie mam czasu, ale jutro postaram się coś działać z tym sterownikiem. :slight_smile:

Aktualizacja: OK, wszystko w porządku. Po instalacji Ubuntu w wersji 64 bitowej i wpisaniu kawałka kodu:

sudo apt-get install nvidia-319 nvidia-settings-319 nvidia-prime

wszystko działa jak powinno… prawie wszystko, ale to inna historia. :slight_smile: Dzięki za pomoc i poświęcenie czasu.