Niemożność instalacji fluxboxa poprzez błąd dot. libstdc++


(system) #1

Witam!

Ściągnąłem fluxboxa, wersję 1.3.1. Przy "./configure" oddaje mi komunikat:

"configure: error: Your libstdc++ doesn't have the sstream or strstream classes"

Da się coś z tym zrobić? Dystrybucja to openSUSE 11.4 x64.


(RubasznyRumcajs) #2
  1. jakie są wymagania opisane przez twórców fluxboksa?

  2. jaką masz wersje libstdc++?


(Qba Lukaszczyk) #3

A openSuSE nie ma fluxboksa w repo?


(system) #4

openSUSE nie ma flux'a w repo.

libstdc++ = 3.3.3-27.4 oraz 4.5.1_20101208-9.8.


(marcin82) #5

Sprawdź, czy masz zainstalowaną paczkę *.dev tej biblioteki. Wyniki z Google:

http://www.google.pl/search?q=Your+libs ... =firefox-a

sugerują aktualizację gcc.


(system) #6

Okej, ./configure, make i make install powiodło się.

Wedle Fluxboxk-wiki, aby dodać Fluxboxa do listy środowisk / menedżerów powinienem....

http://fluxbox-wiki.org/index.php?title=GDM

W każdym razie metoda pierwsze nie trybi. Nie mam tych ścieżek. W /etc/gdm mam:

custom.conf Init PostLogin PostSession PreSession Xsession

z czego Xsession jest plikiem, a drugiej możliwości nie rozważałem, ba! tam nawet nie podfolderu gdm i całej reszty.

Jeśli natomiast chodzi o drugą metodę... Po prostu jej nie próbowałem, ale wnioskując z jej przebiegu, czy można coś w podobie przeprowadzić na gdm z zainstalowanym już XFCE?


(marcin82) #7

Spróbować nie zaszkodzi. Powinny zostać zastosowane ustawienia z lokalnego ~/.Xsession. W razie czego usuniesz ten plik:


(system) #8

Niestety powyższa metoda nie działa. Jakieś sugestie?

Doszedłem i wszystko działa jak powinno działać.


(RubasznyRumcajs) #9

http://software.opensuse.org/search?q=f ... .4〈=en proszę bardzo :slight_smile: