Niestandardowa rozdzielczość w openSuSE -problem z xorg.conf


(Kpc21) #1

Mam problem z plikiem xorg.conf w openSuSE 10.3. Korzystam z nietypowej rozdzielczości 1280x768. Po pierwszym uruchomieniu system ustawił mi "kosmiczną" rozdzielczość 800x600. Odpaliłem więc SaX-a, chcąc przestawić rozdzielczość na właściwą, jednak takiej tam nie znalazłem. Znalazłem wtedy w Internecie, że konieczna jest edycja pliku /etc/X11/xorg.conf. Do sekcji Mode dodałem linię Modelines wygenerowaną za pomocą komendy gtf oraz dodałem właściwy wpis w sekcji Screen. Po restarcie X-ów KDE już się nie uruchomiło (terminal wywalił po angielsku info o błędnej linii 100) i musiałem podmienić xorg.conf na kopię, zrobioną przed edycją.

Przy edycji xorg.conf pomagałem sobie tym postem (dotyczy on Mandrivy, ale w SuSE xorg jest bardzo podobny):

http://www.forum.zlotekrople.prh.pl/sho ... p?p=379815

Teraz moje pytanie:

Co mam zrobić, aby wreszcie KDE działało pod rozdzielczością 1280x768??

Mój xorg.conf:

# /.../

# SaX generated X11 config file

# Created on: 2008-01-28T18:11:56+0100.

#

# Version: 8.1

# Contact: Marcus Schaefer , 2005

# Contact: SaX-User list 

#

# Automatically generated by [ISaX] (8.1)

# PLEASE DO NOT EDIT THIS FILE!

#


Section "Files"

  FontPath "/usr/share/fonts/misc:unscaled"

  FontPath "/usr/share/fonts/local"

  FontPath "/usr/share/fonts/75dpi:unscaled"

  FontPath "/usr/share/fonts/100dpi:unscaled"

  FontPath "/usr/share/fonts/Type1"

  FontPath "/usr/share/fonts/URW"

  FontPath "/usr/share/fonts/Speedo"

  FontPath "/usr/share/fonts/PEX"

  FontPath "/usr/share/fonts/cyrillic"

  FontPath "/usr/share/fonts/latin2/misc:unscaled"

  FontPath "/usr/share/fonts/latin2/75dpi:unscaled"

  FontPath "/usr/share/fonts/latin2/100dpi:unscaled"

  FontPath "/usr/share/fonts/latin2/Type1"

  FontPath "/usr/share/fonts/latin7/75dpi:unscaled"

  FontPath "/usr/share/fonts/baekmuk:unscaled"

  FontPath "/usr/share/fonts/japanese:unscaled"

  FontPath "/usr/share/fonts/kwintv"

  FontPath "/usr/share/fonts/truetype"

  FontPath "/usr/share/fonts/uni:unscaled"

  FontPath "/usr/share/fonts/CID"

  FontPath "/usr/share/fonts/ucs/misc:unscaled"

  FontPath "/usr/share/fonts/ucs/75dpi:unscaled"

  FontPath "/usr/share/fonts/ucs/100dpi:unscaled"

  FontPath "/usr/share/fonts/hellas/misc:unscaled"

  FontPath "/usr/share/fonts/hellas/75dpi:unscaled"

  FontPath "/usr/share/fonts/hellas/100dpi:unscaled"

  FontPath "/usr/share/fonts/hellas/Type1"

  FontPath "/usr/share/fonts/misc/sgi:unscaled"

  FontPath "/usr/share/fonts/xtest"

  FontPath "/opt/kde3/share/fonts"

  InputDevices "/dev/gpmdata"

  InputDevices "/dev/input/mice"

EndSection


Section "ServerFlags"

  Option "AllowMouseOpenFail" "on"

EndSection


Section "Module"

  Load "dbe"

  Load "type1"

  Load "freetype"

  Load "extmod"

  Load "glx"

EndSection


Section "InputDevice"

  Driver "kbd"

  Identifier "Keyboard[0]"

  Option "Protocol" "Standard"

  Option "XkbLayout" "pl"

  Option "XkbModel" "microsoftpro"

  Option "XkbRules" "xfree86"

EndSection



Section "InputDevice"

  Driver "mouse"

  Identifier "Mouse[1]"

  Option "Buttons" "5"

  Option "Device" "/dev/input/mice"

  Option "Name" "Elan Microelectronics PS/2+USB Mouse"

  Option "Protocol" "explorerps/2"

  Option "Vendor" "Sysp"

  Option "ZAxisMapping" "4 5"

EndSection



Section "Monitor"

  DisplaySize 420 257

  HorizSync 30-50

  Identifier "Monitor[0]"

  ModelName "1280X768@60HZ"

  Option "DPMS"

  VendorName "--> LCD"

  VertRefresh 48-61

  UseModes "Modes[0]"

EndSection



Section "Modes"

  Identifier "Modes[0]"

  Modeline "1024x768" 65.26 1024 1080 1184 1344 768 769 772 796

  Modeline "1024x768" 56.00 1024 1072 1104 1184 768 771 775 790 +HSync -Vsync

  Modeline "800x600" 38.85 800 832 912 1024 600 601 604 622

  Modeline "800x600" 35.50 800 848 880 960 600 603 607 618 +HSync -Vsync

  Modeline "1440x900" 89 1440 1488 1520 1600 900 903 909 926 +hsync +vsync

EndSection



Section "Screen"

  DefaultDepth 24

  SubSection "Display"

    Depth 15

    Modes "1024x768" "800x600" 

  EndSubSection

  SubSection "Display"

    Depth 16

    Modes "1024x768" "800x600" 

  EndSubSection

  SubSection "Display"

    Depth 24

    Modes "1024x768" "800x600" 

  EndSubSection

  SubSection "Display"

    Depth 8

    Modes "1024x768" "800x600" 

  EndSubSection

  Device "Device[0]"

  Identifier "Screen[0]"

  Monitor "Monitor[0]"

EndSection



Section "Device"

  BoardName "RV280 5964"

  BusID "1:0:0"

  Driver "radeon"

  Identifier "Device[0]"

  Option "usevnc" "no"

  Option "GARTSize" "32"

  Screen 0

  VendorName "ATI"

EndSection




Section "ServerLayout"

  Identifier "Layout[all]"

  InputDevice "Keyboard[0]" "CoreKeyboard"

  InputDevice "Mouse[1]" "CorePointer"

  Option "Clone" "off"

  Option "Xinerama" "off"

  Screen "Screen[0]"

EndSection



Section "DRI"

    Group "video"

    Mode 0660

EndSection


Section "Extensions"

EndSection

(matiit) #2

Zawsze wzorowałem się na tym How-To i działało.

Zanim podmienisz xorga pokaż, żeby się Xy włączyły.


(Longhorn2009) #3

Twój problem pewno dlatego, że masz monitor podpięty pod D-Sub.


(matiit) #4

GMajka12

Jeśli pokazał mu się błąd że linijka X jest niepoprawna to miał błąd w xorg.conf.


(Kpc21) #5

A co mam zrobić??

Tak, ale jaki błąd??

Xorga podmieniałem z poziomu X-ów.


(matiit) #6

Jeszcze raz sobie wygeneruj Modeline i pododawaj co trzeba, ale zanim zrestartujesz Xy (po podmianie xorg.conf) pokaż nam ten plik.


#7

Ten pogrubiony wiersz to właśnie ten 100 w którym jest błąd. Porównaj ten wiersz z poprzednim i zobacz czym się różni od poprzednich w tej sekcji.


(Fisiu) #8

Ja to z modeline nigdy nie korzystałem, zawsze dopisywałem swoją rozdziałkę w sekcji “screen” przy trybie 24 bity. I zawsze działało. Tyle, że zawsze korzystałem z natywnej rozdzielczości matrycy. A rozdzielczość 1280x768 do zbyt typowych nie należy… to chyba 16:9 jest. Normalne monitory to raczej są w proporcjach 4:3 i 16:10.


(Kpc21) #9

Mój monitor to Hyundai X90W (taki mi wystarcza, nie potrzeba mi takiego za 1000 :slight_smile: ). Jego proporcje to 16:10 (Widescreen), jednak tej rozdzielczości używam pod Windowsem i jest O.K. i ona mi najbardziej odpowiada.


(Fisiu) #10

Skoro mówisz o proporcjach 16:10, to np. 1280x800, 1440x900. Zresztą Twój ma natywną 1440x900. I przy tej wielkości matrycy ta rozdzielczość jest wg mnie najlepsza.

A to, że monitor wygasza się przy starcie X’ów to nie jego wina tylko Twojego Radeona!!

Zresztą zawsze możesz najpierw uruchomić system w trybie tekstowym (init 3). Wystarczy po włączeniu komputera, w menu gruba dopisać 3. Potem logujesz się jako root. Instalujesz sterownik do karty graficznej, sprawdzasz xorg.conf i w razie potrzeby modyfikujesz go. Potem restart systemu… i działa :slight_smile:


(Kpc21) #11

A według mnie za duża

Gdy ją ustawię w SaX-ie, obraz testowy jest zwężony w poziomie, a rozszerzony w pionie (dolna krawędź wychodzi poza krawędź monitora) i przesunięty w prawo.

Nie mogę.

Korzystam z tego tutoriala:

http://suse.ehelp.pl/modules/articles/article.php?id=79

Coś nie wychodzi. Czyżby sterownik ze strony głównej ATI nie pasował do SuSE 10.3??

JA:/tmp # sh /tmp/ati-driver-installer-8.28.8.run --buildpkg SuSE/SUSE103-IA-32

Creating directory fglrx-install

Verifying archive integrity... All good.

Uncompressing ATI Proprietary Linux Driver-8.28.8.....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

==================================================

 ATI Technologies Linux Driver Installer/Packager

==================================================

Generating package: SuSE/SUSE103-IA-32

[b]Requested package is not supported.[/b]

Removing temporary directory: fglrx-install

(matiit) #12

To ustaw monitorem…

Ustawisz raz i masz na zawsze. (póki nie ustawisz drugi raz)


(Kaka') #13

Mając kiedyś kartę ATI interesowałem się tym zagadnieniem i jak dobrze pamiętam, nie wszystkie sterowniki wspierały daną kartę (mojej np. nie wspierały najnowsze sterowniki). Być może potrzebujesz starszych wersji sterowników - poszukaj na stronie ATI. Dodam jeszcze, że przy tego typu niestandardowych rozdzielczościach, instalacja sterowników powinna rozwiązać problem (było to dość często omawiane na debian.linux.pl).

Pozdrawiam.


(Fisiu) #14

Sterownik działa, ale nie generuj paczki rpm. Odinstaluj wszystko co ma w nazwie AMD/Ati/fglrx.

Metodą sprawdzoną jest → http://en.opensuse.org/ATI#openSUSE_10.3

Albo instalacja najnowszych sterowników ze strony ati.amd.com

Czyli

cd Desktop

wget -c https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/ati-driver-installer-8-01-x86.x86_64.run

su

./ati-driver-installer-8-01-x86.x86_64.run

sax2 -r -m 0=fglrx

Potem restart systemu i powinno działać.


(Kpc21) #15

Fisiu

Gdy wykonałem te komendy i zrestartowałem SuSE, X-y nie uruchomiły się, a po komendzie startx, wyświetla się następujący błąd:

(WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found

(EE) No devices detected


Fatal server error

no screens found

giving up.

xinit: Connection reset by peer (errno 104): unable to connect to X server

xinit: No such process (errno 3): Server error

Jeżeli polskie znaki niepoprawnie się wyświetlają, to przepraszam - piszę z Lynksa i nie mogę tam ustawić, żeby działaÂły polskie litery.


(matiit) #16

Czy aby na pewno sterownik fglrx obsługuje Twoją kartę graficzną?


(Kpc21) #17

Nie wiem - nie pytaliście o kartę, więc myślałem, że to jakiś uniwersalny. A możliwe, że nie obsługuje, bo moja karta to zabytek, jak zresztą cały komp. Jest to Radeon 9200SE od Gigabyte’a.

Co ciekawe w SaX-ie po instalacji sterownika, ale zanim zrestartowałem system zaczął mi wykrywać monitor - wcześniej było ustawione na 1280x768@60Hz, teraz jest Hitachi X90W (tak naprawdę mam Hyundaia, ale to pewnie to samo).

Co do Lynksa (nie Linksa, Lynksa), mam tam ustawione UTF-8, ale jeśli ustawię na ISO-8859-2, jest tak samo. Na Windows-1250 nie próbowałem, ale wątpię, żeby Linux miał kodowanie z WinZgrozy.

EDIT:

Dodam, że z tym 1280x768@60Hz chodzi o monitor (default) - rozdzielczości takiej nie mogę ustawić.


(matiit) #18

Radeon 9200SE…

Nie instaluj sterowników fglrx… nie wspierają już tej karty…

Jeśli ta rozdzielczość nie zadziała z otwartymi to raczej nic nie poradzisz…

Pokaż obecny xorg.conf

Napiszę Ci co dopisać, i jak nie wstanie z tym to może być już ciężko wymyślić coś nowego.


(Kaka') #19

A jednak tu bym się sprzeczał. KLIK

Sterowniki starej daty co prawda, ale z tego co mi wiadomo, wspierają ową kartę. Sam używałem tych sterowników przy R. 9550.


(matiit) #20
Automated installer and Display Drivers for XFree86 4.3 and X.Org 6.7, 6.8, 6.9, 7.0, 7.1

Więc mogą np. niedomagać przy xorgu 7.3 (który już jest standardem w nowych dystrybucjach).