Niezgodność jquery w WP i problem z ładowaniem skryptu


(Atac3) #1

Mam jeden podwójny problem. Generalnie jest jeden problem, ale podejrzewam, że mogę być za niego odpowiedzialne dwa elementy. Mianowicie nie do końca ładuje mi się skrypt jscrollpane.

Po pierwsze, nie jestem pewny czy w wordpressie jest zgodność jquery. Chociaż to dziwne, bo na innej stronie również opartej na wordpressie ładuję jquery/1.8.3/jquery.min.js i jqueryui/1.9.2/jquery-ui.min.js i ten sam skrypt działa.

Chodzi generalnie o to, że pokazuje się jscrollpane, ale bez suwaków. Skrypt tworzy nowego diva, tak jak powinien, oraz inne elementy. Brakuje tylko tych suwaków. Na tej drugiej strony wszystko działa już dobrze.

Kod stopki:

Podaję też adres strony, tak żeby dało się sprawdzić w praktyce. Chodzi o element Kalender http://www.christophstauder.capnix.com/#calendar_div


(mario@) #2

Nie wiem czy o to chodziło.

W css odnajdź .jspContainer i zamień overflow:hidden na overflow:auto.

W html odnajdź diva class="jspPane" i zmień tam wartość width na 780px (bądź taką która spowoduje usunięcie poziomego paska przewijania, nie wiem dlaczego nie chciało przyjąć overflow-x).


(Atac3) #3

Nie działa. Po tym jak dałem overflow:auto pokazał się suwak ale zwykły, nie ten jScrollPane. Ciągle nie wczytuje tylko jednego elementu 'jspVerticalBar'. W tym divie znajdują się wszystkie rzeczy odpowiedzialne za przewijanie. Trochę dziwne, że wczytuje pół skryptu...