Nieznany typ partycji po zmianie nazw partycji


(patrx95) #1

Witam.

Mam problem z odpaleniem systemu, ponieważ system nie odpala się z powodu błędu "error 17" przed ładowaniem GRUBa.

Po wygooglowaniu info o tym błędzie zorientowałem się że jest związany z nieodnajdywaniem lokalizacji partycji.

Sprawdziłem więcej info w gparted na puppy linuxie i okazało się że wszystkie partycje oprócz swap mają typ partcji zamiast ext3 unnamed, a ich nazwy zmieniły się z /dev/sdaX na /dev/hdc/X (myślę że to było związane z zmianą podłączenia kabli z dysku na napęd cd-rom).

Więc mam 2 pytania:

  1. Czy muszę formatować wszystkie partycje do ext3 lub ext4.

  2. Jak zmienić nazwy partycji na poprzednie /dev/sdaX

Dystrybucje live:

-Puppy Linux

-Ubuntu 10.04 (tylko w trybie konsoli)

Dysk:

Seagate 80GB ATA100

Z góry dzięki za odpowidzi.

Pozdrawiam.


(Xwars) #2
  1. Nie

  2. Nie da się, to zależy tylko i wyłącznie do którego złącza na płycie głównej jet podłączone urządzenie

W każdym razie, jeśli nie chcesz przekładać kabelków będziesz musiał odpalić jakieś live-cd, podmontować /boot*, poprawić konfigurację i przeinstalować gruba ( 'grub-install') . Nowsze wersje GRUBa powinny także obsługiwać UUID zamiast ścieżek do urządzeń. UUID są niezależne od sposobu podłączenia, można je podejrzeć np poleceniem ls -la /dev/disk/by-uuid/

* w niektórych dystrybucjach konfiguracja grub2 znajduje się w /etc/grub, więc trzeba podmontować także ten katalog :confused:


(patrx95) #3

A jak zrobić po kolei montowanie katalogów?

//domyślam się że przez komendę sudo mount [katalog] ale nie wiem jakie katalogi mam montować


(Filip Hh) #4

Wklep sudo fdisk -l wyświetlą ci się partycje wraz z ich oznaczeniem.

Później podmontuj partycję z linuxem poleceniem sudo mount /dev/xxxx /mnt gdzie xxxx to nazwa partycji z linuxem np sda1 hda 1

Następnie sudo grub-install --root-directory=/mnt /dev/xxx gdzie xxx to nazwa dysku (tak jak partycja tylko bez numerka)

Możesz jeszcze wykonać sudo update grub.


(Soren) #5

Do instalacji gruba z poziomu livecd nie będzie przypadkiem chroot potrzebny?


(roobal) #6

Z LiveCD tak.

Zmień wpisy w /etc/fstab.

Pozdrawiam!


(marcin82) #7

Witam.

Aby uaktualnić GRUBA uruchamiasz live-cd, zaloguj się od razu jako root, potem w konsoli:

grub

, następnie:

find /boot/grub/stage1

potem:

root (hd+,+)

+,+ numery partycji pokazane w poprzednim poleceniu następnie:

setup (hd0)

i na koniec

quit

To uaktualni Ci GRUBA, teraz trzeba jeszcze doprowadzić do porządku plik /etc/fstab. W tym celu wpisz w konsoli komendę:

blkid

To wyświetli wszystkie partycje wraz z UUID-ami. Otwórz plik /etc/fstab, sprawdź czy UUID są takie same, pozmieniaj numery partycji i system powinien bez problemów ruszyć.


(patrx95) #8

ehh... trochę jest problem bo właśnie już odinstalowałem całego GRUBa i teraz nie mam żadnego programu do uruchamiania systemu

najbardziej tkwi u mnie problem w tym że nic mi nie rozpoznaje jaki mam typ partycji ext3 czy ext4 czy ntfs (próbowałem przez Gparted, SuperGrubDisk czy przez polecenie fdisk -l) i tutaj pewnie będą problemy z montowaniem albo z czym innym bo nie można rozpoznać typu

i tu moje pytanie:

Jak przywrócić typ partycji (czy wystarczy sama instalacja GRUB ?) najlepiej bez formatowania partycji? ponieważ mam trochę danych takich jak muza, zdjęcia, konfigi itp.

Z góry wielkie dzięki za pomoc.


(dragonn) #9

Spróbuj zamontować (z jakiegoś livecd) partycje za pomocą:

mount -t typ_partycji /dev/sdaX /punkt/montowania

i pokaż co wywali. I sprawdź dysk pod kątem bad sektorów


(roobal) #10

GParted z tego co zauważyłem to sobie rozpoznaje lub nie po swojemu w stosunku do fdisk ale piszesz, że fdisk też nie rozpoznaje dobrze partycji to w takim razie zainteresuj się dystrybucją RIP Linux (Recovery Is Possible Linux) przy jej pomocy przywrócisz partycje jak i dane z dyku.

Pozdrawiam!


(patrx95) #11

Witam ponownie po długiej przerwie nie odzewu :wink:

Właśnie sprawdziłem jeszcze raz czy fdisk na pewno nie rozpoznaje partycji i chyba jednak się albo pomyliłem albo coś się zmieniło, bo teraz fdisk poznaje które to partycje są Linux lub swap (nie pokazuje czy ext3/4 tylko linux... czy to normalne?).

Czy to coś zmienia że fdisk rozpoznaje partycje? Jakie podjąć mam następne kroki??

Z góry dziękuję za odpowiedzi. :slight_smile:


(marcin82) #12

Trzeba "uświadomić" GRUBA, że /dev/sda -> teraz stało się /dev/sdb.

Postępuj zgodnie z tym poradnikiem:

http://dug.net.pl/tekst/77/przywracanie ... ca_chroot/

To jest opis dla Gruba2. Ubuntu już jakiś czas korzysta z Gruba2, więc ten jest odpowiedni.

Instrukcję dla Gruba1 (ver. 0.97) podałem w poście powyżej:http://forum.dobreprogramy.pl/nieznany-typ-partycji-zmianie-nazw-partycji-t403666.html#p2588550 .

Następnie, żeby system nie czekał 60 sekund na zgłoszenie się partycji ze starymi oznaczeniami, należy wyedytować /etc/fstab (sens tego jest taki sam, skoro UUID się nie zmieniły, musisz tylko zmienić literki, które oznaczają hierarchię tych dysków).

Wszystko już miałeś opisane, przez wszystkich razem i każdego z osobna :slight_smile:


(patrx95) #13

no więc już zaczął się problem z montowaniem (dokładniej komendą: mount device dir) zwróciło mi:

mount: you must specify the filesystem type

...więc potem wpisałem mount -t ext dev dir:

# mount -t ext3 /dev/sdc2 /mnt/root

mount: wrong fs type, bad option, bad superblock on /dev/sdc2

missing codepage or other error

In some cases useful info is found in syslog - try

dmesg | tail or so

skoro pisało że przydatne ma być dmesg | tail to już daję to co zwróciło:

#dmesg | tail

ip_tables: (C) 2000-2006 Netfilter Core Team

ip_connctrack versuib 2.4 (4095 buckets, 32760 max) - 228 bytes per conntrack

FAT: bogus nume of reserved sectors

VFS: Can't find a valid FAT filesystem on dev hdc2

SQUASHFS: Can't find a SQUASHFS superblock on hdc2

VFS: Can't find a ext3 filesystem on dev hdc2

FAT: bogus nume of reserved sectors

VFS: Can't find a valid FAT filesystem on dev hdc2

SQUASHFS: Can't find a SQUASHFS superblock on hdc2

VFS: Can't find a ext3 filesystem on dev hdc2

A pomijając montowanie partycji to mount -t proc none /mnt/root/proc zadziałało.


(roobal) #14

Na pewno na tej partycji założony (sformatowana) jest system plików ext3? Z błędów wynika jakoby to był FAT32.

Pozdrawiam!


(patrx95) #15

Przed instalacją linuxa stawiałem partycje tylko na ext3.

Więc ta partycja (jak i analogicznie wszystkie inne) jest sformatowana i na nich nie ma już żadnych danych?


(roobal) #16

Jeśli formatowałeś i nic nie wrzucałeś na partycję to zapewne nic tam nie ma. Jeśli nic tam nie ma to może sformatuj jeszcze raz? Ale to Ty musisz wiedzieć czy tam coś jest czy nie ma. Potraktuj jeszcze tę partycję programem Fsck:

fsck /dev/sdc2

lub

fsck.ext3 /dev/sdc2

Zamiast sdc2 możesz też spróbować hdc2, bo wg dmesg, jądro rozpoznaje tę partycję jako hdc a nie sdc. Sprawdź jeszcze konfiguracje Gruba i /etc/fstab pod tym kątem.

Pozdrawiam!