Niskie FPS na 1060 msi 6GB? Dlaczego?


(oskix3211) #1

Witam. Mam problem dotyczący praktycznie wszystkich gier na PC. Gry na ultra, które działają w oknie fullHD działają powyżej 60 fps, dosięga nawet 100. Lecz gdy ustawię na pełny ekran nagle z 60 robi się 30, gdzie wiem ze jest w stanie wycisnąć więcej. Mam gry Far Cry 3, 4 Just Cause 2 i 3, Mass Effect Andromeda, nawet na dirt 3 dzieje się tak samo.

Nie mam zbyt słabego PC aby grać tylko na 30 FPS,

Intel Core i7 7700K (nie podkręcony)
MSI GTX 1060 6GB
Hyper X black 2x8 2400
Asus Strix H270F

Dodam kilkusekundowy filmik, w którym przełączam się pomiędzy oknem a full-screen, widać gdy fps maleje i rośnie. (góra po lewej)

Link dysk Google: https://drive.google.com/open?id=1FmBHB-gmFIDI9Qlz-1qWMkp7EmyZKkHP

Są jakieś pomysły dlaczego tak się dzieje ? Proszę o pomoc.

Pozdrawiam.


(thommy181) #2

Po pierwsze należy sprawdzić jakie procesy działają w tle. Dosyć poważnie są w stanie zamulić takie procesy jak: Centrum Zabezpieczeń, Zapora systemu windows (lepiej stosować własny darmowy antywirus niż te od MS), Wstępne ładowanie bibliotek do pamięci, Windows Update. Te procesy radziłbym wyłączyć, raz do miesiąca skorzystać z Windows Update. Drugie pytanie czy procesor ma włączoną oszczędność energii czyli czy zegar procesora skacze w przypadku obciążania go a przy braku obciążenia spada ? W pecetach do gier ustawiam zawsze najwyższy możliwy zegar (nie mylić z OC). Można to zrobić w Biosie. Trzecia sprawa to ustawienia graficzne Nvidia. Tutaj w ustawieniach 3d wybrałbym wyłączenie synchronizacji pionowej (bezpośredni wpływ na liczbę klatek w grach) oraz włączenie maksymalnej wydajności w opcji profil zarządzania energią. Gdyby to nie pomogło należy sprawdzić czy w biosie jest wyłączony zintegrowany procesor graficzny, oraz sprawdzić również w bios czy pamięci chodzą z zegarem 2400 Mhz i czy nie ma przy nich ustawienia AUTO. To tak z grubsza co mi na myśl przychodzi. Popróbuj i daj znać jaki jest efekt.


(oskix3211) #3

Nie chciał bym bagatelizować tego co napisałeś o procesach, ale to nie komputer z epoki kamienia łupanego żeby oszczędzać na procesach w tle. Ponadto nie mam szczególnie innych procesów w tle, jedynie Steam i U play bo tego potrzebują Far Cry 3 i 4, załączonych chrome, podczas działania gier procesor nie wykorzystuje więcej niż 60%. W biosie mam ustawiony tryb wydajności, a ten procesor na prawdę bardzo ciężko wykorzystać w 100%… W opcjach gier i ustawieniach grafiki PC wyraźnie jest zaznaczona opcja karty graficznej MSI, a nie zintegrowanej. Dodatkowo jeśli był by to problem z RAM, procesorem lub grafiką problem objawiał byt się nie tylko w Full-Screen ale i w oknie. w BIOS’ie RAM na 2400.

Dodam też że w Wiedźmin 3: Dziki Gon jest opcja limitu FPS i na full-screen jest 55-60 FPS na ultra. bo mam do 60 zaznaczone. A w innych grach np. tej opcji już nie ma.


(thommy181) #4

Tryb wydajność w BIOS masz ustawiony, a co z ustawieniami sterownika graficznego pod Windows ? Piszesz, że to nie problem ustawień procesora czy grafiki. A w jaki sposób to sprawdziłeś ? Zapytałeś co może być przyczyną małej liczby klatek w grach, więc mniej więcej i z grubsza napisałem co “może” być przyczyną. Nikt nie dawał gwarancji na to, że odpowiedzią na Twój wpis naprawi problemy twojego komputera czy systemu. Nie pojmuję rozumowania typu: "

Mocno się mylisz kolego. Współczesna karta graficzna ma przynajmniej 3 tryby działania. Korzystając z systemu Windows i aplikacji w nim (gra to też aplikacja) karta graficzna jest używana w ograniczonym zakresie. Dopiero po uruchomieniu gry w pełnej krasie (rozdzielczość HD - jakiś tam poziom szczegółów w grze) należy oczekiwać, że karta graficzna przejdzie w tryb aplikacji 3d i wtedy będzie działać w pełni mocy. Ta moc może zostać ograniczona ustawieniami oprogramowania lub opcjami w grze. Z tego powodu możesz mieć mało klatek w grach i należy dojść do tego gdzie jest problem. Najlepiej zrobić to drogą eliminacji poszczególnych czynników. W efekcie gdy dojdziesz gdzie jest problem będziesz mógł go wyeliminować.
Wydaje mi się, że Twoje początkowe założenie jest błędne - “to nie będzie problem procesora czy karty bo je ciężko obciążyć tak na 100%” I ciężko obciążyć i nie ciężko wszystko zależy od tego co będziesz robił na komputerze. Nie ma komputera z nieograniczonymi zasobami. Żeby stwierdzić co powoduje problem trzeba komputer testować przy pomocy specjalnych programów. Na koniec dodam, że powód może być prozaiczny jak np. zasyfiona płyta główna i brak dobrego styku pomiędzy płytą główną, procesorem, portem pcie, kartą graficzną i itd. Nie piszesz też nic o zasilaczu, jaki masz, jaka jest jego moc, stan techniczny, zewnętrzny. Zasilacz ma własną obudowę, do której też sporo syfu może się napylić i wpłynąć negatywnie na jego wydolność.
Jak widzisz problem nie jest tak prosty do rozwiązania jak zakładasz. Aby się dowiedzieć co jest przyczyną trzebaby tę maszyne potestować trochę.


(oskix3211) #5

Tak więc zacznijmy od ustawień karty graficznej, pobrałem teraz MSI Gaming APP i mam teraz tryb OC (było po załączeniu programu) przestawiłem się na tryb gaming, ale brak efektu. Dalej tak samo. Komputer oczyszczony z kurzu sprężonym powietrzem (stare części i obudowa) CPU, RAM i płyta główna nowiutkie z sklepu. Zasilacz Silentium Deus G1 ma z 3 lata, również oczyszczony z kurzu 600W. Co do procka i BIOS’u wszedłem tam jeszcze raz i zauważyłem ze zniknął mi tryb wydajności, został tylko Tryb oszczędzania enegrii i standard. Szukałem w ustawieniach ale jakoś nie widziałem tam ustawień. Komputer składałem sam i jak najbardziej wszystko dokładnie podłączone, sprawdziłem dla pewności.


(thommy181) #6

Sprawdź jakie są ustawienia odświeżania ekranu. Wydaje mi się, że skoro jest tylko 30 fps to może być to wina po 1. włączonego synchronizowania z częstotliwością monitora. 2. Aplikacja wspomagająca typu MSI Gamming App też może być winowajcą sytuacji (możesz spróbować ją odinstalować w celu testów). Pozostaw sobie tylko oryginalne sterowniki do urządzeń. 3. Nie wiem jaki dokładnie posiadasz zestaw komputerowy, ale z tego co jest opisane to jak liczyłem pobór mocy płyty, procesora, karty i ramu wychodzi jakieś 300 - 310 W. Zakładając, że Twój zasilacz jednak nie ma rzeczywistych 600 W tylko na przykład 500 czy 550 W może być nieco za mało mocy zasilacza, ale tę ewentualność należy sprawdzać dopiero po tym jak się wykluczy kwestie oprogramowania.


(LORDEK) #7

To jest chyba objaw włączonego v-sync. Wejdź w opcje i pozmieniaj to ustawienie. Do momentu aż odblokują Ci się klatki.

obraz

Ostatnia opcja obcina właśnie klatki do połowy wartości odświeżania monitora. Adaptive jest chyba najlepszym wyborem na Gforce, bo usuwa tearing bez utraty FPS. Oczywiście możesz zmienić opcję na OFF, ale będziesz miał do czynienia ze wspomnianym tearingiem.


(oskix3211) #8

Jak już wcześniej wspomniałem, mówiąc “pobrałem teraz” czyli jej nie miałem. Kwestia zasilacza… hmmm. Nie będę się wypowiadać :slight_smile: Ale dzięki za chęć pomocy.


(oskix3211) #9

To było to ! Strzał w dziesiątkę, a nie jakieś doczepianie się … zasilacza :slight_smile: Dzięki Ci bardzo


(LORDEK) #10

Tak na przyszłość. Gdy widzisz, że klatki obcinają się do 30, 45, 60 to na pewno winny jest właśnie V-Sync. Raz miałem wyjątek od tej reguły, gdzie w Assassin’s Creed Syndicate obcinało mi klatki do równych 30, co naprawiło zmniejszenie detali otoczenia. Ale akurat Assassyny to trochę buble optymalizacyjne, także…


(oskix3211) #11

Bardzo przydatna wiadomość, nawet Euro Truck Simulator mi mulił na 30 FPS, tragedia heh, Aczkolwiek ja nie odczuwam żadnej różnicy graficznej z V-sync czy bez niej… jedynie to ustawienie, które mi podałeś w panelu sterowania nVidii muszę zmieniać na szybkie gdy chcę grać a na adaptyczne (o połowa mniejsza wartość klatek) gdy patrzę na film, ponieważ efekt o którym wspominałeś “tearing” jest tak duży w odtwarzanych filmach czy filmikach na YT że oglądać się nie da. Niestety aby to zaczęło działać muszę komputer ponownie uruchomić. Jedynie nie wiem jak to z sobą pogodzić abym nie musiał tego ciągle zmieniać.


(LORDEK) #12

U góry masz zakładkę “Program settings”. Wyszukaj na niej swoją przeglądarkę oraz odtwarzacz i zmień im ustawienia indywidualnie.


(oskix3211) #13

Dzięki Ci bardzo, konkretna odpowiedź na każde pytanie :smiley: