No such device grub rescue Ubuntu 10.10


(Red19boy10) #1

Posiadam dwa dyski fizyczne Dysk C oraz Dysk D. Na dysku C mam zainstalowany win7 zachciało mi się dziś przetestować Ubuntu 10.10 postanowiłem że zainstaluje go na drugim dysku. Jednak gdy już wszystko zainstalowałem i zobaczyłem że nie mam dostępu do dysku D na win7 ponieważ służy on dla Ubuntu pomyślałem że odinstaluje Ubuntu i zainstaluje go obok win7. Usunąłem partycje dysku D (były ich trzy) sposobem podanym na tej stronie http://windows.microsoft.com/pl-PL/windows-vista/Delete-a-hard-disk-partition. Po ponownym włączeniu komputera żaden system nie chciał się włączyć natomiast wyskakiwał błąd:

Error: no such device

grub rescue

Pomyślałem że od nowa zainstaluje Ubuntu jednak to nie zadziałało. Mogłem jedynie odpalić Ubuntu z LiveCD oraz po włożeniu płyty LiveCD i wybraniu Dysku C jako bootowalnego i włączył się Windows. Inaczej nie da się odpalić żadnego systemu. Wiem że ze mnie lama :confused: Jakieś pomysły koledzy jak to naprawić? Z góry dziękuje.

-- Dodane 24.08.2011 (Śr) 22:46 --

Jeżeli przy starcia wcisne F12 i wybiore drugi dysk mam do wyboru system operacyjny i płyta LiveCD nie musi być w napędzie przy starcie. W takim wypadku chyba muszę przywrócić partycje które usunąłem a nastepnie usunąć ubuntu. Wie ktoś może jak to zrobić?


(marcin82) #2

Na którym dysku zainstalowałeś bootloader GRUB? Jeśli na /dev/sdb to Windows powinien się normalnie uruchamiać. Jeśli na /dev/sda , czyli na dysku Windowsa zajrzyj tutaj (kompletne How-To):

http://ubuntu.pl/forum/viewtopic.php?f=146&t=134405

i tutaj:

http://ubuntu.pl/forum/viewtopic.php?f=146&t=134533

Chodzi o usunięcie Gruba z MBR dysku Windowsa.


(Red19boy10) #3

Został zainstalowany na /dev/sdb ale potem usunąłem te trzy partycje tym sposobem podanym w linku i po ponownym włączeniu komputera tak się dzieje. Jeżeli wcisne F12 i wybiore drugi dysk to mam wybór jaki system operacyjny chce wybrać. Natomiast gdy pozwole aby bootloader szedł z tego drugiego dysku (dysk D gdzie był zainstalowany ubuntu) to wyskakuje właśnie ten błąd. Jest możliwość usuniecie Ubuntu i Gruba w tym przypadku?


(marcin82) #4

Dobra, to napisz jeszcze, czy jak przestawisz kolejność bootowania w BIOS na dysk z Windowsem jako pierwsze urządzenie bootujące to czy Windows się normalnie uruchamia bez żadnej płyty w napędzie i innych czarów?

====

Jeśli tak, to trzeba tylko wyczyścić MBR dysku /dev/sdb. W tym celu uruchom live-cd Ubuntu, otwórz terminal i wykonaj takie polecenia:

  • zalogowanie się na konto roota:

    sudo su

  • zerowanie MBR (bootloadera oraz tablicy partycji dysku /dev/sdb):

    dd if=/dev/zero of=/dev/sdb bs=512 count=1

Następnie możesz uruchomić GParted i założyć nowe partycje np. NTFS - tak aby Windows je rozpoznał (tak jak pisałeś).

Powyższe komendy wykonaj TYLKO i WYŁĄCZNIE w przypadku, gdy Windows startuje bez probemów, gdy w BIOSIE jako urządzenie startowe ustawisz jego dysk.

Napisz czy wszystko ok.


(Red19boy10) #5

Próbowałem tym sposobem opisanym w pierwszym linku i nie wykrywa tego Dysku D

dodaje screena http://imageshack.us/photo/my-images/822/dysk.png

Nie posiadam płyty instalacyjnej windowsa


(marcin82) #6

Wykrywa - tylko on nie ma etykiety i partycji "D : \ ". To teraz już zostaw w spokoju TestDisk i nie rób nic tym programem - zajmij się tylko dyskiem /dev/sdb.

Jeśli jest tak, jak napisałem tutaj:

to tylko wyczyść MBR /dev/sdb jak napisałem wyżej i załóż na nim nową partycję NTFS i nadaj mu etykietę " D : \ ".

Ustaw w BIOS na stałe bootowanie z dysku Windowsa. Win7 po tym powinien normalnie wykrywać nową partycję NTFS na dysku /dev/sdb.


(Red19boy10) #7

Nie widziałem opcji w Biosie abym mógł ustawic aby to Dysk C był jako pierwszy bootujący (hard drive jako ogólnie to tak ale nie konkretny dysk)


(marcin82) #8

Podaj dokładny model płyty głównej. Jeśli masz dwa dyski twarde - obydwa muszą być widoczne tak jak np. dwa napędy optyczne. Sam mam na pzykład jeden dysk twardy i dwa napędy optyczne do wyboru (Lite-On oraz LG). Chodzi o to, żeby tak samo jak wybierasz pod F12 "drugi dysk", tak samo usatwić / wybrać w BIOS i zapisać zmiany.


(Red19boy10) #9

Płyta główna to Gigabyte GA-945GZM-SA


(marcin82) #10

W "First/Second/Third Boot Device" albo w "Hard Disk Boot Priority" powinieneś mieć do wyboru jeden albo drugi dysk twardy i tyle. Instrukcja do płyty strona 34:

http://www.retrevo.com/d/ds/progress?do ... 4266146458 .

========

A jak uruchamiasz komputer z F12 to jak rozróżniasz dyski, jak są widoczne?


(Red19boy10) #11

Miałeś racje w Hard Disk Boot Priority trzeba było zmienić kolejność dysków.

Gdy uruchamiałem komputer z F12 to wybierałem Hard Drive a następnie pojawiały się dwa dyski (oby dwa są takie same) i jak wybrałem pierwszy to wyskakiwał właśnie ten błąd a gdy wybierałem drugi to miałem do wyboru który system operacyjny chce wybrać, Windows lub też Ubuntu.

Teraz po ustawieniu który dysk ba być "bootowany" jako pierwszy mam właśnie do wyboru system operacyjny (Windows lub też Ubuntu)

Jak w takim razie usunąć Ubuntu i przywrócić aby dysk D był widoczny w windowsie i żebym mógł z niego tam korzystać? (przypomnie że na dysku C mam windowsa a na dysku D był Ubuntu zainstalowany)


(marcin82) #12

To opisałem Ci dokładnie tutaj:

such-device-grub-rescue-ubuntu-t459168.html#p2905255

Żeby jednak była jasność, na którym dysku trzeba wyczyścić MBR (Grub + tablica partycji), pokaż jeszcze wynik polecenia wykonanego z poziomu live-cd Ubuntu a z dyskiem nic nie rób:

sudo fdisk -l

Czyli na ten moment rozumiem, że Ubuntu masz zainstalowane obok Windowsa na dysku /dev/sda? (tam gdzie jest partycja C : ) i zarówno Windows jak i linux uruchamiają się bez problemów? I ten dysk ustaw w BIOS jako pierwsze urządzenie bootujące na stałe -> Save Settings and exit.


(Red19boy10) #13

Na to wygląda że jest obok Windowsa pomimo że zapisywałem go na Dysku D :confused: zaraz przetestuje to co napisałem

-- Dodane 25.08.2011 (Cz) 18:11 --

Włączyłem Ubuntu poprzez LiveCD jak kazałeś i wpisałem komende sudo fdisk -1

ubuntu@ubuntu:~$ sudo fdisk -1

fdisk: invalid option -- '1'


Składnia:

 fdisk [opcje] zmiana tablicy partycji

 fdisk [opcje] -l wypisanie tablic(y) partycji

 fdisk -s podanie rozmiaru partycji w blokach


Opcje:

 -b rozmiar bloku (512, 1024, 2048 lub 4096)

 -c wyłączenie trybu kompatybilności z DOS-em

 -h wyświetlenie opisu

 -u podawanie rozmiarów w sektorach zamiast w cylindrach

 -v wyświetlenie wersji

 -C podanie liczby cylindrów

 -H podanie liczby głowic

 -S podanie liczby sektorów na ścieżce

(marcin82) #14

To jest L jak Licheń ;] , czyli:

sudo fdisk -l

Dla pewności pobierz jeszcze ten skrypt:http://sourceforge.net/projects/bootinfoscript/Zapisz go na Pulpicie "live-cd", prawy przycisk myszy => Rozpakuj tutaj. Następnie otwórz terminal i wykonaj takie komendy:

cd Desktop

oraz:

sudo sh boot_info_script.sh

Wynik zostaną zapisane w pliku RESULTS.TXT na Pulpicie, wstaw go tutaj w tagach


(Red19boy10) #15

A więc pierwsze:

Dysk /dev/sdb: 164.7 GB, bajtów: 164696555520

głowic: 255, sektorów/ścieżkę: 63, cylindrów: 20023

Jednostka = cylindrów, czyli 16065 * 512 = 8225280 bajtów

Rozmiar sektora (logiczny/fizyczny) w bajtach: 512 / 512

Rozmiar we/wy (minimalny/optymalny) w bajtach: 512 / 512

Identyfikator dysku: 0x00055b19


Urządzenie Rozruch Początek Koniec Bloków ID System

/dev/sdb1 * 1 125 999424 82 Linux swap / Solaris

Partycja 1 nie kończy się na granicy cylindra.

/dev/sdb2 125 20024 159834113 5 Rozszerzona

/dev/sdb5 125 1992 14998528 83 Linux

/dev/sdb6 1993 20024 144834560 83 Linux


Dysk /dev/sda: 164.7 GB, bajtów: 164696555520

głowic: 255, sektorów/ścieżkę: 63, cylindrów: 20023

Jednostka = cylindrów, czyli 16065 * 512 = 8225280 bajtów

Rozmiar sektora (logiczny/fizyczny) w bajtach: 512 / 512

Rozmiar we/wy (minimalny/optymalny) w bajtach: 512 / 512

Identyfikator dysku: 0xc771b8ba


Urządzenie Rozruch Początek Koniec Bloków ID System

/dev/sda1 * 1 13 102400 7 HPFS/NTFS

Partycja 1 nie kończy się na granicy cylindra.

/dev/sda2 13 20023 160730112 7 HPFS/NTFS

ubuntu@ubuntu:~$

Ten skrypt nie chce się otworzyć jak wpisuje te komendy w terminalu:

ubuntu@ubuntu:~$ cd Desktop

ubuntu@ubuntu:~/Desktop$ sudo sh boot_info_script.sh

sh: Can't open boot_info_script.sh

ubuntu@ubuntu:~/Desktop$

(marcin82) #16

To zaloguj się jako root:

sudo su

Nadaj skryptowi prawo do wykonania (będą na Pulpicie):

chmod a+x boot_info_script.sh

lub prawy przycisk myszy => Właściwości => Uprawnienia => Wykonywanie i potem:

sh boot_info_script.sh

Czy jesteś na Pulpicie sprawdzisz komendą:

pwd

Powinna zwrócić:

/home/ubuntu/Desktop

(Red19boy10) #17

Wtedy te dwa pliki Changelog oraz boot_info_script.sh były dodatkowo w folderze, przeniosłem te dwa pliki na pulpit uruchomiłem to co pisałeś wcześniejszym poście i o to wynik

ubuntu@ubuntu:~$ cd Desktop

ubuntu@ubuntu:~/Desktop$ sudo sh boot_info_script.sh


boot_info_script version: 0.60 [17 May 2011]



"gawk" could not be found, using "busybox awk" instead.

This may lead to unreliable results.


[: 326: busybox awk: unexpected operator

boot_info_script.sh: 353: Syntax error: "(" unexpected (expecting "fi")

ubuntu@ubuntu:~/Desktop$

(marcin82) #18

To zainstaluj na szybko program gawk i powtórz wykonanie skryptu:

apt-get update && apt-get install gawk

Oczywiście program jest "instalowany" do pamięci RAM i po restarcie go już nie będzie.


(Red19boy10) #19

Zainstalowałem ale dalej wyskakuje coś takiego:

root@ubuntu:/home/ubuntu# cd Desktop

root@ubuntu:/home/ubuntu/Desktop# sh boot_info_script.sh


boot_info_script version: 0.60 [17 May 2011]


boot_info_script.sh: 353: Syntax error: "(" unexpected (expecting "fi")

root@ubuntu:/home/ubuntu/Desktop#

(marcin82) #20

Dobra ... skoro twierdzisz, że po wybraniu w BIOS dysku z Windowsem wszystko startuj OK, to teraz na dysku /dev/sdb (tam gdzie był Ubutnu) korzystając z live-cd i GParted usuń po prostu partycje => Zastosuj. Utwórz na nowo partycje i sformatuj w systemie plików NTFS. Partycje powinny zostać wykryte przez Windows. Upewnij się, że chodzi o dysk /dev/sdb , opieram się na Twoim wyniku:

such-device-grub-rescue-ubuntu-t459168.html#p2905871

na /dev/sda jest tylko Windows, na /dev/sdb tylko linux.