NVidia - błąd aktualizacji repozytorium dla openSUSE 42.1


(ra-v) #1

Zobaczcie na zrzut ekranu:
https://drive.google.com/file/d/0B-2q3ptbnWQ2OVR0emlBaG1ITnM/view?usp=sharing

Niby wszystko jest ok, plik jest dostępny, ale w tym pliku w ostatniej sekcji widać taką wartość:

<location href="repodata/712c24d30131af68919b910fb81dd274082c9475d1460f4abc4e38d4b0821164-primary.xml.gz"/>

Wskazuje na plik, który tutaj nie istnieje:
http://http.download.nvidia.com/opensuse/leap/42.1/repodata/

Czy dobrze myślę, że to NVidia dała ciała i usunęła potrzebny plik?


(marcin82) #2

Podaj wynik polecenia jako root:

zypper dup

 


(ra-v) #3

https://drive.google.com/file/d/0B-2q3ptbnWQ2M0hmTklzV25Jc2c/view?usp=sharing


(marcin82) #4

Nie wiem po jakiego czorta biorą się za pisanie nakładek graficznych do menedżerów pakietów, skoro są one w stanie “niedorobionym”.

 

Zaktualizuj w pełni system - jako root - zatwierdź tą operację:

zypper dup

Jeśli będą błędy to pokaż, jeśli nie będzie błędów to napisz, że jest OK.

PS

Zaraz mnie krew zaleje z tym edytorem :smiley:


(ra-v) #5

No ja dopiero od 42.1 instaluje sterowniki w ten sposób, normalnie robiłem to “po staremu” czyli na wyłączonych X-ach instalowałem binarke z nvidia.com.

Nie chcę w pełni aktualizować wszystkich pakietów do najnowszych wersji, np. w zypper dup, który to zmieni mi wersję i repozytoria np. do Bluefisha, Digicama, VLC czy czegoś do nagrywania ekranu i kodowania filmów.
Pakiety z aktualnych repozytoriów są najświeższe, prócz NVidia.

Oczywiście, że przez zypper update będzie błąd, bo to jest tylko tekstowa forma aktualizacji.

Pobieranie metadanych repozytorium "nVidia Graphics Drivers" -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------[\]

Pliku "./repodata/712c24d30131af68919b910fb81dd274082c9475d1460f4abc4e38d4b0821164-primary.xml.gz" nie znaleziono na nośniku "http://download.nvidia.com/opensuse/leap/42.1/"



Przerwij, ponów, ignoruj? [p/s/i/? wyświetla wszystkie opcje] (p): i

Pobieranie metadanych repozytorium "nVidia Graphics Drivers" ..........................................................................................................................................................................[błąd]

Repozytorium "nVidia Graphics Drivers" jest niepoprawne.

[http-download.nvidia.com-216e1e90|http://download.nvidia.com/opensuse/leap/42.1/] Valid metadata not found at specified URL

Proszę sprawdzić, czy zdefiniowane adresy URI dla tego repozytorium wskazują na poprawne repozytorium.

Ostrzeżenie: Pominięto repozytorium "nVidia Graphics Drivers" z powodu powyższego błędu.

Część repozytoriów nie została odświeżona z powodu błędów.

 

DODANE
(PS. Mnie też szlag trafia, bo w poprzednim poście nie mogłem usunąć kodu…)

zypper dup robi podobnie. Poprzedni wynik tego polecenia wkleiłem na wyłączonym repo Nvidia (taka nieuwaga).

zypper dup
Ostrzeżenie: Zamierza się dokonać aktualizacji dystrybucji przy użyciu wszystkich dostępnych repozytoriów. Przed aktualizacją proszę się upewnić, że te repozytoria są zgodne. Więcej informacji na temat tego polecenia - patrz “man zypper”
.
 

zypper dup

Ostrzeżenie: Zamierza się dokonać aktualizacji dystrybucji przy użyciu wszystkich dostępnych repozytoriów. Przed aktualizacją proszę się upewnić, że te repozytoria są zgodne. Więcej informacji na temat tego polecenia - patrz "man zypper".

Pobieranie metadanych repozytorium "nVidia Graphics Drivers" -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------[\]

Pliku "./repodata/712c24d30131af68919b910fb81dd274082c9475d1460f4abc4e38d4b0821164-primary.xml.gz" nie znaleziono na nośniku "http://download.nvidia.com/opensuse/leap/42.1/"



Przerwij, ponów, ignoruj? [p/s/i/? wyświetla wszystkie opcje] (p): ^C

 


(marcin82) #6

Leap to wydanie ciągłe, więc nieaktualizowanie go doprowadzi w pewnym momencie do miejsca, w którym nie będzie możńa nic zaktualizować. Ale tutaj już decyduj ty.

 

Chodzi o to, że musisz odświeżyć indeksy repozytorium, co pokaże komenda:

zypper refresh

(ra-v) #7
Repozytorium "dvd" jest aktualne.

Repozytorium "google-chrome" jest aktualne.

Pobieranie metadanych repozytorium "nVidia Graphics Drivers" -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------[\]

Pliku "./repodata/712c24d30131af68919b910fb81dd274082c9475d1460f4abc4e38d4b0821164-primary.xml.gz" nie znaleziono na nośniku "http://download.nvidia.com/opensuse/leap/42.1/"



Przerwij, ponów, ignoruj? [p/s/i/? wyświetla wszystkie opcje] (p): i

Pobieranie metadanych repozytorium "nVidia Graphics Drivers" ..........................................................................................................................................................................[błąd]

Repozytorium "nVidia Graphics Drivers" jest niepoprawne.

[http-download.nvidia.com-216e1e90|http://download.nvidia.com/opensuse/leap/42.1/] Valid metadata not found at specified URL

Proszę sprawdzić, czy zdefiniowane adresy URI dla tego repozytorium wskazują na poprawne repozytorium.

Pominięto repozytorium "nVidia Graphics Drivers" z powodu powyższego błędu.

Repozytorium "devel:languages:pascal" jest aktualne.

Repozytorium "openSUSE:Leap:42.1:NonFree" jest aktualne.

Repozytorium "Education" jest aktualne.

Repozytorium "devel:languages:haskell" jest aktualne.

Repozytorium "home:ecsos" jest aktualne.

Repozytorium "games:tools" jest aktualne.

Repozytorium "games" jest aktualne.

Repozytorium "network" jest aktualne.

Repozytorium "KDE:Extra" jest aktualne.

Repozytorium "SuSE" jest aktualne.

Repozytorium "Opera packages" jest aktualne.

Repozytorium "packman" jest aktualne.

Repozytorium "openSUSE-Leap-42.1-Oss" jest aktualne.

Repozytorium "openSUSE-Leap-42.1-Update" jest aktualne.

Repozytorium "openSUSE-Leap-42.1-Update-Non-Oss" jest aktualne.

Repozytorium "vivaldi" jest aktualne.

Część repozytoriów nie została odświeżona z powodu błędów.

 


(marcin82) #8

Okej. Zgłoś to do opiekuna repozytorium. Podmienili paczki, ale byc może coś się jeszcze nie zsynchronizowało albo niepoprawnie wygenerował się indeks repozytorium. Siłą rzeczy wstrzymaj się z aktualizacją czegokolwiek, dopóki tego nie naprawią.