Obliczenia w Excel (formuły logiczne)


(ak6) #1

Muszę zrobić w Excelu pewien szablon do obliczeń procentowych danej liczby w pewnych przedziałach liczbowych.

Najlepiej wytłumaczyć mi to będzie na przykładzie.

Załóżmy, że daną mam liczbę 51000. Muszę teraz wyliczyć jej wartość procentową w następujących przedziałach:

  1. <15000 0%

  2. 15000-24000 3%

  3. 24000-35000 3,50%

  4. 35000-50000 4%

  5. >50000 4,50%

Czyli wiadomo, że dla liczby 51000

w pierwszym przedziale mamy 0 (zero)

w drugim przedziale 270 (ponieważ 24000-15000=9000, 9000*3%=270)

w trzecim przedziale 385 (ponieważ 35000-24000=11000, 11000*3,5%=385)

w czwartym przedziale 600 (ponieważ 50000-35000=15000, 15000*4%=600)

i w piątym przedziale 45 (ponieważ z 51000-50000 zostaje nam 1000, 1000*4,5%=45)

Razem suma wyników procentowych ze wszystkich przedziałów to 0+270+385+600+45=1300

Niby wszystko proste i wystarczy użyć formuły logicznej "Jeżeli" i wszystko będzie ok. Ale tylko niby bo utknąłem na komórkach, w których pojawia się wartość mniejsza od zera. Tak jest w przypadku kiedy liczba wyjściowa jest mniejsza od 50000.

Pokażę to na przykładzie:

qy926_formula.jpg

Formuła jakiej użyłem widoczna jest w oknie "Argumenty funkcji". Jak widać, w komórkach dotyczących np. liczby 17000 pojawia mi się liczba ujemna. Jak sobie z tym poradzić (zamienić liczbę ujemną na zero) aby suma była prawdziwa?

Wiem, że jest to nieco skomplikowane w związku z tym jeśli potrzebne będą dodatkowe wyjaśnienia to piszcie. Postaram się to wytłumaczyć dokładniej.


(Drobok) #2

Eh pomieszało mi się troszkę, masz dać 2 przedziały 15>x<24 itd


(Pablo_Wawa) #3

To proste, w komórce D6 (i innych też) nie sprawdzasz, czy liczba z wiersza 4 (D4) jest > 24000 i bezwarunkowo stosujesz wzór jak dla wiersza 5.

Musisz dodać tutaj odpowiedni warunek. :slight_smile:

-- Dodane 20.02.2012 (Pn) 22:26 --

Dodatkowo sugeruję użyć przy niektórych komórkach adresowania bezwzględnego ($) - chodzi o wiersz 4 (liczby) i kolumnę B (procenty).

Moje sugestie dla formuł dadzą taki efekt:

w komórce C5: =JEŻELI(C$4>15000;JEŻELI(C$4>24000;270;(C$4-15000)*$B5);0)

w komórce C6: =JEŻELI(C$4>24000;JEŻELI(C$4>35000;385;(C$4-24000)*$B6);0)


(ak6) #4

drobok , to nie do końca daje oczekiwany efekt. Na to wpadłem już wcześniej.

Dzięki Pablo_Wawa. O to chodziło.

Idąc za twoim rozumowaniem to formuła w komurce C8 powinna wyglądać następująco:

=JEŻELI(C$4>50000;(C$4-50000)*$B8;0)

Zgadza się?


(Frog) #5

I tyle wystarczy. Forum to nie czat.

Reszta dyskusji --> Śmietnik.