Obraz "nie mieści się" na ekranie telewizora podłączonego przez HDMI


(Pokrzywek321) #1

Witam. Mam laptopa z 32-bitowym systemem Linux Ubuntu 14.04 oraz zainstalowanym bumblebee (które nie działa, ale to osbny temat, który poruszyłem w nowym wątku). Posiadam również, 32-calowy TV z HD Ready. W przypadku, gdy połączę laptopa z TV przez złącze D-sub(VGA) problemu nie ma - wszystko działa. Schodki się zaczynają, gdy połączę przez HDMI. Wówczas, mimo wszelkiej dostępnej konfiguracji jaką próbowałem podjąć (Ustawienia>Ekrany) obraz jest za duży i "nie mieści się" na ekranie TV. Jest to dość denerwujące - zwłaszcza te dwa kable (a nie jeden), które muszą leżeć na szafce oraz myśl, że w Windowsie wszystko działa poprawnie. icon_biggrin.gif


(nintyfan) #2

Źle, że dodałeś ten pliczek do /etc/init.d, ponieważ xrand wymagaz włączonych X-ów. Musisz dodać ten skrypt do autostartu.


(Pokrzywek321) #3

Do autostartu (programy startowe) też go już dodałem. Jest uruchamiany razem z systemem. Mam go usunąć z init.d? Gdzie go umieścić?


(roobal) #4

Ja ostatnio walczyłem z tym samym, tyle że pod Windows. Kombinowałem z ustawieniami, sprawdziłem ustwawienia TV czy nie mam włączonego powiększania i okazało się, że miałem ustawiony inny rozmiar ekranu. Zmiana na 16:9 naprawiła problem. Sprawdź ustawienia TV.


(Pokrzywek321) #5

W tym sęk, że przetestowałem chyba wszystkie ustawienia jakie są dostępne w TV - zmieniałem, dodawałem, usuwałem, przywróciłem do domyślnych i nic... Pod Windowsem u mnie wszystko działa dobrze. Zdecydowanie jest to problem z Ubuntu, a nie z TV.


(moh3r) #6

Obraz wyświetla teraz Intel czy NVIDIA? Sterowniki otwarte czy własnościowe? Ogólnie to trzeba skompensować overscan.


(Pokrzywek321) #7

Raczej Intel, bo NVIDIA z racji tego kulejącego bumblebee nie działa. Sterownik własnościowy "NVIDIA binary driver - version 331.113 z nvidia-331". Co do overscan proszę o wytłumaczenie. :slight_smile:


(moh3r) #8

Spróbuj w terminalu wpisać: xrandr --output HDMI1 --set audio force-dvi --mode 1280x720 --right-of LVDS1


(roobal) #9

Sprawdź też na live cd/usb bez bumblebee czy jest to samo. Dziś odpalałem Ubuntu w trybie Live na laptopie z grafiką intela i Nvidia i wszystko działa poprawnie. Co prawda mamy różne karty graficzne, więc nie muszą działać tak samo, ale skoro system źle wykrywa cale TV, to coś jest nie tak.


(Pokrzywek321) #10

 

Nic nie pomoglo.

 

@roobal - Wlasnie jestem na live CD i nadal to samo. Obraz jak sie nie miescil - tak sie nie miesci.