Odpowiednik aptitude w Fedora 12?


(demisen) #1

Mam zamiar ponownie przejść na linuxa bo skończyłem z graniem. Zastanawiam się nad Fedorą (poprzednio Debian). Czy w Fedorze, też mogę w jakiś sposób za pomocą odpowiedniej komendy wykonać to co robiłem na Debianie ? Chodzi mi o masową instalację softu z zależnościami. Stawiałem sobie gołego Debiana klepałem "aptitude install exaile pidgin ..... etc" (zazwyczaj jakieś 30-40 programów) i wychodziłem na dwór :slight_smile: jak wróciłem to miałem to co chciałem :smiley:


(mati75) #2

Fedora ma yum.

http://gigablogs.wordpress.com/2007/09/ ... ramowania/


(RubasznyRumcajs) #3

ja to bym jeszcze dodał tego linka http://docs.fedoraproject.org/install-g ... index.html :slight_smile:


(wojti.) #4

Nie wiem jak w Fedorze z Gnome, posiadałem wersję 11 wraz z KDE. W składzie systemu była jeszcze graficzna nakładka na Yuma- KPackageKit. Możesz również przez nią instalować programy.


(roobal) #5

KPackegeKit to nie jest żadna nakładka na Yuma. KPackegeKit to menedżer pakietów niezależny od dystrybucji, który powstał w celu ujednolicenia dystrybucji linuksowych, czyli ma za zadanie rozwiązać problemy z różnorodnością pakietów (RPM, Deb, tar.gz, tgz itp.) w różnych dystrybucjach i ma zarządzać pakietami w jednolity sposób niezależnie od dystrybucji czy pakietu.

Co oznacza, że KPackeKit możesz używać zarówno w Fedorze jak i Ubuntu, Debianie, Mandrive czy OpenSUSE lub jeszcze innej dystrybucji zamiast Yuma, Apta, RPM czy Yasta i obsłuży on zarówno pakiety RPM jak i Deb czy jeszcze inne.

Pozdrawiam!


(wojti.) #6

Z tego co czytałem swojego czasu jak wychodził miał być nakładką na popularne menadżery, tak żeby użytkownik używający Linuksa czuł się pewnie w każdej dystrybucji. Za wikipedią

"Pierwsze założenia PackageKit Richard Hughes opublikował na swoim blogu w 2007. Pomysł spodobał się społeczności i jest teraz rozwijany przez mały zespół programistów. Fedora 9 była pierwszą dystrybucją która wykorzystywała go jako domyślnego menadżera (jako nakładka na YUM). Wykorzystywany jest również w Ubuntu (od wersji 8.04) i OpenSUSE (od wersji 11.0)

Obsługiwanych jest wiele systemów zarządzania pakietami, m.in są to APT, alpm, Conary, opkg, PiSi, poldek, Smart Package Manager, YUM i zypp"

Żródło