OpenGL na Win10 - No ICD registry entry


(Krissirk000a) #1

Witam,


(Veers) #2

Problem jest generalnie znany już od Visty - czyli od zmiany modelu sterowników w okienkach. Nie ma jakiegoś uniwersalnego rozwiązania, ale ja bym zaczął od odinstalowania sterowników i próby zainstalowania sterowników dostępnych na stronie Intela.

To niestety nie zawsze się udaje - ze względu na blokady konfiguracyjne nakładane przez producentów laptopów. Można to spróbować obejść, instalując sterowniki z pominięciem instalatora, poprzez ręczną aktualizację sterowników z poziomu Menadżera Urządzeń. Wcześniej jednak trzeba rozpakować paczkę instalatora sterownika do jakiegoś folderu tymczasowego, by można było wybrać sterownik ręcznie (wskazać ręcznie plik .inf instalatora).

Niestety - nie ma gwarancji że to ostatecznie rozwiąże problem, gdyż zdarza się że w pewnych kombinacjach GPU/chipset - jedynym obejściem jest wymuszenie trybu zgodności z DirectX i pominięcie OpenGL.


(Krissirk000a) #3

Udało mi się znaleźć i zainstalować nowsze sterowniki (maj 2015, na stronie Intel pisze, że najnowsze). W OpenGL Viewer nadal widnieje komunikat ,No icd registry entry", chociaż wychwytuje, że jest nowa wersja sterownika. Nadal jest też komunikat o przestarzałych sterownikach, chociaż jak wspomniałem, na stronie Intel nowszych nie ma.