OpenSSL - problem z kompilacją


(Btw Men) #1

Witam

Problem zaczął się od instalacji Kadu na Mandrivie 2006, pojawiał sie komunikat

libcrypto.so.4 jest wymagany przez kadu-0.3.9-1.fc2.i386

libssl.so.4 jest wymagany przez kadu-0.3.9-1.fc2.i386

jak wyszukałem potrzebne jest zainstalowanie OpenSSL, sciągnąłem i rozpakowałem openssl-0.9.8a.tar.gz. i gdy próbuje zainstalować pojawia sie

[root@localhost admin]# cd /home/admin/Desktop/openssl/openssl-0.9.8a/ssl

[root@localhost ssl]# ./configure

bash: ./configure: Nie ma takiego pliku ani katalogu

[root@localhost ssl]#

Prawdopodobnie robie cos zle, to mój drugi dzień z linuksem, proszę o pomoc.


Zmiana tematu na mówiący o problemie

Areh


#2

Za daleko wlazłeś. ./configure próbujesz zrobić w …/openssl-0.9.8a/ssl a powinieneś w …/openssl-0.9.8a

I jeszcze coś: ./configure i make robimy jako zwykły użytkownik, dopiero make install jako root.

A tak swoją drogą, to nie możesz znaleść sobie gotowego rpma, musisz od razu, na samym początku, brać się za kompilacje?


EDIT:

Teraz zauważyłem. To Kadu, które próbujesz zainstalować to jest paczka pod FedoraCore 2, w dodatku jest to stara wersja. Idż lepiej na stronę Kadu i zassaj najnowszą wersję pod Twoją wersję Mandrivy (są paczki, przed chwilą sprawdziłem).