openSUSE 10.3 - nie mogę uruchomić gry Tremulous


(demisen) #1

Od 2 dni walczę z openSUSE. Obecny problem to odpalenie gry Tremoulous:

demi@linux-i5x7:~> tremulous

tremulous 1.1.0 linux-x86 Feb 28 2006

----- FS_Startup -----

Current search path:

/home/demi/.tremulous/base

/usr/local/games/tremulous/base/vms-1.1.0.pk3 (4 files)

/usr/local/games/tremulous/base/map-uncreation-1.1.0.pk3 (110 files)

/usr/local/games/tremulous/base/map-tremor-1.1.0.pk3 (45 files)

/usr/local/games/tremulous/base/map-transit-1.1.0.pk3 (135 files)

/usr/local/games/tremulous/base/map-niveus-1.1.0.pk3 (134 files)

/usr/local/games/tremulous/base/map-nexus6-1.1.0.pk3 (151 files)

/usr/local/games/tremulous/base/map-karith-1.1.0.pk3 (118 files)

/usr/local/games/tremulous/base/map-atcs-1.1.0.pk3 (87 files)

/usr/local/games/tremulous/base/map-arachnid2-1.1.0.pk3 (67 files)

/usr/local/games/tremulous/base/data-1.1.0.pk3 (1229 files)

/usr/local/games/tremulous/base


----------------------

2080 files in pk3 files

execing default.cfg

couldn't exec autogen.cfg

couldn't exec autoexec.cfg

Hunk_Clear: reset the hunk ok

----- Client Initialization -----

----- Initializing Renderer ----

-------------------------------

----- Client Initialization Complete -----

----- R_Init -----


------- Input Initialization -------

Joystick is not active.

------------------------------------

...loading libGL.so.1:

Calling SDL_Init(SDL_INIT_VIDEO)...

SDL_Init(SDL_INIT_VIDEO) passed.

Initializing OpenGL display

...setting mode 3: 640 480

SDL_SetVideoMode failed: Couldn't find matching GLX visual

SDL_SetVideoMode failed: Couldn't find matching GLX visual

SDL_SetVideoMode failed: Couldn't find matching GLX visual

SDL_SetVideoMode failed: Couldn't find matching GLX visual

SDL_SetVideoMode failed: Couldn't find matching GLX visual

SDL_SetVideoMode failed: Couldn't find matching GLX visual

SDL_SetVideoMode failed: Couldn't find matching GLX visual

Using 4/4/4 Color bits, 16 depth, 8 stencil display.

GL_RENDERER: Mesa GLX Indirect



***********************************************************

 You are using software Mesa (no hardware acceleration)!

 Driver DLL used: libGL.so.1

 If this is intentional, add

       "+set r_allowSoftwareGL 1"

 to the command line when starting the game.

***********************************************************

...WARNING: could not set the given mode (3)

----- CL_Shutdown -----

RE_Shutdown( 1 )

-----------------------

----- CL_Shutdown -----

-----------------------

Sys_Error: GLimp_Init() - could not load OpenGL subsystem


demi@linux-i5x7:~>

Może to jest wina sterowników od grafiki bo miałem problem z ich instalacją:

#### YaST2 conflicts list - generated 2008-02-02 21:40:58 ####


x11-video-nvidiaG01 nie mo?e zosta? zainstalowany z powodu brakuj?cych zale?no?ci

    Nie ma mo?liwych do instalacji dostawc�w nvidia-gfxG01-kmp dla: x11-video-nvidiaG01-169.09-0.1.i586[NVIDIA Repository]

    === x11-video-nvidiaG01-169.09-0.1.i586[NVIDIA Repository] ===

        x11-video-nvidiaG01-169.09-0.1.i586[NVIDIA Repository] zostanie zainstalowany przez inn? aplikacj?. (ApplLow/ApplHigh)

        glibc-2.6.1-18.i686 jest wymagany przez x11-video-nvidiaG01-169.09-0.1.i586[NVIDIA Repository] (libm.so.6)

        bash-3.2-61.i586 jest wymagany przez x11-video-nvidiaG01-169.09-0.1.i586[NVIDIA Repository] (/bin/sh)

    12 wi?cej...

            libgcc42-4.2.1_20070724-17.i586 jest wymagany przez x11-video-nvidiaG01-169.09-0.1.i586[NVIDIA Repository] (libgcc_s.so.1(GCC_3.0))

            xorg-x11-libX11-7.2-75.i586 jest wymagany przez x11-video-nvidiaG01-169.09-0.1.i586[NVIDIA Repository] (libX11.so.6)

            glib2-2.14.1-4.i586 jest wymagany przez x11-video-nvidiaG01-169.09-0.1.i586[NVIDIA Repository] (libgobject-2.0.so.0)

            xorg-x11-libXext-7.2-65.i586 jest wymagany przez x11-video-nvidiaG01-169.09-0.1.i586[NVIDIA Repository] (libXext.so.6)

            zlib-1.2.3-75.i586 jest wymagany przez x11-video-nvidiaG01-169.09-0.1.i586[NVIDIA Repository] (libz.so.1)

            x11-video-nvidiaG01-169.09-0.1.i586[NVIDIA Repository] jest wymagany przez (libGLcore.so.1)

            atk-1.20.0-5.i586 jest wymagany przez x11-video-nvidiaG01-169.09-0.1.i586[NVIDIA Repository] (libatk-1.0.so.0)

            gtk2-2.12.0-5.i586 jest wymagany przez x11-video-nvidiaG01-169.09-0.1.i586[NVIDIA Repository] (libgdk-x11-2.0.so.0)

            pango-1.18.2-4.i586 jest wymagany przez x11-video-nvidiaG01-169.09-0.1.i586[NVIDIA Repository] (libpango-1.0.so.0)

            3ddiag-0.740-85.i586 jest wymagany przez x11-video-nvidiaG01-169.09-0.1.i586[NVIDIA Repository] (3ddiag == 0.740-85)

            nvidia-gfxG01-kmp-default-169.09_2.6.22.16_0.1-0.1.i586[NVIDIA Repository] dostarcza nvidia-gfxG01-kmp == 169.09_2.6.22.16_0.1, ale jest nie do odinstalowania. Nale?y spr�bowa? zainstalowa? go osobno, by uzyska? wi?cej informacji.

        (null)

    Rozwi?zanie konfliktu:

        ( ) nie instaluj x11-video-nvidiaG01

            nie instaluj x11-video-nvidiaG01-169.09-0.1.i586[NVIDIA Repository]

        ( ) Zignoruj ten wym�g tylko tutaj


#### YaST2 conflicts list END ###

Pomimo tego udało się je zainstalować "pomyślnie". Gdzie jest problem ?


(matiit) #2

Nie działa Ci openGL.

Tu masz opis jak poprawnie zainstalować sterowniki do Nvidii.

:arrow: http://pl.opensuse.org/Instalacja_stero ... ych_NVidia


(demisen) #3

Robiłem tą metodą za pomocą nvidia.ymp i miałem problem z zależnością. Pobrałem instalkę z strony nvidi, odpalam terminal, su, przechodzę do folderu z plikiem, sh nvidia-linux-....run i error [log z niego]:

nvidia-installer log file '/var/log/nvidia-installer.log'

creation time: Sat Feb 2 22:27:03 2008


option status:

  license pre-accepted : false

  update : false

  force update : false

  expert : false

  uninstall : false

  driver info : false

  precompiled interfaces : true

  no ncurses color : false

  query latest version : false

  OpenGL header files : true

  no questions : false

  silent : false

  no recursion : false

  no backup : false

  kernel module only : false

  sanity : false

  add this kernel : false

  no runlevel check : false

  no network : false

  no ABI note : false

  no RPMs : false

  no kernel module : false

  force SELinux : default

  no X server check : false

  force tls : (not specified)

  X install prefix : (not specified)

  X library install path : (not specified)

  X module install path : (not specified)

  OpenGL install prefix : (not specified)

  OpenGL install libdir : (not specified)

  utility install prefix : (not specified)

  utility install libdir : (not specified)

  doc install prefix : (not specified)

  kernel name : (not specified)

  kernel include path : (not specified)

  kernel source path : (not specified)

  kernel output path : (not specified)

  kernel install path : (not specified)

  proc mount point : /proc

  ui : (not specified)

  tmpdir : /tmp

  ftp mirror : ftp://download.nvidia.com

  RPM file list : (not specified)


Using: nvidia-installer ncurses user interface

-> The file '/tmp/.X0-lock' exists and appears to contain the process ID '7402'

   of a runnning X server.

ERROR: You appear to be running an X server; please exit X before installing. 

       For further details, please see the section INSTALLING THE NVIDIA DRIVER

       in the README available on the Linux driver download page at

       www.nvidia.com.

Bardzo mi się spodobał ten openSUSE więc nie chcę się tak szybko poddać.


(Asterisk) #4

Zapoznaj się proszę z tą stroną i zmień tytuł na konkretny.

Inaczej temat poleci do śmietnika.


(matiit) #5

A jaką masz kartę graficzną?

Może powinieneś wybrać sterowniki legacy?

Co do zależności niestety nie pomogę bo nie miałem do czynienia z openSuse...ale jest tu kilka osób które Ci na pewno pomogą... Nie rezygnuj, sterowniki Nvidia działają bardzo ładnie.

Co do ręcznej: trzeba doinstalować źródła kernela, make, gcc i jeszcze kilka rzeczy i przede wszystkim wyłączyć Xy.


(demisen) #6

Karta graficzna GF7300GT -.-

Wyłączyć Xy - nie wiem ocb :slight_smile:


(matiit) #7

Przy logowaniu możesz wybrać samą konsolę...

Albo po prostu wydaj komendę - telinit 3 (tylko nie wiem, który runlevel ma ustawiony openSuse).

Najlepiej poczekaj, aż Ci ktoś pomoże z zależnościami, bo wygodniej mieć z paczek (przy aktualizacji szczególnie).


(demisen) #8
telinit 3

Spoko odpaliłem i dostałem pytanie o login / pw. Wpisuje i nie działa -.- [wpisuje poprawnie bo zapisałem sobie na kartce przy instalowaniu]. I teraz przy uruchamianiu staje na tekstowym i loginie/pw. Można jakoś uruchomić normalnie tryb graficzny ? Czy czeka mnie reinstalka ?


(Pangrys) #9

Wbij takie komendy

init 3

sax2 -r -m 0=nvidia

init 5

Jak ci się nie uda zalogować bez X. to spróbuj w konsoli na prawach roota.

sax2 -r -m 0=nvidia

I na przyszłość

http://forum.suse.pl/index.php/topic,13868.0.html