OpenSuse 11.3 - nie mogę uruchomić Gnome Control Center


(Matek) #1

Witam

Niedawno siadłem na openSUSE 11.3 + Gnome i mam problem, mianowicie z nieznanych mi przyczyn nie mogę otworzyć Gnome Control Center (na świeżej instalacji było OK). Otrzymuję komunikat "Failure loading - settings.menu". Na root i innych użytkownikach działa bez problemu (żadna niespodzianka), choć tego pliku nie znajduję w katalogach domowych. Próbowałem usunąć wszystkie katalogi z ustawieniami Gnome, system wrócił do domyślnej konfiguracji, ale problem nadal występuje. Proszę o pomoc.

Pozdrawiam


(Hard Vard) #2

spróbuj "zupgradować" gnome.


(Matek) #3

Raz że to nic nie da, bo problem zapewne leży w configu użytkownika, a dwa że już tego próbowałem ;f

EDIT: wywolanie superuserem z terminala :

(gnome-control-center:13202): Unique-DBus-WARNING **: Unable to open a connection to the session bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.


(gnome-control-center:13202): Unique-DBus-WARNING **: Unable to connect to the running instance, aborting.

(nintyfan) #4

Spróbuj to samo wywołać z terminala bez superusera.

Gnome-Control-Center próbuje się podłączyć do SessionBUS, a jako inny użytkownik niż właściciel sesji nie może tego zrobić.


(Matek) #5

Efekt jest taki sam jak normale uruchamianie.

Może jeszcze dodam że zaraz po rozpoczęciu występowania błędu pojawiało się okno Centrum sterowania, lecz po ułamku sekundy znikało.