OpenSUSE 11 błysk monitora LCD zamiast pulpitu


(Robin-Otzi) #1

miałem już taki problem startując linuksy z płyt LiveCD

myślałem, że po zainstalowaniu na dysku twardym lepiej sobie poradzi z obsługą grafiki

zainstalowałem openSUSE 11 i KDE 3,2 (czy jakoś tam) system startuje bez problemu

lecz zamiast pokazać pulpit czy tam najpierw okno logowania na ekranie jest błysk (tzn cały robi się na moment biały i ciemnieje)

wyłącza się. Do trybu tekstowego mogę się spokojnie zalogować, działa również tryb graficzny ale jak wybiorę przy stracie tryb awaryjny.

grafika wbudowana: GeForce 6150SE Nforce 430

monitor LCD: Samsung SyncMaster 740n

1280x1024 @ 72Hz w Windows

z tego co udało mi się znaleźć w Linuksie podaje 77Hz i to może jest problem

nie mam jednak możliwości zmiany rozdzielczości ani odświeżania.

Jest może jakiś konfigurator, polecenie do zmiany ustawień czy jak mam zrobić aby w normalnym trybie graficznym wszystko działało OK


(Kynski) #2

Podaj wynik polecenia:

cat /etc/X11/xorg.conf

(Robin-Otzi) #3
# /.../  	

# SaX generated X11 config file 	

# Created on: 2009-01-22T12:57:26+0100. 	

# 	

# Version: 8.1 	

# Contact: Marcus Schaefer , 2005 	

# Contact: SaX-User list 

# 	

# Automatically generated by [ISaX] (8.1) 	

# PLEASE DO NOT EDIT THIS FILE! 	

# 	

Section "Files" 	

FontPath "/usr/share/fonts/misc:unscaled" 	

FontPath "/usr/share/fonts/local" 	

FontPath "/usr/share/fonts/75dpi:unscaled" 	

FontPath "/usr/share/fonts/100dpi:unscaled" 	

FontPath "/usr/share/fonts/Type1" 	

FontPath "/usr/share/fonts/URW" 	

FontPath "/usr/share/fonts/Speedo" 	

FontPath "/usr/share/fonts/PEX" 	

FontPath "/usr/share/fonts/cyrillic" 	

FontPath "/usr/share/fonts/latin2/misc:unscaled" 	

FontPath "/usr/share/fonts/latin2/75dpi:unscaled" 	

FontPath "/usr/share/fonts/latin2/100dpi:unscaled" 	

FontPath "/usr/share/fonts/latin2/Type1" 	

FontPath "/usr/share/fonts/latin7/75dpi:unscaled" 	

FontPath "/usr/share/fonts/baekmuk:unscaled" 	

FontPath "/usr/share/fonts/japanese:unscaled" 	

FontPath "/usr/share/fonts/kwintv" 	

FontPath "/usr/share/fonts/truetype" 	

FontPath "/usr/share/fonts/uni:unscaled" 	

FontPath "/usr/share/fonts/CID" 	

FontPath "/usr/share/fonts/ucs/misc:unscaled" 	

FontPath "/usr/share/fonts/ucs/75dpi:unscaled" 	

FontPath "/usr/share/fonts/ucs/100dpi:unscaled" 	

FontPath "/usr/share/fonts/hellas/misc:unscaled" 	

FontPath "/usr/share/fonts/hellas/75dpi:unscaled" 	

FontPath "/usr/share/fonts/hellas/100dpi:unscaled" 	

FontPath "/usr/share/fonts/hellas/Type1" 	

FontPath "/usr/share/fonts/misc/sgi:unscaled" 	

FontPath "/usr/share/fonts/xtest" 	

FontPath "/opt/kde3/share/fonts" 	

InputDevices "/dev/gpmdata" 	

InputDevices "/dev/input/mice" 	

EndSection 	



Section "ServerFlags" 	

Option "AllowMouseOpenFail" "on" 	

Option "ZapWarning" "on" 	

EndSection 	



Section "Module" 	

Load "glx" 	

Load "type1" 	

Load "extmod" 	

Load "dbe" 	

Load "freetype" 	

EndSection 	



Section "InputDevice" 	

Driver "kbd" 	

Identifier "Keyboard[0]" 	

Option "Protocol" "Standard" 	

Option "XkbLayout" "pl" 	

Option "XkbModel" "microsoftpro" 	

Option "XkbRules" "xfree86" 	

EndSection 	



Section "InputDevice" 	

Driver "mouse" 	

Identifier "Mouse[1]" 	

Option "Buttons" "14" 	

Option "Device" "/dev/input/mice" 	

Option "Name" "A4 Tech PS/2+USB Mouse" 	

Option "Protocol" "explorerps/2" 	

Option "Vendor" "Sysp" 	

Option "ZAxisMapping" "4 5" 	

EndSection 	



Section "Monitor" 	

Option "CalcAlgorithm" "XServerPool" 	

DisplaySize 338 270 	

HorizSync 30-81 	

Identifier "Monitor[0]" 	

ModelName "SAMSUNG SYNCMASTER" 	

Option "DPMS" 	

Option "PreferredMode" "800x600" 	

VendorName "SAM" 	

VertRefresh 43-75 	

UseModes "Modes[0]" 	

EndSection 	



Section "Modes" 	

Identifier "Modes[0]" 	

Modeline 1280x1024 108.00 1280 1328 1440 1688 1024 1025 1028 1066 +HSync +VSync

Modeline 800x600 49.50 800 912 992 1056 600 601 604 625

EndSection 	



Section "Screen" 	

DefaultDepth 24 	

SubSection "Display" 	

Depth 15 	

Modes "800x600" "768x576" "640x480" 	

EndSubSection 	

SubSection "Display" 	

Depth 16 	

Modes "800x600" "768x576" "640x480" 	

EndSubSection 	

SubSection "Display" 	

Depth 24 	

Modes "800x600" "768x576" "640x480" 	

EndSubSection 	

SubSection "Display" 	

Depth 8 	

Modes "800x600" "768x576" "640x480" 	

EndSubSection 	

Device "Device[0]" 	

Identifier "Screen[0]" 	

Monitor "Monitor[0]" 	

EndSection 	



Section "Device" 	

BoardName "GeForce 6100 nForce 430" 	

BusID "0:13:0" 	

Driver "nv" 	

Identifier "Device[0]" 	

Screen 0 	

VendorName "NVidia" 	

EndSection 	



Section "ServerLayout" 	

Identifier "Layout[all]" 	

InputDevice "Keyboard[0]" "CoreKeyboard" 	

InputDevice "Mouse[1]" "CorePointer" 	

Option "Clone" "off" 	

Option "Xinerama" "off" 	

Screen "Screen[0]" 	

EndSection 	



Section "DRI" 	

Group "video" 	

Mode 0660 	

EndSection 	



Section "Extensions" 	

Option "Composite" "off" 	

EndSection

(Kynski) #4

Hmmm.. Możliwe, że jest to problem z odświeżaniem jak mówisz..

Zaloguj się na konto roota. Następne wykonaj polecenia:

Xorg -configure && mv xorg.conf.new /etc/X11/xorg.conf

Pamiętaj, aby podczas polecenia serwer X11 nie był włączony.


(matiit) #5

Tylko nie wiem czy SAX2 i tak nie zastąpi tego configa...


(Kynski) #6

Mówisz, że zastąpi po wydaniu polecenia:

Xorg -configure

Jeśli tak, to możliwe.. Ale, jeśli mam być szczery to zawsze tworzyło mi nowy plik xorg.conf w katalogu, w którym obecnie jestem.


(Robin-Otzi) #7

poradziłem sobie inaczej

poczytałem man'a i znalazłem opcję kombinację klawiszy do przełączania rozdzielczości

Ctrl+Alt+"szary +" lub "szary -"

trochę się nastukałem aby dojść do pasujących ustawień

sprawdzę to samo na dystrybucjach Live

np Knoppix 6 :smiley: