OpenSuse instalacja obok Windows 10


(Karaluch580) #1

Witam, chciałbym zainstalować OpenSuse obok Windows 10, jednak wyświetla mi się że partycje należące do OS Microsoftu zostaną usunięte no i pokazuje mi się taki komunikat, że jest to wymagane, gdyż mój dysk nie ma etykiety GPT.
Posiadam Dysk Toshiba DT01ACA100.


(roobal) #2

Jeśli nie masz gpt, to Linuksa nie instaluj w UEFI tylko w legacy/bios mode.


(Karaluch580) #3

A jak to zrobić? UEFI mam od ASRock.


(marcin82) #4

Masz jakieś inne livecd? Jeśli tak to uruchom, potem uruchom terminal / konsolę, podnieś uprawnienia:

i podaj wynik poleceń:

EDYCJA:
Podaj dokładny model płyty głównej.


(lingruby) #5

ja mam gpt i UEFI miałem jeszcze jakiś czas temu win10/linux i wszystko hulało teraz chwast został wyrwany i został sam arch linux ( gpt i UEFI ) :wink:

tylko trzeba zrobić mały myk czyli hasło na bios i wyłączyć Secure Boot: disable i wszystko działa :smiley:

acz są distra których nie odpalisz na UEFI ( pomino myku z bios ) ale w większości UEFI jest już wspierany


(roobal) #6

Tyle, kolega twierdzi, iż nie ma gpt, a prawdopodobnie mbr. Można to przekonwertować lub instalować w trybie legacy.


(Radek68) #7

Autorowi wątku chyba nie o to chodzi, że są Linuksy które można zainstalować na UEFI, tylko jak zainstalować OpenSuse obok Windowsa.


(Karaluch580) #8

Nie mogę znaleźć nic w UEFI o tym BIOS Legacy Mode. Przy wybraniu bootowania mam napęd, dysk, UEFI Sandisk oraz USB Sandisk z tym że po wybraniu USB Sandisk uruchamia się Windows. Płyta główna to https://www.morele.net/plyta-glowna-asrock-h81m-s1150-h81-2ddr3-usb3-hd-dvi-ds-box-h81m-605249/


(marcin82) #9

Żeby uruchomić komputer bez UEFI ustaw w BIOS wszystkie pozycje w zakładce BOOT tak jak [akurat] jest ustawione w instrukcji na stronie 72:
ftp://europe.asrock.com/Manual/H81M.pdf .

Nie rób nic “na pałę”. Najlepiej byłoby przygotować ręcznie partycje dla linuksa, a potem wskazać tylko punkty montowania.


(Karaluch580) #10

Zerknąłem i mam tak samo ustawione jak w instrukcji. Próbowałem partycjonować ręcznie jednak albo wywalał jakiś komunikat, ewentualnie już się po prostu gubiłem :slight_smile:

Jest sens próbować z inną dystrybucją skoro z tą jest taki problem?


(marcin82) #11

Najpierw jest sens podać wyniki komend, o których pisałem wcześniej …

Oczywiście, że jest sens chociażby przetestować livecd innych dystrybucji. Zobacz np. Manjaro czy PCLinuxOS.


(roobal) #12

Jeśli nie startuje Ci z usb sandisk, sprawdź czy masz w uefi fastboot disabled.

W windows wyłącz też szybkie uruchamianie, tak żeby windows zamknął system, a nie go w polowie zahibernował. Ta hybryda i tak nic nie daje i stwarza tylko problemy.


(Karaluch580) #13

Wyniki komend, które zostały użyte na Lubuntu:

Sprawdziłem i mam ustawione w UEFI Fast Boot na disabled. Wyłączyłem też szybkie uruchamianie i bez zmian.
Gdyby to miało coś na rzeczy, to używam programu Rufus do wgrywania Linuxa na pendrive.


(marcin82) #14

Sprawdź jeszcze dla pewności - w jakim trybie zostało uruchomione Ubuntu. Sprawdzisz to poleceniem:

Ponieważ nie widzę procesu startu komputera, uruchamiania BIOS, POST itd. to jest to w pewnym sensie gdybanie … Moim zdaniem instalator OpenSUSE po prostu “nie widzi” dla siebie miejsca (4 partycje podstawowe) i dlatego proponuje według jakiegoś tam swojego algorytmu - wybrane rozwiązanie, czyli zaoranie wszystkiego.

W livecd Lubuntu możesz “online” zainstalować program GParted. Jeśli na partycji /dev/sda4 masz jakieś dane - przenieś je gdzie indziej. Potem:

  1. Usuń partycję /dev/sda4
  2. Utwórz partycję ROZSZERZONĄ (extended) -> ZASTOSUJ
  3. W obrębie partycji rozszerzonej utwórz trzy partycje logiczne - odpowiednio:
    4a) główny system plików ( “/” root); ext4 -> 20GB
    4b) katalog użytkownika ( "/home); ext4 -> 232GB /minus/ 20GB /minus/ SWAP
    4c) partycja wymiany SWAP - jeśli używasz wstrzymania (suspend to RAM) musi mieć trochę więcej niż pamięć RAM. Jeśli w ogóle nie używasz to SWAP można pominąć.

Napisz, ile masz pamięci RAM.

Po wszystkim uruchom OpenSUSE i wybierz “Utwórz własny rozkład partycji”. Tam powinno być możliwe przypisanie partycji do punktów montowania. Dopóki nie będziesz 100% pewny, że wiesz co robisz - nic nie zatwierdzaj. Zawsze można cofnąć.


(Domker) #15

Przede wszystkim na dysku twardym ma zwykłe MBR, a nośnik LiveUSB ma zrobiony pod GPT. (UEFI)!!
LiveUSB uruchamia mu się w trybie UEFI, bo w BIOS ma włączony CSM. (możliwość startu z nośników z MBR jak i GPT).

Zacząłbym od zrobienia nośnika z Linuxem z MBR.
W Rufusie wybierz MBR dla BIOS. (a nie domyślne ustawienie).
Wtedy LiveUSB wystartuje na 100% w trybie MBR i nie będzie problemu później z instalatorem.


(marcin82) #16

Jakby tak było to by mu SUSE w ogóle nie startowało => [ Legacy only ] w BIOS. CSM umożliwia właśnie uruchamianie w trybie zgodności z BIOS. Chociaż możliwe, że automagiczny Rufus coś namieszał.


(Karaluch580) #17

Zrobienie nośnika z MBR nic nie dało.

Lubuntu zostało uruchomione w trybie UEFI zgodnie z tym co zostało wyświetlone w terminalu. Co do RAM to posiadam 8 GB DDR 3 GOODRAM Play.
W Lubuntu na Live CD jest już GParted, zatem spróbuję później, Jednak nie wiem czy jest sens dawać na home te 232 GB, gdyż nie wiem żebym tyle wykorzystał na SuperSU.


(marcin82) #18

Przejrzyj - może coś przeoczyliśmy:
http://forum.asrock.com/forum_posts.asp?TID=2081&title=how-to-switch-to-legacy-bios-for-win7-install



(roobal) #19

W ostateczności możesz przekonwertować tablicę partycji na gpt. Jeśli ostatnia partycja nie jest w całości zawalona, zmniejszysz ją i będziesz miał miejsce pod Linuksa.

Nie wiem jak Windows zachowuje się w stosunku do systemu plików, ale Linuks zachowuje sobie system plików. Nawet jak rozwalisz sobie tablicę partycji, dane pozostaną na dysku. Wystarczy tylko odtworzyć układ partycji. Dlatego w razie gdyby coś się sypnęło, to nie próbuj w zadnym przypadku ratować danych spod Windowsa.

Szczerze to nawet lepiej byłoby konwersję robić pod Linuksem, bo znając życie, Windows jak zaora mbr, to wyczyści również system plików.


(Karaluch580) #20

Spróbuję może najpierw zainstalować Debiana czy coś innego, natomiast z partycjami pobawię się najpóźniej w najbliższy piątek, ponieważ w razie gdybym coś sknocił to nie mam za bardzo czasu na stawianie systemu na nowo. Dziękuję bardzo za pomoc, jeżeli problemu nie rozwiąże to napisze, albo jeśli rozwiążę to zostawię informację dla potomnych co pomogło. :slight_smile:

Edycja:Dam sobie na razie spokój, na Debianie pisze następujące gdy trochę poklikałem: