OpenSUSE Leap 42.2 i wolne działanie plasmashell


(nintyfan) #1

Zainstalowałem ojcu OpenSuSE Leap 42.2, gdyż do tej pory korzystał z powodzeniem z OpenSuSE 13.1(z KDE4). Przeprowadziłem aktualizację. Problem polega na wolnym działaniu plasmashell, niezależnie od ustawień kompozytora, korzystania jądra ze swapu, itd. Przede wszystkim:

  1. Ojciec korzysta z układu widok katalogu

  2. Rozciąganie zaznaczenia na pulpicie trwa wolno

  3. Zaznaczenie ikon na pulpicie wolno się odświeża

  4. Ojciec ma grafikę Intela(pewnie jakiś stary układ)

  5. Ustawienia plasmy i całego kde są nowe

 

Gdzie jeszcze(prócz kompozytora i swapu) mogę szukać przyczyny.


(pocolog) #2

Sprawdź czy grafika działa

glxgears

glxinfo | grep render

Podaj model karty graficznej.


(nintyfan) #3

>glxgears

301 frames in 5.0 seconds = 60.155 FPS
301 frames in 5.0 seconds = 60.051 FPS
299 frames in 5.0 seconds = 59.656 FPS
301 frames in 5.0 seconds = 60.061 FPS
301 frames in 5.0 seconds = 60.057 FPS
300 frames in 5.0 seconds = 59.850 FPS

>glxinfo | grep render

direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
OpenGL renderer string: Mesa DRI Intel® G33 x86/MMX/SSE2
    GL_OES_fbo_render_mipmap, GL_OES_get_program_binary, GL_OES_mapbuffer

>/sbin/lspci

00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 10)


(pocolog) #4

Jako root w htop posortuj sobie procesy według obciążenia procesora i sprawdź czy go nic nadmiernie nie obciąża. W kde4 te wszystkie akonadi i spółka potrafiły mi czasem nieźle gotować cpu.


(Domker) #5

Przyczyn może być wiele, ale spróbuj może:

 W sekcji “Uruchamianie i wyłączanie” wejdź do “Sesja pulpitu” i zaznacz - przy wychodzeniu “Zakończ bieżącą sesję”, przy logowaniu “Rozpocznij pustą sesję”

 

Miałem raz taką sytuację, ale nie z OpenSuse tylko Mintem edycja KDE.

Kombinowałem wtedy, aż to pomogło.


(nintyfan) #6

U mnie Plasma5 działa żwawiej od KDE4, więc nie spodziewałem się, że nadmierna liczba ikon na pulpicie może być przyczyną. Sytuacja rozwiązana.


(nintyfan) #7

Jednak problem nie został do końca rozwiązany. Dzisiaj się dowiedziałem, że podczas przesuwania myszki nad ikonami okna programu plasma-shell obciążenie procesora dochodzi do 50%. Ponieważ jest to procesor dwurdzeniowy, to domyślam się, że jeden rdzeń jest maksymalnie zajęty. Być może, gdyby był to procesor jednordzeniowy, to byłby zajęty w 100%.


(nintyfan) #8

Teraz okazało się, że Ojciec narzeka też na działanie GNOME. Zainstalowany flash przez wrapper PAPPER API na NPAPI tnie niemiłosiernie. Spróbuję zainstalować flash przez pipelight.


(nintyfan) #9

Żadnej pomocy nie dostałem na tym forum. Tymczasem przejrzałem bugzillę KDE i natrafiłem na ten wątek:

https://bugs.kde.org/show_bug.cgi?id=356479

 

Być może, dzięki włączeniu jakiejś łatki do gałęzi 5.8, Plasma na komputerze ojca zacznie normalne działać. Oczywiście, że nie jestem pewien, iż łatka coś pomoże, ale jest to możliwe. Nie wiem za ile łatka trafi do aktualizacji, ale w momencie, gdy Plasma na komputerze mojego ojca zacznie normalnie działać, to poproszę o zamknięcie tematu.


#10

Konsola i:

akonadictl stop

balooctl stop

Sprawdź, czy cokolwiek pomogło.

Umiesz uruchomić Plasmę na GLES? Jeśli tak, to spróbuj. Zobaczymy.

No i last but not least, ale zawsze tak trzeba. Rozumiem, że w przypadku tego komputera nastąpił “upgrade” z KDE4 do Plasma 5. Zatem dwie możliwości do wyboru ( uwaga po pierwszej będziesz musiał potem poprzywracać nieco do “normalności”, zatem musisz wiedzieć jak to zrobić np. w konsoli - jeśli masz wątpliwości - pytaj).

  1. Zmieniasz nazwę dwu katalogów na dowolne, łatwe do zapamiętania, bądź spisujesz na kartce (tak najlepiej) co zrobiłeś. Nazwy katalogów docelowych poniżej zakładają suffix bak, a całość w konsoli (nie jest to końieczne, można w dolphinie - po prostu mi tak łatwiej).
     

    mv ~/.config ~/config.bak

    mv ~/.local ~/.local.bak

Teraz sprawdzasz jeszcze czy nie istnieją jakieś pozostałości po KDE4, których Plasma chciałaby się dobrać (choćby katalogi .kde4; ten akurat na 99% istnieje). Jeśli tak, postępujesz analogicznie jak wyżej.

Nie pamiętam też, w jaki sposób dostarczane są różne tematy itp. ustawień wyglądu Plasma 5 w OpenSUSE, ale o ile się nie mylę - globalnie, paczkami. Przed następnym ruchem, dla pewności odinstaluj wszelkie ustawienia personifikujące wygląd KDE4. Wszelkie, włacznie z ikonami. Bardzo często problem, który opisałeś powodują stare, niedostosowane do nowej (ponad 2 lata już Plasmy wystroje, ikony, tematy itp. dla KDE4. Wystroje z KDE4, choć działające (teoretycznie) i tak na nic nie są Ci potrzebne, bowiem powodują przypadłości, jak opisane przez Ciebie.

Następnie wykonujesz przelogowanie się. Otrzymasz “natywny” wygląd Plasma 5, pozbawiony jakichkolwiek pozostałości po starym KDE4. Jeśli chodzi - jeśli nie dobrze - ale po prostu lepiej; problem leży w pozostałościach po instalacji 3rd parties wystrojów itp. dla KDE4 i ustawieniach w plikach konfigurujących środowisko.

 

  1. Alternatywa - jeśli potrafisz dodać nowego użytkownika - dodaj, uruchom sesję na nowym użytkowniku (bądź w przypadku stosowania lightdm na tzw. sesji gościa) i zobacz, czy to pomaga.

(saturno) #11

Aplikacje z poza środowiska (Vlc, SMPlayer, itp.) uruchamiają się normalnie?

 

Nie podałeś parametrów komputera.


#12

@saturnoJemu działa wolno plasmashell, a nie poszczególne aplikacje. Tak na 99% za to co opisał odpowiada KWin (aha, karta Intela, to jeszcze kilka ustawień). Najpierw jeszcze niech wyeliminuje ewentualne błędy wynikające z migracji.


(saturno) #13

 

 


(nintyfan) #14

Dzięki za zainteresowanie. Zamiast się bawić w zmianę nazw katalogów, to utworzę czysty profil(nowy użytkownik), Dzisiaj lub jutro przeprowadzę testy.


(nintyfan) #15

Utworzyłem nowy profil i nadal to samo. Jak znajdę czas,. to wyłączę baloo i akanodi.


(eskimosek) #16

Opensuse to jest trochę ciężki system jak na 2 rdzeniowy komp.Do opensuse trzeba mieć szybki komp.Zmien sobie może dystrybucje na Sparky Linux KDE i będzie szybciej,


(nintyfan) #17

Dzięki. Obecnie ten komp jest niewykorzystywany, więc będą móc zainstalować tam inny system. Jednak problem w tym, że KDE4 chodziło płynnie, a w Plaśmie5 ponoć poprawili to i owo. Winne są chyba jednak sterowniki graficzne, a nie sama Plasma.


(Latający Turban) #18

Też tak miałem na intelu. ARCH z KDE 4 chodził płynnie z wszystkimi animacjami i przezroczystością a Plasma 5 była nie do użytku. Jak na moje oko musiałbyś całkiem wyłączyć kompozycje albo jechać na XFCE/ LXQT


#19

No to kilka “prawd” o Plasma 5.
De facto zasobożerność samej Plasmy jest niższa od KDE4. Plasmashell, czy KWin mają mniejsze zapotrzebowanie tak na RAM, jak i na CPU. Oczywiście przy takich samych ustawieniach systemu i środowiska i na tym samym komputerze.
LXQT w zależności od tego, czy używa OpenBOX, czy KWin ma mniejsze lub większe zapotrzebowanie na zasoby.
U mnie efekty częściowo włączone, przezroczystość wyłącznie pod panelem, komputer do to raczej low-end: AMD A6-4455M z wbudowanym (APU) Radeon HD7500G, 4GB RAM.
99% to jest kwestia ustawień i to tak samego systemu/dystrybucji, jak i użytkownika.


(Domker) #20

Jeżeli chodzi o szybkość działania Plasmy 5 to wbrew pozorom duże ma znaczenie dystrybucja.
Na OpenSUSE na starym kompie (AMD64 3000+, 4GB ddr ram, stary geforce) okropnie muliła, a na Manjaro np. działa płynnie.
Często też sytuację trochę polepsza zmiana silnika wyświetlania w kompozytorze.
U siebie zmieniłem z OpenGL 2.0 na OpenGL 3.1 i jest mała różnica.
W przypadku słabszego APU, czasami dobrze jest zrezygnować z “efektów”.