[openSUSE] Przywrócenie pulpitu

Jak przy niedziałającym środowisku graficznym zainstalować/przywrócić sterownik graficzny (nvidia)?

Ja bym spróbował X --configure

Nie dam głowy, że pomoże.

jesli “zgubiło” się po zainstalowaniu sterownika to zalogować się do konsoli i odinstalować poprzez zypper remove
ewentualnie powinno być polecenie nvidia-xconfig które powinno skonfigurować wszystko ok.
ewentualnie usunąć /etc/xorg.conf

Pliki xorg.conf raczej nie ma. Jest katalog z plikami konfiguracyjnym x-ów. /etc/X/xorg.conf.d chyba. Może znajdziesz tam plik z NVIDIA w członie. Zmień mu nazwę, doklejając coś do końca (np. .backup) i zrestartuj system.

Do zmiany nazwy posłuż się mv lub programem midnight commander. Ten ostatni może będziesz musieć zainstalować.

Do instalacji programów zaloguj się na roota. Potem np. zypper se “midnight commander” i zypper instalki nazwa paczki.

Zrobiłem tak jak nintyfan poradziłeś, i od razu odpalił. Dzięki wielkie!

Teraz wynikł jeszcze taki problem, że nvidia-settings nie chce za nic zapisywać ustawień.
Nawet nie chce się uruchomić przez sudo z terminala.

1lajk

OpenSUSE to nie Ubuntu. U mnie apki QT nie działają przez sudo. Spróbuj xdg-su .

xdg-su -c "polecenie"

Po co uruchamiać nvidia-settings z podwyższonymi uprawieniami? Klikasz ikonę w menu programów, a zmiany zostają zapisane do pliku ~/.nvidia-settings-rc.

Sprzętem zarządza udev i nie jest konieczne umieszczanie żadnych wpisów w /etc/X11/xorg.conf lub /etc/X11/xorg.conf.d/* .

Hałtu:
https://en.opensuse.org/SDB:NVIDIA_drivers .

Jeśli instalujecie coś “z łapy” to potem mogą być jaja…

Nie wydaje mi się żeby było tak jak piszesz.
Gdyby zmiany były gdzieś zapisywane to po restarcie powinny być, prawda? A nie było.
nvidia-settings domyślnie “chce” zapisywać do pliku /etc/X11/xorg.conf
Tylko że wygląda na to, że serwer wyświetlania bierze pod uwagę to co jest w pliku /etc/X11/xorg.conf.d/01-nvidia.conf
Bo po zapisaniu konfiguracji do tego pliku po restarcie jest to co ustawię.
A bez podniesienia uprawnień nvidia-settings nic nie zapisze. Co więcej ścieżki do config też nie zapamiętuje, i jak sam jej nie zapamiętam, a za jakiś czas będę chciał coś zmienić to pewnie znowu zapisze do /etc/X11/xorg.conf i nie będzie działać po restarcie.

A w ogóle to nie ma tu żadnych WY, co “instalujecie coś z “łapy””. JA niczego z łapy nie instalowałe, nie wiem skąd takie przypuszczenia…

Poza tym jakby wszystko działało to bym nie musiał kombinować.
Od dłuższego już czasu mam błąd w wyświetlanym obrazie, zgubiła się jedna linia (przypomina to niesławny ‘tearing’ z tym że występuje permamentnie na statycznym obrazie) więc próbuję zmieniać ustawienia czy sterowniki, ale póki co, niestety bez powodzenia.

@nintyfan Jeszcze raz dzięki wielkie za wskazówki, były naprawdę bardzo trafne i pomocne!
Co do tego xdg-su to przypomniałem sobie, że już to robiłem na starszej wersji distro (bodaj Leap 15.1) i wtedy system sam podpowiedział komendę, a teraz tylko jakieś bezsensowne komunikaty wypluwa. IMO coraz gorszy ten openSUSE robią.

„Co do tego xdg-su to przypomniałem sobie, że już to robiłem na starszej wersji distro (bodaj Leap 15.1) i wtedy system sam podpowiedział komendę, a teraz tylko jakieś bezsensowne komunikaty wypluwa. IMO coraz gorszy ten openSUSE robią.”

Nie wiem, o co chodzi? Chodzi o to, że autouzupełnianie tabulatorem nie działa? Uruchom Yast-a, moduł zarządzanie oprogramowaniem, tam wyszukaj NVidia lub podobny ciąg. Jak znajdziesz, to zaznacz wyszukaną paczkę i pod spodem zobacz listę plików. Powinno być coś w /bin, /sbin, /usr/bin, /usr/sbin, /usr/local/bin lub /usr/local/sbin. Co do dwóch ostatnich, to wątpię, ale może instalowałeś paczkę z oficjalnej strony (jeśli jest), więc wcisnęli konfiguratory do /usr/local .

EDIT: Może xdg-su nie jest domyślnie zainstalowane, w co wątpię. Jeśli nie, to cnf xdg-su powinno pomóc. Są też inne opcje, więc jeśli wolisz unikać instalacji dodatkowego oprogramowania, to można wykorzystać sudo/pkexec wraz z programem env.

https://wiki.archlinux.org/title/NVIDIA/Troubleshooting#Avoid_screen_tearing_in_KDE_.28KWin.29