Opera 44 - problem z Facebookiem


(ichu) #1

Od dwóch ostatnich aktualizacji Opery mam problem z wyświetlaniem Facebooka - strona ładuje się, wczytuje dwa posty na tablicy, po czym wszystko staje w miejscu. Nie mogę przewinąć ani kliknąć w żaden link. Zamknięcie karty zajmuje dłuższą chwilę, raz udało mi się osiągnąć stan w którym Opera przestała reagować na próbę zamknięcia tej jednej karty z Facebookiem.
Posiadana wersja Opery: 44.0.2510.1159 (najnowsza w chwili pisania posta)
Wersja systemu: 10.12.4
Czyściłem pamięć podręczną i ciastka. Na Chrome strona otwiera się poprawnie. Problem występuję jedynie z Facebookiem. Pomocy!


#2

Spróbuj zmienić user agent na bardziej chromowaty bez OPR/44.0.2510.1159

Dodatki do zmiany UA:

https://addons.opera.com/pl/extensions/details/user-agent-switcher/?display=en
https://addons.opera.com/pl/extensions/details/custom-useragent-string/?display=en
https://addons.opera.com/pl/extensions/details/domainuseragent/?display=en

Jednorazowo bez dodatków możesz uruchomić poleceniem/utworzyć nowy skrót:

opera --user-agent="Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.98 Safari/537.36" przy okazji trochę ich okłamiesz że masz Windows 7.

Jak nie pomoże to jeszcze możesz przetestować jak jest na wersji przenośnej (nie ważne czy z PotrableApps, ustawienie nowej instalacji na tryb “Sandalone” czy też użycie instalatora z wybranym od razu trybem “Sandalone”).


(Domker) #3

Do czego to doszło, że trzeba fałszować user-agent, żeby poprawnie strony działały ;D
Ale fakt jest faktem - czy to ze względu na przeglądarkę, czy system operacyjny strony często serwują groszy kod i o zgroza zwykle zabugowany.


(ichu) #4

Bardzo dziękuję za pomoc, zmieniłem User Agent, ponownie wyczyściłem cache i cookies, niestety nie przyniosło to żadnego rezultatu :frowning: Postanowiłem wypróbować jeszcze jedną opcję - instalacja Vivaldiego. Na razie wszystko jest ok, albo porzucę Operę definitywnie (szkoda by było po iluś tam latach, ale cóż…) albo przeczekam aż wynajdą jakieś rozwiązanie. Wcześniej zgłosiłem to na operowym forum, niestety, bez odpowiedzi.
Przyznam jednak że w obecnej formie Vivaldi bardzo kusi do pozostania z nim na dłużej.

EDIT: Ciąg dalszy historii - postanowiłem dać szansę Operze Beta i tam wszystko działa. Postanowiłem jeszcze sprawdzić ponownie w standardowej wersji i… tam też działa. Może problem był po stronie Facebooka.


(no9) #5

U mnie nic takiego nie występuje. Może to któryś z dodatków powoduje, bo nie napisałeś czy je wyłączyłeś.


(ichu) #6

Jedynie Adblock Plus, ale wcześniej już próbowałem na wyłączonym - bez rezultatu. Tak jak wspomniałem, problem zniknął dzisiaj, więc być może było to po stronie Fejsa. Pozdrawiam :slight_smile:


#7

Taki problem jest też na Bing images MS nie potrafi rozpoznać przez dodane w UA OPR/XXXXXXX jako nowoczesnej przeglądarki i serwuje wersje jak dla IE8, raczej nigdy nie zmienią tam by wykrywać inaczej co obsługuje przeglądarka.