Opóźnienie napisów w odtwarzaczu TOTEM Ubuntu7.10


(Trawnik) #1

Chciałem odtwarzać filmy w programie TOTEM, lecz napisy są opóźnione o jakieś 10 sekund. Filmy i napisy mam w katalogu Windowsa na dysku NTFS. W Windows wszystko działało prawidłowo, za to jakość obrazu w Linux jest o niebo lepsza niż Windows. Szukałem rozwiązania w Internecie, lecz nie znalazłem. :frowning:


(matiit) #2

Zainstaluj mplayer lub smplayer.... lepiej sobie radzi z napisami niż totem.


(Soren) #3

Pewny jesteś czy poprostu napisy sa dobrze zsynchronizowane z filmem?


(Sim Jude96) #4

w m Player masz 2 klawisze do synchronizacji napisów z filmem jeden w tył i jeden w przód masz link: http://linux.softpedia.com/get/Multimed ... -020.shtml


(Trawnik) #5

Tak jestem pewien. Nie zależy to od kodeka filmu, lecz zależy od jego framerate. Przy 23 działa dobrze, natomiast przy 25 pojawia się opóźnienie, Filmy to .avi divixy lub xvidy, napisy w pliku tekstowym w systemie klatkowym (mDVD). W Windows Cinema player, best player, mplayer - wszystko jest w porządku.


(matiit) #6

a na mplayerze na linuksie?


(Trawnik) #7

Nic nie działa. Jest tylko dzwięk, który się traci po dowolnym kliknięciu myszą.


(matiit) #8

a zainstalowałeś kodeki?

sudo apt-get install w32codecs


(Pooe) #9

ewentualnie jak zainstalujesz kodeki i masz srodowisko graficzne KDE to polecam ci Kaffeine, pod gnome tez nie dziala zle, a moim zdaniem on jest najlepszy.


(Soren) #10

ejj Panowie problem nie leży w totemie jako samej aplikacji bo mi dziala ona dobrze :slight_smile: Może poprostu usuń katalog z ustawieniami totema :slight_smile:


(Trawnik) #11

MPlayer nie chce odtwarzać mi plików avi divx, pokazuje się komunikat "Fatal error! Error opening/initialing the selekted video_out (-vo) device". Nie wiem co jest grane. Nie mam doświadczenia z Ubuntu. Wcześniej używałem Mandrake 10, lecz jaku użytkownik, a nie administrator. Po modernizacji kompa próbowałem przejść na Mandrivę 2006 (mam wszystkie dyski instalacyjne), lecz zaczęły się kłopoty z monitorem (komunikaty "POZA CZĘST") i w końcu znalazłem Ubuntu. Pasuje do mnie i do moich wymagań estetyczno-technicznych. Chcę go sobie skonfigurować do moich potrzeb, i jak to na początku bywa, mam trudności.


(Soren) #12

trawnik odpal mplayer i jak wyskoczy ten komunikat kliknij ok. Potem PPM i wejdź w preferences i ustaw sterownik do obrazu np. nv + ewentualnie sprawdź czy w audio masz ustawione na alsa.


(Trawnik) #13

Dźwięk jest, lecz nie ma obrazu. W zakładce Video widać prawie same X11.

Złączono Posta : 29.10.2007 (Pon) 16:44

I napis "Configure driver" jest niedostępny. W Audio jest "dużo" ALSA, configure jest dostępne, i dźwięk działa wspaniale. Właśnie go słyszę.

Złączono Posta : 29.10.2007 (Pon) 17:09

W zakładce Video, Available drivers nie ma nic o NVidia. Moja kara w kompie to NV GeForce 6100.


(matiit) #14

w zakładce video ustaw x11

w audio alsa

I musi grać wszystko.


(Killavus) #15

Polecam Ci skompilować MPlayera - zyskasz dużo za chwilę czasu spędzonego przy komputerze - mi po skompilowaniu MPlayera odtwarza dosłownie WSZYSTKO.

Że jesteś początkujący? Spokojnie, zaraz Ci podam, co masz zrobić:

  1. Pobieramy potrzebne paczki:

    sudo aptitude install ffmpeg libgtk2.0-dev libasound2-dev libx11-dev xserver-xorg-dev libx264-dev libxvidcore4-dev

  2. Pobieramy źródła i kodeki:

    wget http://www7.mplayerhq.hu/MPlayer/releases/MPlayer-1.0rc2.tar.bz2

    wget http://www.mplayerhq.hu/MPlayer/releases/codecs/all-20071007.tar.bz2

Rozpakować umiesz, prawda? :slight_smile: 3. Wchodzimy do katalogu z kodekami, kopiujemy wszystko do /usr/lib/codecs (stwórz ten folder). Przykład jak to wygląda u mnie:

cd all-20071007

sudo mkdir /usr/lib/codecs

sudo mv * /usr/lib/codecs
  1. Wchodzimy do katalogu ze źródłami MPlayera i kompilujemy go, przy okazji instalując:

    ./configure --prefix=/usr --language=pl --codecsdir=/usr/lib/codecs --win32codecsdir=/usr/lib/codecs --enable-gui --enable-menu --enable-alsa

    make dep

    make

    sudo make install

Co do --win32codecsdir nie jestem pewien - gdyby nie działało, spróbuj --w32codecsdir. 5. Po skompilowaniu ściągamy jakikolwiek skin, przykładowo Abyss i kopiujemy go do /usr/share/mplayer/skins:

wget http://www.mplayerhq.hu/MPlayer/skins/Abyss-1.6.tar.bz2

tar jxf Abyss-1.6.tar.bz2

sudo mv Abyss /usr/share/mplayer/skins

sudo ln -s /usr/share/mplayer/skins/Abyss /usr/share/mplayer/skins/default

Pozostała jeszcze tylko czcionka napisów, wrzucamy ją do ~/.mplayer. Jako nazwę podajemy "subfont.ttf". W pliku "config" mamy nasze opcje konfiguracji, oto mój plik:

# Write your default config options here!

zoom = yes

subfont-encoding = cp1250

Pierwsza linijka odpowiada za full screen za pomocą klawisza f, druga ustawia domyślne kodowanie napisów na Windows-1250.

Sądze, że pomogłem.

Pozdrawiam

Killavus


(Trawnik) #16

Po ./configure ... otrzymałem komunikat "Error: cannot find header either inttypes.h or bitypes.h. There is no chanse for compilation to succeed. Natomiast po make dep komunikat: Brak reguł do zrobienia obiektu config.h wymaganego przez version.h. Stop. Sprawdałem czy nie popełniłem błędu przy wpisywaniu polecenia, ale nie. Pozdrowienia


(Soren) #17

Najpierw musisz uregulować wszystkie zależności i błędy związane z ./configure bo jak nie to nie masz co wykonywać make...


(Killavus) #18

Zainstaluj jeszcze biblioteki od png, jpeg, gif i:

aptitude install make gcc binutils xlibs-dev

Pozdrawiam

Killavus


(Trawnik) #19

Jeszcze raz usiłowałem to skompilować po dodaniu tych bibliotek, otrzymałem taką odpowiedź:


(matiit) #20