OS Sierra na niewspieranych urządzeniach


(WalterW) #1

Witam serdecznie, czy warto zainstalować najnowszy system od Apple na nie wspieranym urządzeniu? Mowa o Macbooku Pro z 2009 roku. Wiąże się to z jakimś brakiem sterowników, zagrożeniami itp?


(MiL-) #2

Wiąże. Ja mam Macbooka Pro z 2008 roku i pomimo że można zastosować pewne sztuczki żeby system tam zainstalować to nie będzie działała karta wifi bo nie ma do niej sterowników. Być może da się te sterowniki jakiś tam wrzucić ale nie zgłębiałem tego tematu.


(Toxic_one) #3

Przeprowadziłem test organoleptyczny na MBP late 2008. Sam sytem działa jak ElCap, nawet można po rozmawiać z siri. Nie działa WI-FI (podejrzewam że już są gdzieś kexty, żeby działało, ale nie szukałem), podświetlenie klawiatury i czujnik oświetlenia. 


(MiL-) #4

Kexty byłoby najprościej przenieść ale widziałem też opcję z wymianą karty WIFI na nowszą.

Jak instalowałeś Sierrę? Trzeba zmodyfikować instalator?


(Toxic_one) #5

Opcja z wymianą karty wydaje się bezpieczniejsza, niż grzebanie w kextach, (zawsze można coś uwalić) Do instalacji, ściągnąłem instalator z MAP, na wspieranym sprzęcie. Użyłem MacOS sierra patcher. Który robi bootpendrive z sierra, a poźniej wybierasz model sprzętu na jakim chcesz odpalić i program patch’uje instalkę. Cała operacja w raz z instalacją zajęła mi ok 40 minut. 

Tak sobie myślę po mich przygodach z zasilaczem, że to jest Apple i tego się nie zrozumie i podejrzewam że ciężko będzie znaleść "kompatybilną’ kartę wi-fi. No ale nic będę przeprowadzał eksperymenty i jak się uda to napiszę :wink:


(MiL-) #6

Musiałaby to być karta z jakiegoś nowszego MacBooka. Widziałem jak ktoś wymieniał w białym MacBooku używając przejściówki i to działało ale nie wiem jak by było z MacBookiem Pro.


(Toxic_one) #7

Ze “zwykłego” lapka też może być, pod warunkiem że będzie kompatybilna z macOS. Aczkolwiek to jest Apple…

Procedura instalacji, i wykaz wspieranych kart wi fi http://dosdude1.com/sierrapatch.html


(Boguslav4) #8

Dopisuje się do tego tematu, bo mam w sumie podobny problem. Chciałbym kupić używanego maca, ale na tyle nowego, by bez problemu był w nim najnowszy system i nie było problemów z driverami. Sprawdziłem i wychodzi, ze model Macbook 6.1 się na da, ale jako osoba która się nie zna aż tak na ekosystemie Appla wole się upewnić.


(Toxic_one) #9

@mhr_boguslav NIe patrz na model tylko na rocznik produkcji komputera, 

W macach nie ma “driverów” Mac OS jest pisany pod konkretne modele, i system ma już w sobie odpowiednie Kexty. 

MacOS Sierra jest kompatybilny z 

Od 2010 roku w górę    Od 2009 w górę 

MacBook Air                  MacBook        

MacBook Pro                 iMac

Mac Mini 

Mac Pro

Odradzam kombinowanie z instalką Sierry nie wspieranych sprzętach. Ani kupowaniu jakiś składanych MacBooków z allegro. Jak i radził bym celować w roczniki 2014-2015, nie są to tanie sprzęty, ale posłużą dłużej niż rocznik 2010. 


#10

Ja powiem tak, po 24 godzinach wróciłem do OS X El Capitan, i do wersji Sierra nie zamierzam wracać. Nowy system nie wnosi nic rewelacyjnego by z niego korzystać, skoro poprzedni świetnie daje radę. Lecenie za numerkami nie ma sensu.


(Toxic_one) #11

@krisp Też z chęcią przesiadł bym się na ElCap. Ale na moim głównym MBP którego używam do pracy, mogę tylko na Sierra działać.

Co ciekawe. ElCap na MBP z 2008 z core2duo 2,5 ghz, 4 gb ram i ssd, śmiga tak samo wydajnie jak Sierra na MBP z tego roku w najwyższej konfiguracji. Nawet jak bawiłem się Sierrą na tym MBP z 2008 roku, to też nie było jakiś wyraźnych różnić w wydajności.