[outlook.com] Inna czcionka polskich znaków


(Rishikbp) #1

Nie wiedziałem gdzie o tym napisać, więc wybrałem Webmastering (myślę, że osoby tu zaglądające najbardziej nadają się do wytłumaczenia tego zjawiska :wink:)

Otóż od samego początku mam problem z nowym wyglądem poczty od Microsoft'u. Jak widać na załączonym poniżej obrazku wszystkie znaki oprócz polskich są pogrubione. Próbowałem znaleźć wytłumaczenie szukając w sieci, jednak jak dotąd nie doczekałem się, aby ktokolwiek to zgłosił. Sprawa wygląda o tyle dziwnie, że czasami zaraz po załadowaniu strony wszystkie znaki są takie same, ale już za chwilę pogrubia te niepolskie.

Testowałem na przeglądarkach: Chrome (21.0.1180.83), Firefox (najnowszy), Opera (najnowsza beta) - wszędzie to samo. System operacyjny: Windows XP Professional + SP 2. Pod IE 6 testowałem - ale strona jest całkowicie rozkrzaczona, więc ciężko ocenić poprawność jej działania. :slight_smile:

Czy ktoś ma/miał podobny problem? Jak go rozwiązać?

scaled.php?server=171&filename=outlookczcionka.jpg&res=landing

Wiem, że niektórym działa poprawnie, bo widziałem polskie artykuły w sieci, w których były zamieszczone zrzuty ekranu. Dlatego pytam, czy ktoś kto miał taki problem wie jak go rozwiązać?


(manieKMP) #2

Możliwe, że ms zastosował fonty bez naszych znaków diakrytycznych (w css'ie określane przez font-family), albo u Ciebie w systemie brak jest odpowiedniego fontu... (nie sprawdzę tego, nie mam konta)


(rgabrysiak) #3

Jak wspomniał wyżej @manieKMP problem leży albo po stronie twojego systemu albo przegladarek z których korzystasz.

Czy sprawdzałeś jak działa Outlook pod IE? Pytam ponieważ u mnie (system Windows 7 + przeglądarka IE9) wszystko działa poprawnie.

image.php?album_id=20&image_id=4972


(Rishikbp) #4

@System operacyjny: Windows XP Professional + SP 2. Pod IE 6 testowałem - ale strona jest całkowicie rozkrzaczona, więc ciężko ocenić poprawność jej działania.

Właśnie o to mi chodzi: u mnie to nie polskie znaki są za chude, tylko reszta znaków jest za gruba..


(rgabrysiak) #5

Zaktualizuj IE do najnowszej wersji jaka jest dostępna dla XP czyli 8. Nawet jeśli na codzień nie korzystasz z przeglądarki Microsoftu.

To samo tyczy się systemu z którego korzystasz, nie warto zaktualizować go do SP3?


(Rishikbp) #6

W IE8 czcionka wyświetla się poprawnie, jednak to nie rozwiązuje problemu..


(km_00618) #7

U mnie na XP sp3 na Chrome i IE8 występuje to samo ale to jest tylko estetyka a nie problem.


(Grzegorz Olszewski) #8

W Firefoksie pod Ubuntu też źle się wyświetla, ale to jest problem Microsoftu że zrobił taką stronę


(manieKMP) #9

Na moje oko problem leży albo w braku określonego w css'ie fontu, albo jego nieaktualnej wersji, w której to brak polskich znaków powoduje ich automatyczną podmianę na domyślne...

Przykład fontu bez "dorobionej" polszczyzny:

Bez_tytu%C5%82u2_jpg_300x300_q85.jpg

A co do możliwego rozwiązania, jeśli SP3 odpada (choć nie wiem czy tą część aktualizuje) to odpaliłbym chociażby dragonfly w Operze, podświetliłbym któryś z elementów tekstowych i sprawdziłbym jakie fonty są wpisane w font-family. Następnie poszukałbym czy są one w systemie zainstalowane i aktualne.

PS. Zabawa wygładzaniem czcionek raczej nie wiele da... a i ms nie jest raczej skory do wspierania XP (fontów mu nie dadzą i zastosują takie, których w nim nie ma :wink:)

PPS. Sprawdź czy masz w systemie zainstalowany font Segoe/Segoe UI , bo z tego co wiem ms jego "wszędzie używa" ostatnimi czasy, a w XP jest on instalowany wyłącznie gdy użytkownik zainstaluje sobie Windows Live Messenger lub Windows Live Mail, chyba że instalowałeś Office (od 2007 wzwyż).


(Rishikbp) #10

Mógłbyś podesłać tę czcionki w polskiej wersji?


(R@z0r) #11

Sama strona zrobiona jest bardzo starannie no może za dużo elementów blokowych się zagnieżdża. Na linuxach może brakować jakiegoś repo, ale sama czcionka ma jak najbardziej wsparcie dla wszystkich języków europejskich.


(Rishikbp) #12

Pokombinowałem i udało się osiągnąć taki efekt:

outlookCzcionka.jpg

Jest jeszcze tylko jedno pytanie - czy istnieje możliwość, żeby czcionka ta nie była pogrubiona? Mimo wszystko lepiej wygląda, jak jest chuda.


(manieKMP) #13

Być może font-weight ("bold" zamiast np. "normal") zastosowano dla tych elementów.


(Rishikbp) #14

No właśnie nie bardzo - ona jest tak jakby domyślnie lekko pulchna (bo można ją jeszcze bardziej pogrubić). Tak jak już wcześniej pisałem - czasami zdarza się, że zaraz po załadowaniu strony jest ok (tzn. czcionka chuda i przejrzysta), ale zaraz później się zmienia (tak jakby dochodzi do niej 1px) i już nie jest fajnie.

Myślę jednak, że nic na to nie poradzę. Dobrze przynajmniej, że wyświetla mi już wszystkie znaki jednolicie - błąd leży (chyba) po stronie strony (bo nie przewiduje narzucenia czcionki obcokrajowcom - narzuca tylko podstawowy [angielski] alfabet).


(R@z0r) #15

No to daj font-weight: 300 albo lighter.


(Rishikbp) #16

Zmiana grubości czcionki nic nie daje. Prawdopodobnie pomogłoby użycie czcionki "Segoe UI Light", jednak w jaki sposób wprowadzić te zmiany na stałe na danej stronie (w tym przypadku outlook.com)?


(manieKMP) #17

W Fx i GC możesz posłużyć się dodatkiem Stylish. W Fx inną metodą jest też plik userContent.css, w który wpisujesz co i jak chcesz zmienić na danej stronie, przykładowo:

Dla O tworzysz plik css z odpowiednimi "informacjami" (bez "okalania" przez @-moz-document , nie jest potrzebne...), w przeglądarce przechodzisz na stronę i PPM, z menu wybierasz "Preferencje dla witryny...", potem karta "Wyświetlanie" i określasz "Mój arkusz stylów" podając ścieżkę prowadzącą do stworzonego css'a.