[PHP] instalacja interpretera php


(Smerfetka17 1980) #1

jestem poczatkujaca w phpie, kupilam "programowanie w php" z biblioteczki komputer swiata. Schody zaczely sie przy instalacji interpretera php. Zgodnie z instrukcja wszystko zainstalowalam, pozmienialam pliki conf, zrestartowalam apache'a, ale kiedy probuje wyswietlic testowy plik index.php przez localhost, to wyswietla mi sie info:

Forbidden

You don't have permission to access / on this server.

Apache/2.0.55 (Win32) PHP/5.1.4 Server at localhost Port 80

?


(GioWDS) #2

Użyj WebServ’a.


(mozilla007) #3

Albo przenośnej wersji USB WebServer.

http://www.usbwebserver.net/en/download.php

Najlepiej działa wersja 8.


(bolivar) #4

Coś już blokuje port 80. Możliwe, że wcześniej instalowałeś inny serwer www. Sprawdź co nadaje na tym porcie i wyłącz ten service.


(Smerfetka17 1980) #5

dzieki za pomoc, nie, nie instalowalam innego serwera www. Gdzie moge sprawdzic, co nadaje na porcie 80?


(Drobok) #6

Wpisz w url przeglądarki

127.0.0.1

Większość softu wyświetli ci info, że używa portu. Ew start uruchom cmd i wpisz:

netstat -a

(bolivar) #7

Start -> wpisać CMD -> netstat -ano

Będziesz miał PIDy i możesz po nich sprawdzić jaki proces tam siedzi.

Czasem może to być jakieś proxy lub nawet skype :wink:


(Smerfetka17 1980) #8

zrobilam tak Start -> wpisać CMD -> netstat -ano i wyszly mi nastepujace porty (przy wylaczonym apache’u):

image_id: 4991

na porcie 80 mam cos o pidzie 1380

?

zmienilam w pliku httpd.conf 80 na 2222 ale po wpisaniu do przegladarki localhost pojawia sie info:

Nie udało się nawiązać połączenia

Firefox nie może nawiązać połączenia z serwerem localhost.

Witryna może być tymczasowo niedostępna lub zbyt obciążona. Spróbuj ponownie za kilka minut.

Jeśli nie można otworzyć żadnej strony, należy sprawdzić swoje połączenie sieciowe.

Jeśli ten komputer jest chroniony przez zaporę sieciową lub serwer proxy, należy sprawdzić, czy program Firefox jest uprawniony do łączenia się z Internetem.

a po wpisaniu do przegladarki http://127.0.0.1:2222/

Forbidden

You don’t have permission to access / on this server.

Apache/2.0.55 (Win32) PHP/5.1.4 Server at 127.0.0.1 Port 2222

Dodane 27.08.2012 (Pn) 23:17

juz chyba wiem, znalazlam programik, ktory pokazuje nazwy procesow. Wyglada na to, ze na porcie 80 siedzi mi avasta.

image_id: 4992

co teraz?


(mktos) #9

Ajaj. Kolega bolivar wprowadził w błąd, i to znaczny.

Skoro po wejściu na 127.0.0.1 pojawia się komunikat

to dość dobrze. To jest - jak widać - komunikat pochodzący od Apache. Po zmianie portu na 2222 komunikat jest dokładnie taki sam, prawda? Więc to wina Apache, a nie czegoś, co blokuje port 80.

Nic nie blokuje portu 80 - przecież widać na screenie, że Avast podłączony jest do Remote Port 80, czyli łączy się gdzieś tam z jakimś serwerem na jego porcie 80.

Wróć w httpd.conf do Listen 80.

W httpd.conf powinnaś tez mieć deklarację DocumentRoot, czyli katalogu, skąd Apache bierze pliki.

Jeżeli twój plik testowy nazywa się index.php, spróbuj go umieścić w swoim DocumentRoot, a potem odwiedzić znów http://127.0.0.1. Jeśli nie zadziała… to może zadziała http://127.0.0.1/index.php? Jeśli tak, to jesteś prawie w domu - należy tylko ustawić, aby index.php również był traktowany jako domyślny plik katalogu, w httpd.conf szukając DocumentIndex i dopisując tam na końcu index.php.

Obstawiam, że źle ustawiona jest jakaś ścieżka dostępu. Błąd, jaki się pojawia, to klasyczny błąd 403, który często się pojawia, jeśli w katalogu nie ma dokumentu domyślnego i wyłączone jest listowanie plików.

Poza tym, twój Apache powinien stworzyć gdzieś plik error_log, gdzie są opisane błędy - przejrzenie tych błędów pomoże znaleźć rozwiązanie, jeśli to powyżej nie zadziała.

I tak, użycie XAMPP-a na przykład było by łatwiejsze.


(bolivar) #10

Masz rację - moja pomyłka.

http://forum.php.pl/index.php?showtopic=50777


(Smerfetka17 1980) #11

oki doki dziala :smiley: dzieeeeeeeeeeki za pomoc! !!

plik

?php

echo('Dziś jest: '. date(“d.m.Y H:i:s”));

?

wyswietlil sie jako

Dzi? jest: 28.08.2012 22:57:03

Rozwiazanie banalne: po sprawdzeniu wszystkich sciezek, spojrzalam na folder z plikiem php. I tu najlepsze: plik php, ktory utworzylam w notatniku, mial podwojne rozszerzenie index.php.txt. Po wykasowaniu txt i wpisaniu localhosta dziala. Tak wiec trzeba zawsze sprawdzac w kolumnie typ pliku, czy to jest plik php czy txt, dobrze tez odznaczyc opcje “Ukryj rozszerzenia znanych plikow”. A przy zapisywaniu pliku w notatniku, wybrac opcje zapisz jako “wszystkie typy plikow”

Mam jeszcze kilka pytan:

dlaczego nie wyswietlaja sie polskie znaki? ale juz niemieckie umlauty tak…

nie udaje mi sie zrestartowac apache’a, w Apache Service Monitorze jeszcze wczoraj przy restarcie pojawialy sie informacje The Apache server is restarting The Apache server has restarted. gdzie znow zle kliknelam?

Listowanie plikow - w pliku httpd.conf mam zapis bez “indexes” dopisac, zeby juz wszystko bylo ok?

Options FollowSymLinks Indexes

AllowOverride None


(mktos) #12

Polskie znaki są zależne od kodowania pliku. Znasz HTML? Chodzi o znacznik

(wersja skrócona, HTML5). Jeśli używasz Notatnika to przy zapisie możesz wybrać kodowanie UTF-8 swojego pliku, wtedy, jeśli ten znacznik będzie przed twoim tekstem, przeglądarka zrozumie, że wysyłasz tekst zakodowany w UTF-8 i wyświetli polskie znaki poprawnie.

Ogólnie - nie męcz się z Notatnikiem, zainstaluj Notepad++ lub coś podobnego, które o wiele lepiej obsługują nie tylko UTF-8, ale i w ogóle się w nich lepiej pisze.


(cinkibolek) #13

Port 80 może blokować Skype. To tak dla potomnych.